summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorcoutinho <coutinho@esrf.fr>2014-01-21 17:02:45 +0100
committercoutinho <coutinho@esrf.fr>2014-01-21 17:02:45 +0100
commit0492ce6ea1b59e72431cc1db5109f8a47bbf7969 (patch)
treeaf48aafd688dcd3f80f62d2bdadab5e331c917eb /setup.py
parent4b55ab1039858013ba5ec2d5016a050bd4beba3e (diff)
First version with taurus separated from sardana
Diffstat (limited to 'setup.py')
-rwxr-xr-x[-rw-r--r--]setup.py30
1 files changed, 23 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 48462c7c..1b39d523 100644..100755
--- a/setup.py
+++ b/setup.py
@@ -105,8 +105,10 @@ class install_man(Command):
man_pages = []
for f in man_elems:
f = os.path.join(src_man_dir, f)
- if not os.path.isfile(f): continue
- if not f.endswith(".1"): continue
+ if not os.path.isfile(f):
+ continue
+ if not f.endswith(".1"):
+ continue
man_pages.append(f)
install_dir = os.path.join(self.install_dir, 'man1')
@@ -145,15 +147,15 @@ class install_scripts(dftinstall_scripts):
See rationale in:
http://matthew-brett.github.io/pydagogue/installing_scripts.html
'''
-
+
user_options = list(dftinstall_scripts.user_options)
user_options.extend(
[
('wrappers', None, 'Install .bat wrappers for windows (enabled by default on windows)'),
('ignore-shebang', None, 'Use "python" as the interpreter in .bat wrappers (instead of using the interpreter found in the shebang line of the scripts). Note: this only affects to windows .bat wrappers!'),
])
-
-
+
+
BAT_TEMPLATE_SHEBANG = \
r"""@echo off
REM wrapper to use shebang first line of {FNAME}
@@ -180,7 +182,7 @@ call %py_exe% %pyscript% %*
self.ignore_shebang = None
self.wrappers = (os.name == "nt")
dftinstall_scripts.initialize_options(self)
-
+
def run(self):
dftinstall_scripts.run(self)
if self.wrappers:
@@ -293,7 +295,9 @@ def main():
author = Release.authors['Tiago']
maintainer = Release.authors['Pascual-Izarra']
- package_dir = {'sardana': abspath('src', 'sardana')}
+ package_dir = {
+ 'sardana': abspath('src', 'sardana'),
+ }
packages = [
'sardana',
@@ -318,6 +322,18 @@ def main():
'sardana.spock',
'sardana.spock.ipython_00_10',
'sardana.spock.ipython_00_11',
+
+ 'sardana.taurus.core.tango.sardana',
+ 'sardana.taurus.qt.qtcore.tango.sardana',
+ 'sardana.taurus.qt.qtgui.extra_macroexecutor',
+ 'sardana.taurus.qt.qtgui.extra_macroexecutor.favouriteseditor',
+ 'sardana.taurus.qt.qtgui.extra_macroexecutor.macroparameterseditor',
+ 'sardana.taurus.qt.qtgui.extra_macroexecutor.macroparameterseditor.customeditors',
+ 'sardana.taurus.qt.qtgui.extra_macroexecutor.sequenceeditor',
+
+ 'sardana.taurus.qt.qtgui.extra_sardana',
+ 'sardana.taurus.qt.qtgui.extra_sardana.ui',
+ 'sardana.taurus.qt.qtgui.extra_pool',
]
provides = [