summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorzreszela <zreszela@cells.es>2017-06-28 13:00:32 +0200
committerzreszela <zreszela@cells.es>2017-06-28 13:00:32 +0200
commit1288b4e716dfd16f3bca6511d98fe0314e81eb3c (patch)
tree9ee007debc6d384fa4917444df83322175506e14 /setup.py
parent54e1088352da763d84de523ea924dad31daf6960 (diff)
Fix dependency version specifiers
Some older versionos of setuptools does not recognize version specifiers within parentheses. Change it to a format compatible with all versions. Remove conditional dependency of ordereddict becasuse it is only available in the very new versions of setuptools (see: https://hynek.me/articles/conditional-python-dependencies/). This means that ordereddict won't be installed with pip for Python 2.6.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 4 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index bac978a6..52a7d6fa 100644
--- a/setup.py
+++ b/setup.py
@@ -62,11 +62,10 @@ requires = [
]
install_requires = [
- 'PyTango (>=7.2.3)',
- 'itango (>=0.0.1)',
- 'taurus (>= 3.6.0)',
- 'lxml (>=2.1)',
- 'ordereddict;python_version<"2.7"'
+ 'PyTango>=7.2.3',
+ 'itango>=0.0.1',
+ 'taurus>=3.6.0',
+ 'lxml>=2.1'
]