summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTuomas Virtanen <katajakasa@gmail.com>2017-09-13 11:09:33 +0300
committerGitHub <noreply@github.com>2017-09-13 11:09:33 +0300
commitbf1d1e30ac4062a2f764193a865761161ec7fc6b (patch)
tree517572a8c044d1f001028e0e2ae9859e5353323b
parent3235ac16899da92ecc554c0d3eae3cdb071d94be (diff)
parentec27746ce8d7faa2073fb939e72f1f4f51332472 (diff)
Merge pull request #26 from OdyX/cmake-install-dirs
Use CMAKE_INSTALL targets
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a9eca76..14e4e3b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -79,10 +79,11 @@ if(BUILD_EXAMPLES)
endif()
# Installation
+include(GNUInstallDirs)
INSTALL(FILES ${HEADERS} DESTINATION include/kitchensink/)
INSTALL(TARGETS SDL_kitchensink SDL_kitchensink_static
- RUNTIME DESTINATION bin
- LIBRARY DESTINATION lib
- ARCHIVE DESTINATION lib
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
)