summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTuomas Virtanen <katajakasa@gmail.com>2018-07-01 21:50:06 +0300
committerTuomas Virtanen <katajakasa@gmail.com>2018-07-01 21:50:06 +0300
commit6d30b5ed4a555875f504d13ebb362205fbbf056f (patch)
tree57b682543f4e4f770ecb4a58ad88ebac7d5319d1 /CMakeLists.txt
parent406491cf0378a02d0188e2d3c92518d571db82f1 (diff)
Source cleanups + RWOps
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2fbfdb3..cd47a37 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -90,23 +90,27 @@ if(BUILD_EXAMPLES)
add_executable(complex examples/example_complex.c)
add_executable(simple examples/example_simple.c)
add_executable(custom examples/example_custom.c)
+ add_executable(rwops examples/example_rwops.c)
if(MINGW)
target_link_libraries(audio mingw32)
target_link_libraries(complex mingw32)
target_link_libraries(simple mingw32)
target_link_libraries(custom mingw32)
+ target_link_libraries(rwops mingw32)
endif()
set_property(TARGET audio PROPERTY C_STANDARD 99)
set_property(TARGET complex PROPERTY C_STANDARD 99)
set_property(TARGET simple PROPERTY C_STANDARD 99)
set_property(TARGET custom PROPERTY C_STANDARD 99)
+ set_property(TARGET rwops PROPERTY C_STANDARD 99)
target_link_libraries(audio SDL_kitchensink_static ${LIBRARIES})
target_link_libraries(complex SDL_kitchensink_static ${LIBRARIES})
target_link_libraries(simple SDL_kitchensink_static ${LIBRARIES})
target_link_libraries(custom SDL_kitchensink_static ${LIBRARIES})
+ target_link_libraries(rwops SDL_kitchensink_static ${LIBRARIES})
endif()
# documentation target