summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJohannes 'josch' Schauer <josch@debian.org>2020-07-15 19:41:51 +0200
committerJohannes 'josch' Schauer <josch@debian.org>2020-07-15 19:41:51 +0200
commit254d823b1eedafaaf949f24da11546cd07f867bb (patch)
treee68fc5870e77bfcd61f879c0fa6c609227390541 /debian
parentb245a65db0ce0d230b466e81c206c87723d7efc1 (diff)
add patch to parse README.md with encoding
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/encoding11
-rw-r--r--debian/patches/series1
2 files changed, 12 insertions, 0 deletions
diff --git a/debian/patches/encoding b/debian/patches/encoding
new file mode 100644
index 0000000..0b80694
--- /dev/null
+++ b/debian/patches/encoding
@@ -0,0 +1,11 @@
+--- a/setup.py
++++ b/setup.py
+@@ -12,7 +12,7 @@ sys.path.insert(0, './searx')
+ from version import VERSION_STRING
+ import brand
+
+-with open('README.rst') as f:
++with open('README.rst', encoding='utf-8') as f:
+ long_description = f.read()
+
+ with open('requirements.txt') as f:
diff --git a/debian/patches/series b/debian/patches/series
index 0569fd8..9dfcba9 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,3 +3,4 @@ clean-gruntfiles
settingsyml
setuppy
makefile
+encoding