summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJohannes Schauer Marin Rodrigues <josch@debian.org>2021-12-07 12:21:48 +0100
committerJohannes Schauer Marin Rodrigues <josch@debian.org>2021-12-07 16:28:55 +0100
commit64a34a85533e8fd57841dac78b114903d0f98ed6 (patch)
treeda238f992bc6c7df16265564de7f5ac9f7f2b8de /debian
parent0ccb32fcff2fe6f4534f69c6a7f5981d3716f228 (diff)
Rework patches for 1.0 release
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/clean-gruntfiles46
-rw-r--r--debian/patches/makefile14
-rw-r--r--debian/patches/series5
-rw-r--r--debian/patches/settingsyml2
-rw-r--r--debian/patches/setuppy2
5 files changed, 34 insertions, 35 deletions
diff --git a/debian/patches/clean-gruntfiles b/debian/patches/clean-gruntfiles
index 5453ae9..8db91f9 100644
--- a/debian/patches/clean-gruntfiles
+++ b/debian/patches/clean-gruntfiles
@@ -1,25 +1,33 @@
--- a/searx/static/themes/oscar/gruntfile.js
+++ b/searx/static/themes/oscar/gruntfile.js
-@@ -80,16 +80,9 @@ module.exports = function(grunt) {
+@@ -103,9 +103,6 @@ module.exports = function(grunt) {
+ production: {
+ options: {
+ paths: ["src/less/pointhi", "src/less/logicodev", "src/less/logicodev-dark", "src/less/bootstrap"],
+- plugins: [
+- new (require('less-plugin-clean-css'))()
+- ],
+ sourceMap: true,
+ sourceMapURL: (name) => { const s = name.split('/'); return s[s.length - 1] + '.map';},
+ outputSourceFiles: false,
+@@ -136,16 +133,12 @@ module.exports = function(grunt) {
}
});
-- grunt.loadNpmTasks('grunt-contrib-uglify');
+- grunt.loadNpmTasks('grunt-contrib-copy');
+ grunt.loadNpmTasks('grunt-contrib-uglify');
- grunt.loadNpmTasks('grunt-contrib-jshint');
- grunt.loadNpmTasks('grunt-contrib-watch');
-- grunt.loadNpmTasks('grunt-contrib-concat');
+ grunt.loadNpmTasks('grunt-contrib-concat');
- grunt.loadNpmTasks('grunt-contrib-less');
-+ grunt.loadNpmTasks('grunt-contrib-uglify', '/usr/lib/nodejs');
-+ grunt.loadNpmTasks('grunt-contrib-concat', '/usr/lib/nodejs');
-
-- grunt.registerTask('test', ['jshint']);
--
-- grunt.registerTask('default', ['jshint', 'concat', 'uglify', 'less']);
--
-- grunt.registerTask('styles', ['less']);
+
+ grunt.registerTask('test', ['jshint']);
+
+- grunt.registerTask('default', ['copy', 'jshint', 'concat', 'uglify', 'less']);
+ grunt.registerTask('default', ['concat', 'uglify']);
- };
+ grunt.registerTask('styles', ['less']);
+
--- a/searx/static/themes/simple/gruntfile.js
+++ b/searx/static/themes/simple/gruntfile.js
@@ -67,12 +67,6 @@ module.exports = function(grunt) {
@@ -35,22 +43,20 @@
banner: '/*! searx | <%= grunt.template.today("dd-mm-yyyy") %> | <%= process.env.GIT_URL %> */\n'
},
files: {
-@@ -147,15 +141,8 @@ module.exports = function(grunt) {
+@@ -147,15 +141,11 @@ module.exports = function(grunt) {
}
});
- grunt.loadNpmTasks('grunt-contrib-watch');
-- grunt.loadNpmTasks('grunt-contrib-uglify');
+ grunt.loadNpmTasks('grunt-contrib-uglify');
- grunt.loadNpmTasks('grunt-contrib-jshint');
-- grunt.loadNpmTasks('grunt-contrib-concat');
+ grunt.loadNpmTasks('grunt-contrib-concat');
- grunt.loadNpmTasks('grunt-contrib-less');
-- grunt.loadNpmTasks('grunt-contrib-cssmin');
+ grunt.loadNpmTasks('grunt-contrib-cssmin');
- grunt.loadNpmTasks('grunt-webfont');
-+ grunt.loadNpmTasks('grunt-contrib-uglify', '/usr/lib/nodejs');
-+ grunt.loadNpmTasks('grunt-contrib-concat', '/usr/lib/nodejs');
-- grunt.registerTask('test', ['jshint']);
--
+ grunt.registerTask('test', ['jshint']);
+
- grunt.registerTask('default', ['jshint', 'concat', 'uglify', 'less:development', 'less:production']);
+ grunt.registerTask('default', ['concat', 'uglify']);
};
diff --git a/debian/patches/makefile b/debian/patches/makefile
index 034fbd4..971d9cd 100644
--- a/debian/patches/makefile
+++ b/debian/patches/makefile
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -137,7 +137,6 @@ buildenv:
+@@ -110,7 +110,6 @@ buildenv: pyenv
# ----------
node.env: buildenv
@@ -8,8 +8,8 @@
node.clean:
$(Q)echo "CLEAN locally installed npm dependencies"
-@@ -156,20 +155,23 @@ PHONY += themes.bootstrap themes themes.
- themes: buildenv themes.bootstrap themes.oscar themes.simple themes.legacy themes.courgette themes.pixart
+@@ -129,20 +128,23 @@ PHONY += themes themes.oscar themes.simp
+ themes: buildenv themes.oscar themes.simple
quiet_cmd_lessc = LESSC $3
- cmd_lessc = PATH="$$(npm bin):$$PATH" \
@@ -34,13 +34,5 @@
+ $(call cmd,lessc,themes/simple/less/style-rtl.less,themes/simple/css/style-rtl.min.css)
+ $(call cmd,lessc,themes/simple/less/style.less,themes/simple/css/style.min.css)
- themes.legacy: node.env
- $(Q)echo '[!] build legacy theme'
-@@ -186,7 +188,6 @@ themes.pixart: node.env
- $(call cmd,lessc,themes/pix-art/less/style.less,themes/pix-art/css/style.css)
-
- themes.bootstrap: node.env
-- $(call cmd,lessc,less/bootstrap/bootstrap.less,css/bootstrap.min.css)
-
# docker
diff --git a/debian/patches/series b/debian/patches/series
index 0569fd8..9eb7e29 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,5 +1,6 @@
beautifyjs
-clean-gruntfiles
+#clean-gruntfiles
settingsyml
setuppy
-makefile
+#makefile
+clean-gruntfiles
diff --git a/debian/patches/settingsyml b/debian/patches/settingsyml
index 5603a33..f327947 100644
--- a/debian/patches/settingsyml
+++ b/debian/patches/settingsyml
@@ -1,6 +1,6 @@
--- a/searx/settings.yml
+++ b/searx/settings.yml
-@@ -25,8 +25,8 @@ server:
+@@ -35,8 +35,8 @@ server:
Referrer-Policy : no-referrer
ui:
diff --git a/debian/patches/setuppy b/debian/patches/setuppy
index 29f764e..01c934d 100644
--- a/debian/patches/setuppy
+++ b/debian/patches/setuppy
@@ -1,6 +1,6 @@
--- a/setup.py
+++ b/setup.py
-@@ -56,23 +56,9 @@ setup(
+@@ -55,23 +55,9 @@ setup(
},
package_data={
'searx': [