summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJohannes Schauer Marin Rodrigues <josch@debian.org>2023-08-14 13:39:27 +0200
committerJohannes Schauer Marin Rodrigues <josch@debian.org>2023-08-14 13:39:27 +0200
commit8660cfe1d6fa12303b63ea6530d595ad4a6237ae (patch)
tree6c2d5150dd8cbe9fd1616008914c5dd6dbf06f42 /debian
parentec96e1c156b191d7974a18ff052f2344f6e3cbb3 (diff)
debian/rules: fix clean target so that 'dpkg-buildpackage -S' works after building it once (closes: #1045245)
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index b978297..c3dabc9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,3 +27,23 @@ override_dh_auto_build:
# do not run tests because the splinter python3 module is not packaged yet
override_dh_auto_test:
+
+execute_after_dh_auto_clean:
+ rm -f debian/ionicons/ion.ttf debian/ionicons/ion.woff searx/data/bangs.json
+ for p in themes/oscar/src/less/pointhi/variables.less \
+ css/logicodev-dark.min.css \
+ css/logicodev.min.css \
+ css/pointhi.min.css \
+ css/searx-rtl.min.css \
+ css/searx.min.css \
+ themes/oscar/js/searx.js \
+ themes/oscar/js/searx.min.js \
+ themes/oscar/js/searx.min.js.map \
+ themes/simple/js/searx.head.min.js \
+ themes/simple/js/searx.head.min.js.map \
+ themes/simple/js/searx.js \
+ themes/simple/js/searx.min.js \
+ themes/simple/js/searx.min.js.map \
+ themes/simple/less/ion.less; do \
+ rm -f "searx/static/$$p"; \
+ done