summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJohannes 'josch' Schauer <josch@debian.org>2020-07-14 19:41:47 +0200
committerJohannes 'josch' Schauer <josch@debian.org>2020-07-14 19:59:37 +0200
commitcb4e36cbea9c1fdcb772775a28d9171fe549ada5 (patch)
treed77d9e442a911bbb41c950d9e86ed4f56efa9bae /debian
parent1683bd821a00bdc96d113b8143431b523a1a20b8 (diff)
debian/patches/makefile: disable npm and bootstrap build and build css
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/makefile31
1 files changed, 30 insertions, 1 deletions
diff --git a/debian/patches/makefile b/debian/patches/makefile
index 1c6cbf7..e3a0825 100644
--- a/debian/patches/makefile
+++ b/debian/patches/makefile
@@ -1,6 +1,14 @@
--- a/Makefile
+++ b/Makefile
-@@ -157,12 +157,10 @@ PHONY += themes.bootstrap themes themes.
+@@ -138,7 +138,6 @@ buildenv:
+ # ----------
+
+ node.env: buildenv
+- $(Q)./manage.sh npm_packages
+
+ node.clean:
+ $(Q)echo "CLEAN locally installed npm dependencies"
+@@ -157,20 +156,23 @@ PHONY += themes.bootstrap themes themes.
themes: buildenv themes.bootstrap themes.oscar themes.simple themes.legacy themes.courgette themes.pixart
quiet_cmd_lessc = LESSC $3
@@ -15,3 +23,24 @@
themes.oscar: node.env
$(Q)echo '[!] build oscar theme'
+ $(call cmd,grunt,searx/static/themes/oscar/gruntfile.js)
++ $(call cmd,lessc,themes/oscar/less/logicodev/oscar.less,themes/oscar/css/logicodev.min.css)
++ $(call cmd,lessc,themes/oscar/less/logicodev-dark/oscar.less,themes/oscar/css/logicodev-dark.min.css)
++ $(call cmd,lessc,themes/oscar/less/pointhi/oscar.less,themes/oscar/css/pointhi.min.css)
+
+ themes.simple: node.env
+ $(Q)echo '[!] build simple theme'
+ $(call cmd,grunt,searx/static/themes/simple/gruntfile.js)
++ $(call cmd,lessc,themes/simple/less/style-rtl.less,themes/simple/css/style-rtl.min.css)
++ $(call cmd,lessc,themes/simple/less/style.less,themes/simple/css/style.min.css)
+
+ themes.legacy: node.env
+ $(Q)echo '[!] build legacy theme'
+@@ -187,7 +189,6 @@ themes.pixart: node.env
+ $(call cmd,lessc,themes/pix-art/less/style.less,themes/pix-art/css/style.css)
+
+ themes.bootstrap: node.env
+- $(call cmd,lessc,less/bootstrap/bootstrap.less,css/bootstrap.min.css)
+
+
+ # docker