summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohannes 'josch' Schauer <josch@debian.org>2020-07-14 16:26:13 +0200
committerJohannes 'josch' Schauer <josch@debian.org>2020-07-14 16:26:13 +0200
commit075e7e02683d9db1b303de8e8c17ff7da4c62510 (patch)
tree72d3ed7514879810445f4309e641e29d9c57d02d /setup.py
parent61b98ca52e8d48a6ad3b4baed5feb4b38ee53804 (diff)
New upstream version 0.17.0+dfsg1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index bd3dd5d..97a3270 100644
--- a/setup.py
+++ b/setup.py
@@ -10,6 +10,7 @@ import sys
# required to load VERSION_STRING constant
sys.path.insert(0, './searx')
from version import VERSION_STRING
+import brand
with open('README.rst') as f:
long_description = f.read()
@@ -25,6 +26,11 @@ setup(
version=VERSION_STRING,
description="A privacy-respecting, hackable metasearch engine",
long_description=long_description,
+ url=brand.DOCS_URL,
+ project_urls={
+ "Code": brand.GIT_URL,
+ "Issue tracker": brand.ISSUE_URL
+ },
classifiers=[
"Development Status :: 4 - Beta",
"Programming Language :: Python",
@@ -36,7 +42,6 @@ setup(
keywords='metasearch searchengine search web http',
author='Adam Tauber',
author_email='asciimoo@gmail.com',
- url='https://github.com/asciimoo/searx',
license='GNU Affero General Public License',
packages=find_packages(exclude=["tests*"]),
zip_safe=False,