summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohannes Schauer Marin Rodrigues <josch@debian.org>2021-12-07 16:28:44 +0100
committerJohannes Schauer Marin Rodrigues <josch@debian.org>2021-12-07 16:28:44 +0100
commit32d4b6a638456caf50a5f99f2a0b57d60d418c5f (patch)
tree3ef4ebddb9d6bb6bbb46ac10663b1a714063901e /setup.py
parent7a1db4de351875bebb4a8e7ffbe6710ad5b518c5 (diff)
New upstream version 1.0.0+dfsg1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 5 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 6a78f61..61227d1 100644
--- a/setup.py
+++ b/setup.py
@@ -7,10 +7,8 @@ from setuptools import find_packages
import os
import sys
-# required to load VERSION_STRING constant
-sys.path.insert(0, './searx')
-from version import VERSION_STRING
-import brand
+from searx.version import VERSION_STRING
+from searx import brand
with open('README.rst', encoding='utf-8') as f:
long_description = f.read()
@@ -43,7 +41,7 @@ setup(
author='Adam Tauber',
author_email='asciimoo@gmail.com',
license='GNU Affero General Public License',
- packages=find_packages(exclude=["tests*"]),
+ packages=find_packages(exclude=["tests*", "searx_extra"]),
zip_safe=False,
install_requires=requirements,
extras_require={
@@ -51,7 +49,8 @@ setup(
},
entry_points={
'console_scripts': [
- 'searx-run = searx.webapp:run'
+ 'searx-run = searx.webapp:run',
+ 'searx-checker = searx.search.checker.__main__:main'
]
},
package_data={