summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 11 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 436464f..5e0d3e5 100644
--- a/setup.py
+++ b/setup.py
@@ -7,11 +7,10 @@ from setuptools import find_packages
import os
import sys
-# required to load VERSION_STRING constant
-sys.path.insert(0, './searx')
-from version import VERSION_STRING
+from searx.version import VERSION_STRING
+from searx import brand
-with open('README.rst') as f:
+with open('README.rst', encoding='utf-8') as f:
long_description = f.read()
with open('requirements.txt') as f:
@@ -25,6 +24,11 @@ setup(
version=VERSION_STRING,
description="A privacy-respecting, hackable metasearch engine",
long_description=long_description,
+ url=brand.DOCS_URL,
+ project_urls={
+ "Code": brand.GIT_URL,
+ "Issue tracker": brand.ISSUE_URL
+ },
classifiers=[
"Development Status :: 4 - Beta",
"Programming Language :: Python",
@@ -36,9 +40,8 @@ setup(
keywords='metasearch searchengine search web http',
author='Adam Tauber',
author_email='asciimoo@gmail.com',
- url='https://github.com/asciimoo/searx',
license='GNU Affero General Public License',
- packages=find_packages(exclude=["tests*"]),
+ packages=find_packages(exclude=["tests*", "searx_extra"]),
zip_safe=False,
install_requires=requirements,
extras_require={
@@ -46,7 +49,8 @@ setup(
},
entry_points={
'console_scripts': [
- 'searx-run = searx.webapp:run'
+ 'searx-run = searx.webapp:run',
+ 'searx-checker = searx.search.checker.__main__:main'
]
},
package_data={