summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorClint Adams <schizo@debian.org>2009-05-06 21:22:27 -0400
committerClint Adams <schizo@debian.org>2009-05-06 21:22:27 -0400
commit47c0ab9528ec53e5a0a6e761ba3789055e048638 (patch)
tree98fff27a1e9260ee6a8b5597e780236173b28838 /Makefile.am
parent635221dbdbbaa74dfbb1672cb802d136f8208a1f (diff)
Imported Upstream version 4.2
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am53
1 files changed, 34 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index a6ecc04..c1e6a29 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,18 +1,18 @@
## Process this file with automake to produce Makefile.in
# Automake requirements
-AUTOMAKE_OPTIONS = gnits 1.8
-ACLOCAL_AMFLAGS = -I config
+AUTOMAKE_OPTIONS = gnits 1.10 dist-bzip2
+ACLOCAL_AMFLAGS = -I m4
PACKAGE = sed
-SUBDIRS = intl lib po sed doc testsuite
+SUBDIRS = lib po sed doc testsuite
noinst_DATA = bootstrap.sh
noinst_HEADERS = basicdefs.h
-EXTRA_DIST = BUGS THANKS COPYING.DOC README.boot bootstrap.sh \
- config/texi2dvi config/help2man
+EXTRA_DIST = BUGS THANKS COPYING.DOC README.boot \
+ autoboot build-aux/texi2dvi build-aux/help2man
html:
cd doc && make html
@@ -20,23 +20,38 @@ html:
DISTCHECK_CONFIGURE_FLAGS = XGETTEXT='$(SHELL) -c : dummy' $(EXTRA_DC_FLAGS)
EXTRA_DC_FLAGS =
+dist-hook:
+ cmp bootstrap.sh $(srcdir)/bootstrap.sh > /dev/null 2>&1 || \
+ cp -p bootstrap.sh $(srcdir)/bootstrap.sh
+ cp -p $(srcdir)/bootstrap.sh $(distdir)/bootstrap.sh
+
full-distcheck:
+ make distcheck EXTRA_DC_FLAGS='--enable-regex-tests'
make distcheck EXTRA_DC_FLAGS='--enable-html'
make distcheck EXTRA_DC_FLAGS='--disable-i18n'
make distcheck EXTRA_DC_FLAGS='--disable-nls'
- make distcheck EXTRA_DC_FLAGS='--without-included-regex'
make distcheck EXTRA_DC_FLAGS='--without-included-gettext'
+ @case "$(host)" in \
+ *-linux*|*-gnu*) \
+ echo make distcheck EXTRA_DC_FLAGS=\'--without-included-regex\'; \
+ make distcheck EXTRA_DC_FLAGS='--without-included-regex' \
+ ;; \
+ *) \
+ echo Skipping check --without-included-regex \
+ ;; \
+ esac
+
+## update-regex:
+## HOST=sources.redhat.com && \
+## BASEURL="http://$$HOST/cgi-bin/cvsweb.cgi/~checkout~/libc/posix" && \
+## QUERY='cvsroot=glibc&content-type=text/plain' && \
+## wget -O lib/regcomp.c "$$BASEURL/regcomp.c?$$QUERY" && \
+## wget -O lib/regexec.c "$$BASEURL/regexec.c?$$QUERY" && \
+## wget -O lib/regex.c "$$BASEURL/regex.c?$$QUERY" && \
+## wget -O lib/regex_.h "$$BASEURL/regex.h?$$QUERY" && \
+## wget -O lib/regex_internal.c "$$BASEURL/regex_internal.c?$$QUERY" && \
+## wget -O lib/regex_internal.h "$$BASEURL/regex_internal.h?$$QUERY" && \
+## wget -O testsuite/BOOST.tests "$$BASEURL/BOOST.tests?$$QUERY" && \
+## wget -O testsuite/PCRE.tests "$$BASEURL/PCRE.tests?$$QUERY" && \
+## wget -O testsuite/SPENCER.tests "$$BASEURL/rxspencer/tests?$$QUERY"
-update-regex:
- HOST=sources.redhat.com && \
- BASEURL="http://$$HOST/cgi-bin/cvsweb.cgi/~checkout~/libc/posix" && \
- QUERY='cvsroot=glibc&content-type=text/plain' && \
- wget -O lib/regcomp.c "$$BASEURL/regcomp.c?$$QUERY" && \
- wget -O lib/regexec.c "$$BASEURL/regexec.c?$$QUERY" && \
- wget -O lib/regex.c "$$BASEURL/regex.c?$$QUERY" && \
- wget -O lib/regex_.h "$$BASEURL/regex.h?$$QUERY" && \
- wget -O lib/regex_internal.c "$$BASEURL/regex_internal.c?$$QUERY" && \
- wget -O lib/regex_internal.h "$$BASEURL/regex_internal.h?$$QUERY" && \
- wget -O testsuite/BOOST.tests "$$BASEURL/BOOST.tests?$$QUERY" && \
- wget -O testsuite/PCRE.tests "$$BASEURL/PCRE.tests?$$QUERY" && \
- wget -O testsuite/SPENCER.tests "$$BASEURL/rxspencer/tests?$$QUERY"