summaryrefslogtreecommitdiff
path: root/lib/gnulib.mk
diff options
context:
space:
mode:
authorClint Adams <schizo@debian.org>2009-07-22 18:08:07 -0500
committerClint Adams <schizo@debian.org>2009-07-22 18:08:07 -0500
commit86bbc911e93efe1f0957ee887182b3d64bb0eec4 (patch)
treeb5396e313f5bdcce6df85c7e787b214d68e715d4 /lib/gnulib.mk
parent47c0ab9528ec53e5a0a6e761ba3789055e048638 (diff)
Imported Upstream version 4.2.1
Diffstat (limited to 'lib/gnulib.mk')
-rw-r--r--lib/gnulib.mk114
1 files changed, 109 insertions, 5 deletions
diff --git a/lib/gnulib.mk b/lib/gnulib.mk
index 462d885..9bc564a 100644
--- a/lib/gnulib.mk
+++ b/lib/gnulib.mk
@@ -9,7 +9,7 @@
# the same distribution terms as the rest of that program.
#
# Generated by gnulib-tool.
-# Reproduce by: gnulib-tool --import --dir=. --local-dir=gl --lib=libsed --source-base=lib --m4-base=m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-libtool --macro-prefix=gl acl alloca btowc extensions getline getopt gettext localcharset mbrlen mbrtowc mbsinit mkstemp obstack pathmax regex stat-macros stdbool strerror strverscmp unlocked-io verify wcrtomb wctob
+# Reproduce by: gnulib-tool --import --dir=. --local-dir=gl --lib=libsed --source-base=lib --m4-base=m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-libtool --macro-prefix=gl acl alloca btowc c-ctype extensions getline getopt gettext localcharset mbrlen mbrtowc mbsinit memchr mkstemp obstack pathmax regex rename selinux-h stat-macros stdbool strerror strverscmp unlocked-io verify wcrtomb wctob
AUTOMAKE_OPTIONS = 1.5 gnits
@@ -83,6 +83,12 @@ EXTRA_libsed_a_SOURCES += btowc.c
## end gnulib module btowc
+## begin gnulib module c-ctype
+
+libsed_a_SOURCES += c-ctype.h c-ctype.c
+
+## end gnulib module c-ctype
+
## begin gnulib module configmake
# Retrieve values of the variables through 'configure' followed by
@@ -103,7 +109,7 @@ EXTRA_libsed_a_SOURCES += btowc.c
# The Automake-defined pkg* macros are appended, in the order
# listed in the Automake 1.10a+ documentation.
configmake.h: Makefile
- rm -f $@-t $@
+ rm -f $@-t
{ echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \
echo '#define PREFIX "$(prefix)"'; \
echo '#define EXEC_PREFIX "$(exec_prefix)"'; \
@@ -133,12 +139,26 @@ configmake.h: Makefile
echo '#define PKGLIBDIR "$(pkglibdir)"'; \
echo '#define PKGLIBEXECDIR "$(pkglibexecdir)"'; \
} | sed '/""/d' > $@-t
- mv $@-t $@
+ if test -f $@ && cmp $@-t $@ > /dev/null; then \
+ rm -f $@-t; \
+ else \
+ rm -f $@; mv $@-t $@; \
+ fi
+
BUILT_SOURCES += configmake.h
CLEANFILES += configmake.h configmake.h-t
## end gnulib module configmake
+## begin gnulib module dirname
+
+
+EXTRA_DIST += basename.c dirname.c dirname.h stripslash.c
+
+EXTRA_libsed_a_SOURCES += basename.c dirname.c stripslash.c
+
+## end gnulib module dirname
+
## begin gnulib module errno
BUILT_SOURCES += $(ERRNO_H)
@@ -221,6 +241,15 @@ EXTRA_libsed_a_SOURCES += getopt.c getopt1.c
## end gnulib module getopt
+## begin gnulib module getpagesize
+
+
+EXTRA_DIST += getpagesize.c
+
+EXTRA_libsed_a_SOURCES += getpagesize.c
+
+## end gnulib module getpagesize
+
## begin gnulib module gettext
# This is for those projects which use "gettextize --intl" to put a source-code
@@ -289,7 +318,8 @@ all-local: charset.alias ref-add.sed ref-del.sed
charset_alias = $(DESTDIR)$(libdir)/charset.alias
charset_tmp = $(DESTDIR)$(libdir)/charset.tmp
-install-exec-local: all-local
+install-exec-local: install-exec-localcharset
+install-exec-localcharset: all-local
if test $(GLIBC21) = no; then \
case '$(host_os)' in \
darwin[56]*) \
@@ -317,7 +347,8 @@ install-exec-local: all-local
fi ; \
fi
-uninstall-local: all-local
+uninstall-local: uninstall-localcharset
+uninstall-localcharset: all-local
if test -f $(charset_alias); then \
sed -f ref-del.sed $(charset_alias) > $(charset_tmp); \
if grep '^# Packages using this file: $$' $(charset_tmp) \
@@ -400,6 +431,15 @@ EXTRA_libsed_a_SOURCES += mbsinit.c
## end gnulib module mbsinit
+## begin gnulib module memchr
+
+
+EXTRA_DIST += memchr.c memchr.valgrind
+
+EXTRA_libsed_a_SOURCES += memchr.c
+
+## end gnulib module memchr
+
## begin gnulib module mkstemp
@@ -461,6 +501,40 @@ EXTRA_libsed_a_SOURCES += regcomp.c regex.c regex_internal.c regexec.c
## end gnulib module regex
+## begin gnulib module rename
+
+
+EXTRA_DIST += rename.c
+
+EXTRA_libsed_a_SOURCES += rename.c
+
+## end gnulib module rename
+
+## begin gnulib module selinux-h
+
+libsed_a_SOURCES += se-context.in.h se-selinux.in.h
+
+BUILT_SOURCES += $(SELINUX_SELINUX_H)
+selinux/selinux.h: se-selinux.in.h
+ rm -f $@-t $@
+ $(MKDIR_P) selinux
+ cp $(srcdir)/se-selinux.in.h $@-t
+ chmod a-x $@-t
+ mv $@-t $@
+MOSTLYCLEANFILES += selinux/selinux.h selinux/selinux.h-t
+
+BUILT_SOURCES += $(SELINUX_CONTEXT_H)
+selinux/context.h: se-context.in.h
+ rm -f $@-t $@
+ $(MKDIR_P) selinux
+ cp $(srcdir)/se-context.in.h $@-t
+ chmod a-x $@-t
+ mv $@-t $@
+MOSTLYCLEANFILES += selinux/context.h selinux/context.h-t
+MOSTLYCLEANDIRS += selinux
+
+## end gnulib module selinux-h
+
## begin gnulib module stat-macros
@@ -564,6 +638,7 @@ stdio.h: stdio.in.h
-e 's|@''GNULIB_FTELL''@|$(GNULIB_FTELL)|g' \
-e 's|@''GNULIB_FTELLO''@|$(GNULIB_FTELLO)|g' \
-e 's|@''GNULIB_FFLUSH''@|$(GNULIB_FFLUSH)|g' \
+ -e 's|@''GNULIB_FPURGE''@|$(GNULIB_FPURGE)|g' \
-e 's|@''GNULIB_FCLOSE''@|$(GNULIB_FCLOSE)|g' \
-e 's|@''GNULIB_FPUTC''@|$(GNULIB_FPUTC)|g' \
-e 's|@''GNULIB_PUTC''@|$(GNULIB_PUTC)|g' \
@@ -601,6 +676,8 @@ stdio.h: stdio.in.h
-e 's|@''REPLACE_FTELLO''@|$(REPLACE_FTELLO)|g' \
-e 's|@''REPLACE_FTELL''@|$(REPLACE_FTELL)|g' \
-e 's|@''REPLACE_FFLUSH''@|$(REPLACE_FFLUSH)|g' \
+ -e 's|@''REPLACE_FPURGE''@|$(REPLACE_FPURGE)|g' \
+ -e 's|@''HAVE_DECL_FPURGE''@|$(HAVE_DECL_FPURGE)|g' \
-e 's|@''REPLACE_FCLOSE''@|$(REPLACE_FCLOSE)|g' \
-e 's|@''HAVE_DECL_GETDELIM''@|$(HAVE_DECL_GETDELIM)|g' \
-e 's|@''HAVE_DECL_GETLINE''@|$(HAVE_DECL_GETLINE)|g' \
@@ -719,6 +796,7 @@ string.h: string.in.h
-e 's|@''GNULIB_MBSSPN''@|$(GNULIB_MBSSPN)|g' \
-e 's|@''GNULIB_MBSSEP''@|$(GNULIB_MBSSEP)|g' \
-e 's|@''GNULIB_MBSTOK_R''@|$(GNULIB_MBSTOK_R)|g' \
+ -e 's|@''GNULIB_MEMCHR''@|$(GNULIB_MEMCHR)|g' \
-e 's|@''GNULIB_MEMMEM''@|$(GNULIB_MEMMEM)|g' \
-e 's|@''GNULIB_MEMPCPY''@|$(GNULIB_MEMPCPY)|g' \
-e 's|@''GNULIB_MEMRCHR''@|$(GNULIB_MEMRCHR)|g' \
@@ -755,6 +833,7 @@ string.h: string.in.h
-e 's|@''HAVE_DECL_STRERROR''@|$(HAVE_DECL_STRERROR)|g' \
-e 's|@''HAVE_DECL_STRSIGNAL''@|$(HAVE_DECL_STRSIGNAL)|g' \
-e 's|@''HAVE_STRVERSCMP''@|$(HAVE_STRVERSCMP)|g' \
+ -e 's|@''REPLACE_MEMCHR''@|$(REPLACE_MEMCHR)|g' \
-e 's|@''REPLACE_MEMMEM''@|$(REPLACE_MEMMEM)|g' \
-e 's|@''REPLACE_STRCASESTR''@|$(REPLACE_STRCASESTR)|g' \
-e 's|@''REPLACE_STRDUP''@|$(REPLACE_STRDUP)|g' \
@@ -771,6 +850,24 @@ EXTRA_DIST += string.in.h
## end gnulib module string
+## begin gnulib module strndup
+
+
+EXTRA_DIST += strndup.c
+
+EXTRA_libsed_a_SOURCES += strndup.c
+
+## end gnulib module strndup
+
+## begin gnulib module strnlen
+
+
+EXTRA_DIST += strnlen.c
+
+EXTRA_libsed_a_SOURCES += strnlen.c
+
+## end gnulib module strnlen
+
## begin gnulib module strverscmp
@@ -973,6 +1070,7 @@ wchar.h: wchar.in.h
-e 's|@''REPLACE_MBSNRTOWCS''@|$(REPLACE_MBSNRTOWCS)|g' \
-e 's|@''REPLACE_WCRTOMB''@|$(REPLACE_WCRTOMB)|g' \
-e 's|@''REPLACE_WCSRTOMBS''@|$(REPLACE_WCSRTOMBS)|g' \
+ -e 's|@''REPLACE_WCSNRTOMBS''@|$(REPLACE_WCSNRTOMBS)|g' \
-e 's|@''REPLACE_WCWIDTH''@|$(REPLACE_WCWIDTH)|g' \
-e '/definition of GL_LINK_WARNING/r $(LINK_WARNING_H)' \
< $(srcdir)/wchar.in.h; \
@@ -1042,6 +1140,12 @@ libsed_a_SOURCES += xalloc-die.c
## end gnulib module xalloc-die
+## begin gnulib module xstrndup
+
+libsed_a_SOURCES += xstrndup.h xstrndup.c
+
+## end gnulib module xstrndup
+
mostlyclean-local: mostlyclean-generic
@for dir in '' $(MOSTLYCLEANDIRS); do \