summaryrefslogtreecommitdiff
path: root/sed
diff options
context:
space:
mode:
Diffstat (limited to 'sed')
-rw-r--r--sed/compile.c4
-rw-r--r--sed/execute.c2
-rw-r--r--sed/local.mk2
-rw-r--r--sed/mbcs.c2
-rw-r--r--sed/regexp.c5
-rw-r--r--sed/sed.c2
-rw-r--r--sed/sed.h4
-rw-r--r--sed/utils.c2
-rw-r--r--sed/utils.h2
9 files changed, 12 insertions, 13 deletions
diff --git a/sed/compile.c b/sed/compile.c
index 7a28e56..e4fbb44 100644
--- a/sed/compile.c
+++ b/sed/compile.c
@@ -1,5 +1,5 @@
/* GNU SED, a batch stream editor.
- Copyright (C) 1989-2016 Free Software Foundation, Inc.
+ Copyright (C) 1989-2017 Free Software Foundation, Inc.
This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
@@ -257,7 +257,7 @@ savchar(int ch)
{
if (prog.cur <= prog.base || *--prog.cur != ch)
panic("Called savchar() with unexpected pushback (%x)",
- (unsigned char)ch);
+ (unsigned int) ch);
}
else
ungetc(ch, prog.file);
diff --git a/sed/execute.c b/sed/execute.c
index 009d188..2302a1e 100644
--- a/sed/execute.c
+++ b/sed/execute.c
@@ -1,5 +1,5 @@
/* GNU SED, a batch stream editor.
- Copyright (C) 1989-2016 Free Software Foundation, Inc.
+ Copyright (C) 1989-2017 Free Software Foundation, Inc.
This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
diff --git a/sed/local.mk b/sed/local.mk
index dd1da0a..d410d26 100644
--- a/sed/local.mk
+++ b/sed/local.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2016 Free Software Foundation, Inc.
+# Copyright (C) 2016-2017 Free Software Foundation, Inc.
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
diff --git a/sed/mbcs.c b/sed/mbcs.c
index 3505ef6..26c6b54 100644
--- a/sed/mbcs.c
+++ b/sed/mbcs.c
@@ -1,5 +1,5 @@
/* GNU SED, a batch stream editor.
- Copyright (C) 2003-2016 Free Software Foundation, Inc.
+ Copyright (C) 2003-2017 Free Software Foundation, Inc.
This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
diff --git a/sed/regexp.c b/sed/regexp.c
index ff898a8..049d9b9 100644
--- a/sed/regexp.c
+++ b/sed/regexp.c
@@ -1,5 +1,5 @@
/* GNU SED, a batch stream editor.
- Copyright (C) 1999-2016 Free Software Foundation, Inc.
+ Copyright (C) 1999-2017 Free Software Foundation, Inc.
This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
@@ -419,8 +419,7 @@ match_regex(struct regex *regex, char *buf, size_t buflen,
#ifdef DEBUG_LEAKS
void
-release_regex(regex)
- struct regex *regex;
+release_regex(struct regex *regex)
{
regfree(&regex->pattern);
free(regex);
diff --git a/sed/sed.c b/sed/sed.c
index 7445178..15faff0 100644
--- a/sed/sed.c
+++ b/sed/sed.c
@@ -1,5 +1,5 @@
/* GNU SED, a batch stream editor.
- Copyright (C) 1989-2016 Free Software Foundation, Inc.
+ Copyright (C) 1989-2017 Free Software Foundation, Inc.
This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
diff --git a/sed/sed.h b/sed/sed.h
index 0d056e3..7510b0a 100644
--- a/sed/sed.h
+++ b/sed/sed.h
@@ -1,5 +1,5 @@
/* GNU SED, a batch stream editor.
- Copyright (C) 1989-2016 Free Software Foundation, Inc.
+ Copyright (C) 1989-2017 Free Software Foundation, Inc.
This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
@@ -28,7 +28,7 @@
/* Struct vector is used to describe a compiled sed program. */
struct vector {
struct sed_cmd *v; /* a dynamically allocated array */
- size_t v_allocated; /* ... number slots allocated */
+ size_t v_allocated; /* ... number of slots allocated */
size_t v_length; /* ... number of slots in use */
};
diff --git a/sed/utils.c b/sed/utils.c
index 8afea8e..25c4b6f 100644
--- a/sed/utils.c
+++ b/sed/utils.c
@@ -1,5 +1,5 @@
/* Functions from hack's utils library.
- Copyright (C) 1989-2016 Free Software Foundation, Inc.
+ Copyright (C) 1989-2017 Free Software Foundation, Inc.
This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
diff --git a/sed/utils.h b/sed/utils.h
index 6b9f8ef..fecf7c7 100644
--- a/sed/utils.h
+++ b/sed/utils.h
@@ -1,5 +1,5 @@
/* Functions from hack's utils library.
- Copyright (C) 1989-2016 Free Software Foundation, Inc.
+ Copyright (C) 1989-2017 Free Software Foundation, Inc.
This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by