summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLaurent Bigonville <bigon@debian.org>2014-05-20 11:47:43 +0000
committerAndrew Shadura <andrew.shadura@collabora.co.uk>2016-09-20 10:28:25 +0200
commitfddd1f5afae44979641977763d3d0343413c949a (patch)
tree5b983b6bb7f30a1d9edfe7aaed1e15dd070e126f
parentae88a5fc7ae2dc1418db1b56ddf27f3896b23c39 (diff)
d/p/typedef_int_Function_readline.patch: Fix FTBFS with readline 6.3
(Closes: #741785)
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/typedef_int_Function_readline.patch23
3 files changed, 31 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 3098f60..a1f32b5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+seed (3.8.1-2) UNRELEASED; urgency=medium
+
+ * d/p/typedef_int_Function_readline.patch: Fix FTBFS with readline 6.3
+ (Closes: #741785)
+
+ -- Laurent Bigonville <bigon@debian.org> Tue, 20 May 2014 13:37:33 +0200
+
seed (3.8.1-1) unstable; urgency=low
[ Jeremy Bicha ]
diff --git a/debian/patches/series b/debian/patches/series
index 2f829c7..a302b12 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
fix_format.patch
link_gmodule.patch
fix_autogen_and_configure.patch
+typedef_int_Function_readline.patch
diff --git a/debian/patches/typedef_int_Function_readline.patch b/debian/patches/typedef_int_Function_readline.patch
new file mode 100644
index 0000000..a345758
--- /dev/null
+++ b/debian/patches/typedef_int_Function_readline.patch
@@ -0,0 +1,23 @@
+From cf772e792fd64f70ee2c714e0b5eaf527ce35467 Mon Sep 17 00:00:00 2001
+From: Alan Knowles <alan@roojs.com>
+Date: Tue, 25 Mar 2014 18:14:03 +0800
+Subject: Fix Bug 725602 - typedef int Function () is removed in readline 6.3
+
+as per readline documents use rl_command_func_t
+
+diff --git a/modules/readline/seed-readline.c b/modules/readline/seed-readline.c
+index cd5ecfe..49d1faa 100644
+--- a/modules/readline/seed-readline.c
++++ b/modules/readline/seed-readline.c
+@@ -77,7 +77,7 @@ seed_readline_bind(SeedContext ctx,
+ key = seed_value_to_string(ctx, arguments[0], exception);
+ c = seed_make_rl_closure((SeedObject) arguments[1]);
+
+- rl_bind_key(*key, (Function *) c);
++ rl_bind_key(*key, (rl_command_func_t *) c);
+
+ g_free(key);
+
+--
+cgit v0.10.1
+