summaryrefslogtreecommitdiff
path: root/doc/reference/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/reference/Makefile.am')
-rw-r--r--doc/reference/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/doc/reference/Makefile.am b/doc/reference/Makefile.am
index b5c6595..d339ebd 100644
--- a/doc/reference/Makefile.am
+++ b/doc/reference/Makefile.am
@@ -39,6 +39,24 @@ MKTMPL_OPTIONS=
# e.g. FIXXREF_OPTIONS=--extra-dir=../gdk-pixbuf/html --extra-dir=../gdk/html
FIXXREF_OPTIONS=
+extra_paths = \
+ $(abs_builddir) \
+ $(abs_top_srcdir)/doc/modules/readline \
+ $(abs_top_builddir)/doc/modules/readline \
+ $(abs_top_srcdir)/doc/modules/sqlite \
+ $(abs_top_builddir)/doc/modules/sqlite \
+ $(abs_top_srcdir)/doc/modules/gtkbuilder \
+ $(abs_top_builddir)/doc/modules/gtkbuilder \
+ $(abs_top_srcdir)/doc/modules/sandbox \
+ $(abs_top_builddir)/doc/modules/sandbox \
+ $(NULL)
+
+
+space = $(NULL) $(NULL)
+
+# Add the builddirs to the HTML path so that built files are found
+MKHTML_OPTIONS=--path=$(subst $(space),:,$(extra_paths))
+
# Used for dependencies. The docs will be rebuilt if any of these change.
# e.g. HFILE_GLOB=$(top_srcdir)/gtk/*.h
# e.g. CFILE_GLOB=$(top_srcdir)/gtk/*.c
@@ -84,3 +102,5 @@ EXTRA_DIST += version.xml.in
# Comment this out if you want your docs-status tested during 'make check'
#TESTS = $(GTKDOC_CHECK)
+
+-include $(top_srcdir)/git.mk