summaryrefslogtreecommitdiff
path: root/tests/javascript/gtypes/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/javascript/gtypes/Makefile.am')
-rw-r--r--tests/javascript/gtypes/Makefile.am40
1 files changed, 24 insertions, 16 deletions
diff --git a/tests/javascript/gtypes/Makefile.am b/tests/javascript/gtypes/Makefile.am
index 253c3c0..690f0b2 100644
--- a/tests/javascript/gtypes/Makefile.am
+++ b/tests/javascript/gtypes/Makefile.am
@@ -1,8 +1,7 @@
TESTS_ENVIRONMENT = PATH=$(top_builddir)/src:$$PATH
-
-EXTRA_DIST = \
+workingtests = \
gtype-class-init-exception.js \
gtype-typerror.js \
gtype.js \
@@ -14,20 +13,29 @@ EXTRA_DIST = \
gtype-self.js \
gtype-extraprop.js \
gtype-gtype-class-init.js \
- gtype-signal.js \
- testsuite.js
+ gtype-signal.js
+
+failingtests = \
+ $(NULL)
+
+otherfiles = testsuite.js
+
+installingtests_DATA = $(workingtests) $(otherfiles)
+installingtestsdir = $(datadir)/seed@SEED_GTK_VERSION@-tests/javascript/gtypes/
+
+EXTRA_DIST = \
+ $(workingtests) \
+ $(failingtests) \
+ $(otherfiles) \
+ $(NULL)
TESTS = \
- gtype-class-init-exception.js \
- gtype-typerror.js \
- gtype.js \
- gtype-gtype.js \
- gtype-signal-args.js \
- gtype-signal-order-bug663289.js \
- gtype-property-construct.js \
- gtype-property-nice.js \
- gtype-self.js \
- gtype-extraprop.js \
- gtype-gtype-class-init.js \
- gtype-signal.js
+ $(workingtests) \
+ $(failingtests) \
+ $(NULL)
+
+XFAIL_TESTS = \
+ $(failingtests) \
+ $(NULL)
+-include $(top_srcdir)/git.mk