summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHilko Bengen <bengen@debian.org>2015-07-22 17:11:20 +0200
committergregor herrmann <gregoa@debian.org>2022-06-26 13:07:41 +0200
commita37317785fc2736e076d1f57d414dc4567c423f0 (patch)
tree42f30ecba0a6c701264d48881643d0abc212173e
parent6f74e4d7a4a47dab27494b88688dc15c43e6c576 (diff)
Do not install .elc files if they haven't been generated
Gbp-Pq: Name 0003-Do-not-install-.elc-files-if-they-haven-t-been-gener.patch
-rw-r--r--Makefile.PL6
1 files changed, 1 insertions, 5 deletions
diff --git a/Makefile.PL b/Makefile.PL
index a7dfddd..71ad493 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -48,11 +48,7 @@ sub escape_path
sub prompt_for_emacs
{
# try to compile and install Elisp files, but don't die if we can't.
- my ($sysemacs) = grep { defined && -x }
- $ENV{EMACS}, glob '/usr/bin{/local,}/emacs';
- $sysemacs ||= q{emacs};
-
- my $emacs = prompt("Where is your emacs? ", $sysemacs);
+ my $emacs = prompt("Where is your emacs? ");
# Make sure emacs is a valid string/program path...
return undef unless $emacs;