summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Brady <mikebrady@eircom.net>2018-04-07 16:43:05 +0100
committerMike Brady <mikebrady@eircom.net>2018-04-07 16:43:05 +0100
commit31b4dcc54a1240e617fa4c17847ae5955688a6b9 (patch)
tree944854710562fe678c64f1db854c20b6b0eba070 /configure.ac
parent334e39cba606a475c74ef2d64c9472543682ecdc (diff)
parent1881beb54217506e19791ee33a6b6441560e457a (diff)
Release candidate 1 for 3.2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 41 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1c91659..719ca83 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ([2.50])
-AC_INIT([shairport-sync], [3.1.7], [mikebrady@eircom.net])
+AC_INIT([shairport-sync], [3.2d35], [mikebrady@eircom.net])
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([shairport.c])
AC_CONFIG_HEADERS([config.h])
@@ -52,6 +52,9 @@ else
AC_CHECK_LIB([daemon],[daemon_fork], , AC_MSG_ERROR(libdaemon needed))
fi
+##### The following check for the pthreads library doesn't put the compiler into the correct pthread mode
+##### so we add the -pthread compilation flag in AMFLAGS in the Makefile.am as well.
+
AC_CHECK_LIB([pthread],[pthread_create], , AC_MSG_ERROR(pthread library needed))
AC_CHECK_LIB([m],[exp], , AC_MSG_ERROR(maths library needed))
@@ -274,18 +277,54 @@ AC_ARG_WITH(dns_sd, [ --with-dns_sd = choose dns_sd mDNS support], [
AM_CONDITIONAL([USE_DNS_SD], [test "x$HAS_DNS_SD" = "x1"])
# Look for dbus flag
+AC_ARG_WITH(dbus, [ --with-dbus-interface = include support for the native Shairport Sync D-Bus interface], [
+ AC_MSG_RESULT(>>Including dbus support)
+ HAS_DBUS=1
+ AC_DEFINE([HAVE_DBUS], 1, [Needed by the compiler.])
+ PKG_CHECK_MODULES([GIO_UNIX], [gio-unix-2.0 >= 2.30.0],[CFLAGS="${GIO_UNIX_CFLAGS} ${CFLAGS}" LIBS="${GIO_UNIX_LIBS} ${LIBS}"],[AC_MSG_ERROR(dbus messaging support requires the glib 2.0 library -- libglib2.0-dev suggested!)])
+ ], )
AM_CONDITIONAL([USE_DBUS], [test "x$HAS_DBUS" = "x1"])
# Look for dbus test client flag
+AC_ARG_WITH(dbus-test-client, [ --with-dbus-test-client = compile dbus test client], [
+ AC_MSG_RESULT(>>Including dbus test client)
+ HAS_DBUS_CLIENT=1
+ AC_DEFINE([HAVE_DBUS_CLIENT], 1, [Needed by the compiler.])
+ PKG_CHECK_MODULES([GIO_UNIX], [gio-unix-2.0 >= 2.30.0],[CFLAGS="${GIO_UNIX_CFLAGS} ${CFLAGS}" LIBS="${GIO_UNIX_LIBS} ${LIBS}"],[AC_MSG_ERROR(dbus client support requires the glib 2.0 library -- libglib2.0-dev suggested!)])
+ ], )
AM_CONDITIONAL([USE_DBUS_CLIENT], [test "x$HAS_DBUS_CLIENT" = "x1"])
# Look for mpris flag
+AC_ARG_WITH(mpris, [ --with-mpris-interface = include support for a Shairport Sync D-Bus interface conforming to the MPRIS standard], [
+ AC_MSG_RESULT(>>Including the MPRIS D-Bus Interface)
+ HAS_MPRIS=1
+ AC_DEFINE([HAVE_MPRIS], 1, [Needed by the compiler.])
+ PKG_CHECK_MODULES([GIO_UNIX], [gio-unix-2.0 >= 2.30.0],[CFLAGS="${GIO_UNIX_CFLAGS} ${CFLAGS}" LIBS="${GIO_UNIX_LIBS} ${LIBS}"],[AC_MSG_ERROR(dbus messaging support for mpris requires the glib 2.0 library -- libglib2.0-dev suggested!)])
+ ], )
AM_CONDITIONAL([USE_MPRIS], [test "x$HAS_MPRIS" = "x1"])
# Look for mpris test client flag
+AC_ARG_WITH(mpris-test-client, [ --with-mpris-test-client = compile mpris test client], [
+ AC_MSG_RESULT(>>Including mpris test client)
+ HAS_MPRIS_CLIENT=1
+ AC_DEFINE([HAVE_MPRIS_CLIENT], 1, [Needed by the compiler.])
+ PKG_CHECK_MODULES([GIO_UNIX], [gio-unix-2.0 >= 2.30.0],[CFLAGS="${GIO_UNIX_CFLAGS} ${CFLAGS}" LIBS="${GIO_UNIX_LIBS} ${LIBS}"],[AC_MSG_ERROR(mpris client support requires the glib 2.0 library -- libglib2.0-dev suggested!)])
+ ], )
AM_CONDITIONAL([USE_MPRIS_CLIENT], [test "x$HAS_MPRIS_CLIENT" = "x1"])
-AM_CONDITIONAL([USE_DBUS_CORE_AND_DACP], [test "x$HAS_MPRIS" = "x1" -o "x$HAS_DBUS" = "x1"])
+#AM_CONDITIONAL([USE_DBUS_CORE_AND_DACP], [test "x$HAS_MPRIS" = "x1" -o "x$HAS_DBUS" = "x1"])
+
+if test "x$HAS_MPRIS" = "x1" -o "x$HAS_DBUS" = "x1" ; then
+ AC_MSG_RESULT(>>Including the metadata hub)
+ HAS_METADATA_HUB=1
+ AC_DEFINE([HAVE_METADATA_HUB], 1, [Needed by the compiler.])
+ AC_MSG_RESULT(>>Including the DACP client)
+ HAS_DACP_CLIENT=1
+ AC_DEFINE([HAVE_DACP_CLIENT], 1, [Needed by the compiler.])
+fi
+AM_CONDITIONAL([USE_METADATA_HUB], [test "x$HAS_METADATA_HUB" = "x1"])
+AM_CONDITIONAL([USE_DACP_CLIENT], [test "x$HAS_DACP_CLIENT" = "x1"])
+
if test "x${with_systemd}" = xyes ; then
# Find systemd unit dir