summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Brady <mikebrady@eircom.net>2019-07-26 11:26:22 +0100
committerMike Brady <mikebrady@eircom.net>2019-07-26 11:26:22 +0100
commit3c78283c9f67649fb8df176fe792b9e252278b37 (patch)
treec95f2cd2e6395b5a4d81be5e0b97b369c08bb37f /configure.ac
parent3323b58d72e2484c7eff68ed178a7c44ec1b2ed5 (diff)
Updates from 3.3.1:
1. Fix a bug that sometimes caused a crash when a service name was specified in the configuration file. The fix was to be more systematic in allocating and deallocating memory for temporary strings. Thanks to Chris Boot, Ari Sovijarvi and Jeroen Massar for the bug report. Fixes Debian Bug report #925577. 2. Allow the rtsp_listen_loop to exit if the RTSP port (usually port 5000) is not available. This allows the system to exit cleanly rather than abort. 3. Expose some of the settings used in the disable_standby_mode. The first setting the "disable_standby_mode_silence_threshold", which is the amount of audio in the output device's hardware buffer. It should normally be close to the value given in the “audio_backend_buffer_desired_length_in_seconds” setting. If it drops to this value, silence is added to the buffer to prevent the output device from becoming idle. The second new setting is the "disable_standby_mode_silence_scan_interval" which is the time between checks of the output device's hardware buffer. 4. The code for generating frames of silence, which may be dithered, has been simplified. 5. Pretty-print source files using: find . \( -name \*.cpp -or -name \*.h -or -name \*.c \) -exec clang-format -i -style='{BasedOnStyle: llvm, IndentWidth: 2, ColumnLimit: 100}' '{}' \; 6. Change comments for use_precision_timing.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a03955a..36f0b06 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ([2.50])
-AC_INIT([shairport-sync], [3.3.1], [mikebrady@eircom.net])
+AC_INIT([shairport-sync], [3.3.2], [mikebrady@eircom.net])
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([shairport.c])
AC_CONFIG_HEADERS([config.h])