summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Brady <mikebrady@eircom.net>2019-01-04 13:47:44 +0000
committerMike Brady <mikebrady@eircom.net>2019-01-04 13:47:44 +0000
commit4f9730e3b22745f3d4b6a6bdf625d7cbd5be2682 (patch)
treeea2dbdcf58fc8e2cd393ddc359da50c2053f3594 /configure.ac
parent8e5733e6ae88c47d7359eca556e1616091f7cd3c (diff)
Give a nice message if the soxr library isn't installed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c4b783b..f6a1c0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -175,14 +175,15 @@ AC_ARG_WITH(soxr, [ --with-soxr = choose libsoxr for high-quality interpolation
AC_DEFINE([CONFIG_SOXR], 1, [Include support for using the SoX Resampler library for interpolation])
PKG_CHECK_MODULES(
[SOXR], [soxr],
- [LIBS="${SOXR_LIBS} ${LIBS}"])
+ [LIBS="${SOXR_LIBS} ${LIBS}"],
+ [AC_MSG_ERROR(soxr support requires the libsoxr library -- libsoxr-dev suggested!)])
else
AC_CHECK_LIB([avutil],[av_get_cpu_flags])
if test "x${ac_cv_lib_avutil_av_get_cpu_flags}" = xyes ; then
# soxr may link against libavutil, depending on the architecture, but for the sake of simplicity link with it if it is found
- AC_CHECK_LIB([soxr],[soxr_create], , AC_MSG_ERROR(soxr support requested but libsoxr not found!), [-lavutil])
+ AC_CHECK_LIB([soxr],[soxr_create], , AC_MSG_ERROR(soxr support requires the libsoxr library -- libsoxr-dev suggested!), [-lavutil])
else
- AC_CHECK_LIB([soxr],[soxr_create], , AC_MSG_ERROR(soxr support requested but libsoxr not found!))
+ AC_CHECK_LIB([soxr],[soxr_create], , AC_MSG_ERROR(soxr support requires the libsoxr library -- libsoxr-dev suggested!))
fi
fi
], )