summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Brady <mikebrady@eircom.net>2019-04-15 17:07:34 +0100
committerMike Brady <mikebrady@eircom.net>2019-04-15 17:07:34 +0100
commit6cbaa15bdd5f480d0385e9bf916c354596407079 (patch)
treee9e5aef342105f17be7ea70077385180102fd193 /configure.ac
parent1b1348e1ac6dd1ba799be9e8d7c55bfe4edb3862 (diff)
Turn on the configuration flag for building soxr support in when the pkg_config is not available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e466adb..f019be3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -184,8 +184,8 @@ AC_ARG_WITH(ssl, [ choose --with-ssl=openssl, --with-ssl=mbedtls or --with-ssl=p
# Look for soxr flag
AC_ARG_WITH(soxr, [ --with-soxr = choose libsoxr for high-quality interpolation], [
AC_MSG_RESULT(>>Including support for soxr-based interpolation)
+ AC_DEFINE([CONFIG_SOXR], 1, [Include support for using the SoX Resampler library for interpolation])
if test "x${with_pkg_config}" = xyes ; then
- AC_DEFINE([CONFIG_SOXR], 1, [Include support for using the SoX Resampler library for interpolation])
PKG_CHECK_MODULES(
[SOXR], [soxr],
[LIBS="${SOXR_LIBS} ${LIBS}"],