summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Brady <mikebrady@eircom.net>2018-03-10 17:01:42 +0000
committerMike Brady <mikebrady@eircom.net>2018-03-10 17:01:42 +0000
commit9d9b0a1824d15b5c5695783c7e26bf71b687a415 (patch)
treedb28782a354436dc9d9e813139db0b89f4cb69d9 /configure.ac
parent39f159bf9ea6a07c9e60837802c2c71e3263f263 (diff)
Add a Shairport Sync Diagnostics DBus Onject, only part working
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c033ade..6bef971 100644
--- a/configure.ac
+++ b/configure.ac
@@ -279,9 +279,12 @@ AC_ARG_WITH(dbus, [ --with-dbus-interface = include support for a native Shairp
AC_MSG_RESULT(>>Including dbus support)
HAS_DBUS=1
AC_DEFINE([HAVE_DBUS], 1, [Needed by the compiler.])
+ AC_DEFINE([HAVE_DBUS_DIAGNOSTICS], 1, [Needed by the compiler.])
PKG_CHECK_MODULES([GIO_UNIX], [gio-unix-2.0 >= 2.30.0],[CFLAGS="${GIO_UNIX_CFLAGS} ${CFLAGS}" LIBS="${GIO_UNIX_LIBS} ${LIBS}"],[AC_MSG_ERROR(dbus messaging support requires the glib 2.0 library -- libglib2.0-dev suggested!)])
], )
AM_CONDITIONAL([USE_DBUS], [test "x$HAS_DBUS" = "x1"])
+# Automatically include the diagnostics interface
+AM_CONDITIONAL([USE_DBUS_DIAGNOSTICS], [test "x$HAS_DBUS" = "x1"])
# Look for dbus test client flag
AC_ARG_WITH(dbus-test-client, [ --with-dbus-test-client = compile dbus test client], [