summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2024-02-05 17:35:55 +0100
committerPicca Frédéric-Emmanuel <picca@debian.org>2024-02-05 17:35:55 +0100
commitf7789322c3cc8767a4b4248068935304e3ccc948 (patch)
treea8bd521b3a85b1b987e9c2af9f2fe57ba407bd71
parentb4869e4d1d6d15b42e85b385ff328831579144a6 (diff)
refresh the patch series
-rw-r--r--debian/patches/0002-use-the-system-mathjax-privacy-breach.patch4
-rw-r--r--debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch22
-rw-r--r--debian/patches/0006-Tests-if-openCL-can-be-used.patch8
-rw-r--r--debian/patches/0007-do-not-install-scipy_spatial-COPYING.txt.patch22
-rw-r--r--debian/patches/0007-python3.10-fix.patch45
-rw-r--r--debian/patches/0008-deal-with-h5py-until-we-solved-1051781.patch12
-rw-r--r--debian/patches/0008-python3.11-fix.patch35
-rw-r--r--debian/patches/0009-Skip-testing-nanmin-on-float64-arrays-on-mips-el.patch17
-rw-r--r--debian/patches/series3
9 files changed, 32 insertions, 136 deletions
diff --git a/debian/patches/0002-use-the-system-mathjax-privacy-breach.patch b/debian/patches/0002-use-the-system-mathjax-privacy-breach.patch
index e6ff374..c42bfcf 100644
--- a/debian/patches/0002-use-the-system-mathjax-privacy-breach.patch
+++ b/debian/patches/0002-use-the-system-mathjax-privacy-breach.patch
@@ -8,10 +8,10 @@ Subject: use the system mathjax (privacy breach)
1 file changed, 5 insertions(+)
diff --git a/doc/source/conf.py b/doc/source/conf.py
-index 2d242e9..38b531d 100644
+index b412a1d..1f421fe 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
-@@ -138,6 +138,11 @@ pygments_style = 'sphinx'
+@@ -154,6 +154,11 @@ pygments_style = "sphinx"
# A list of ignored prefixes for module index sorting.
# modindex_common_prefix = []
diff --git a/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch b/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch
deleted file mode 100644
index 5213b7a..0000000
--- a/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?= <picca@debian.org>
-Date: Sun, 4 Mar 2018 16:36:35 +0100
-Subject: do not modify PYTHONPATH from setup.py
-
----
- setup.py | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index 531070d..8b4d615 100644
---- a/setup.py
-+++ b/setup.py
-@@ -229,7 +229,8 @@ class BuildMan(Command):
- path.insert(0, os.path.abspath(build.build_lib))
-
- env = dict((str(k), str(v)) for k, v in os.environ.items())
-- env["PYTHONPATH"] = os.pathsep.join(path)
-+
-+ # env["PYTHONPATH"] = os.pathsep.join(path)
- if not os.path.isdir("build/man"):
- os.makedirs("build/man")
- import subprocess
diff --git a/debian/patches/0006-Tests-if-openCL-can-be-used.patch b/debian/patches/0006-Tests-if-openCL-can-be-used.patch
index 6fd8a20..56c311e 100644
--- a/debian/patches/0006-Tests-if-openCL-can-be-used.patch
+++ b/debian/patches/0006-Tests-if-openCL-can-be-used.patch
@@ -7,15 +7,15 @@ Subject: Tests if openCL can be used
1 file changed, 2 insertions(+)
diff --git a/src/silx/opencl/common.py b/src/silx/opencl/common.py
-index cf51406..5702f74 100644
+index 30c9ef7..13b2309 100644
--- a/src/silx/opencl/common.py
+++ b/src/silx/opencl/common.py
-@@ -73,6 +73,8 @@ if pyopencl is None:
+@@ -87,6 +87,8 @@ else:
WRITE_ONLY = 1
READ_ONLY = 1
READ_WRITE = 1
+else:
+ mf = pyopencl.mem_flags
- FLOP_PER_CORE = {"GPU": 64, # GPU, Fermi at least perform 64 flops per cycle/multicore, G80 were at 24 or 48 ...
- "CPU": 4, # CPU, at least intel's have 4 operation per cycle
+
+ FLOP_PER_CORE = {
diff --git a/debian/patches/0007-do-not-install-scipy_spatial-COPYING.txt.patch b/debian/patches/0007-do-not-install-scipy_spatial-COPYING.txt.patch
deleted file mode 100644
index d6d9321..0000000
--- a/debian/patches/0007-do-not-install-scipy_spatial-COPYING.txt.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?= <picca@debian.org>
-Date: Thu, 3 Nov 2022 10:22:11 +0100
-Subject: do not install scipy_spatial COPYING.txt
-
----
- setup.py | 3 ---
- 1 file changed, 3 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index 8b4d615..d66eef5 100644
---- a/setup.py
-+++ b/setup.py
-@@ -789,9 +789,6 @@ def get_project_configuration():
- },
- ext_modules=ext_modules,
- package_data=package_data,
-- data_files=[
-- ('silx/third_party/_local/scipy_spatial/qhull', ['src/silx/third_party/_local/scipy_spatial/qhull/COPYING.txt'])
-- ],
- )
-
-
diff --git a/debian/patches/0007-python3.10-fix.patch b/debian/patches/0007-python3.10-fix.patch
index c36eeb8..a4e54e9 100644
--- a/debian/patches/0007-python3.10-fix.patch
+++ b/debian/patches/0007-python3.10-fix.patch
@@ -3,16 +3,15 @@ Date: Sun, 13 Mar 2022 03:37:32 +0100
Subject: Fix int compare with python3.10, skip a couple of tests
---
- src/silx/app/view/About.py | 2 +-
- src/silx/gui/data/test/test_arraywidget.py | 2 ++
- src/silx/opencl/test/test_medfilt.py | 4 +++-
- 3 files changed, 6 insertions(+), 2 deletions(-)
+ src/silx/app/view/About.py | 2 +-
+ src/silx/opencl/test/test_medfilt.py | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/silx/app/view/About.py b/src/silx/app/view/About.py
-index 2af7ed4..eb5ec16 100644
+index 76e0cf2..350337d 100644
--- a/src/silx/app/view/About.py
+++ b/src/silx/app/view/About.py
-@@ -242,7 +242,7 @@ class About(qt.QDialog):
+@@ -250,7 +250,7 @@ class About(qt.QDialog):
width = hardLimit
height = layoutMinimumSize.height()
@@ -21,45 +20,23 @@ index 2af7ed4..eb5ec16 100644
@staticmethod
def about(parent, applicationName):
-diff --git a/src/silx/gui/data/test/test_arraywidget.py b/src/silx/gui/data/test/test_arraywidget.py
-index 024383d..915238d 100644
---- a/src/silx/gui/data/test/test_arraywidget.py
-+++ b/src/silx/gui/data/test/test_arraywidget.py
-@@ -28,6 +28,7 @@ __date__ = "05/12/2016"
- import os
- import tempfile
- import unittest
-+import pytest
-
- import numpy
-
-@@ -186,6 +187,7 @@ class TestArrayWidget(TestCaseQt):
- b1 = self.aw.getData(copy=False)
- self.assertIs(b0, b1)
-
-+ @pytest.mark.skip(reason="Skip for now since it chokes witth py3.10")
- def testClipping(self):
- """Test clipping of large arrays"""
- self.aw.show()
diff --git a/src/silx/opencl/test/test_medfilt.py b/src/silx/opencl/test/test_medfilt.py
-index e657d0d..dfc598d 100644
+index 2ef4490..15cd749 100644
--- a/src/silx/opencl/test/test_medfilt.py
+++ b/src/silx/opencl/test/test_medfilt.py
-@@ -40,6 +40,8 @@ import time
+@@ -40,6 +40,7 @@ import time
import logging
import numpy
import unittest
-+import pytest
+
from collections import namedtuple
+
try:
- import mako
-@@ -69,7 +71,7 @@ except:
+@@ -77,7 +78,6 @@ except:
HAS_SCIPY = False
from silx.math import medfilt2d as median_filter
--@unittest.skipUnless(ocl and mako, "PyOpenCl is missing")
-+@pytest.mark.skip(reason="PyOpenCl is missing")
+-
+ @unittest.skipUnless(ocl and mako, "PyOpenCl is missing")
class TestMedianFilter(unittest.TestCase):
-
def setUp(self):
diff --git a/debian/patches/0008-deal-with-h5py-until-we-solved-1051781.patch b/debian/patches/0008-deal-with-h5py-until-we-solved-1051781.patch
index 3016425..f1f1b6d 100644
--- a/debian/patches/0008-deal-with-h5py-until-we-solved-1051781.patch
+++ b/debian/patches/0008-deal-with-h5py-until-we-solved-1051781.patch
@@ -7,15 +7,15 @@ Subject: deal with h5py until we solved #1051781
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
-index d66eef5..344d422 100644
+index 75d72bc..37aa7a6 100644
--- a/setup.py
+++ b/setup.py
-@@ -500,7 +500,7 @@ def get_project_configuration():
- # for the script launcher and pkg_resources
- "setuptools",
+@@ -170,7 +170,7 @@ def get_project_configuration():
+ # for version parsing
+ "packaging",
# for io support
- "h5py",
+ # "h5py",
"fabio>=0.9",
- ]
-
+ ]
+ if sys.version_info < (3, 9):
diff --git a/debian/patches/0008-python3.11-fix.patch b/debian/patches/0008-python3.11-fix.patch
deleted file mode 100644
index 346e0fe..0000000
--- a/debian/patches/0008-python3.11-fix.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From: Simon Quigley <tsimonq2@debian.org>
-Date: Fri, 3 Feb 2023 15:35:46 -0400
-Subject: Remove special-case for Python 3.11
-
-Origin: vendor
-Last-Update: 2023-01-26
-
-Last-Update: 2023-01-26
----
- src/silx/gui/utils/testutils.py | 12 ++++--------
- 1 file changed, 4 insertions(+), 8 deletions(-)
-
-diff --git a/src/silx/gui/utils/testutils.py b/src/silx/gui/utils/testutils.py
-index 1ec9b0b..81ce2c4 100644
---- a/src/silx/gui/utils/testutils.py
-+++ b/src/silx/gui/utils/testutils.py
-@@ -141,14 +141,10 @@ class TestCaseQt(unittest.TestCase):
-
- def _currentTestSucceeded(self):
- if hasattr(self, '_outcome'):
-- if hasattr(self, '_feedErrorsToResult'):
-- # For Python 3.4 -3.10
-- result = self.defaultTestResult() # these 2 methods have no side effects
-- if hasattr(self._outcome, 'errors'):
-- self._feedErrorsToResult(result, self._outcome.errors)
-- else:
-- # Python 3.11+
-- result = self._outcome.result
-+ # For Python 3.4 -3.10
-+ result = self.defaultTestResult() # these 2 methods have no side effects
-+ if hasattr(self._outcome, 'errors'):
-+ self._feedErrorsToResult(result, self._outcome.errors)
- else:
- # For Python < 3.4
- result = getattr(self, '_outcomeForDoCleanups', self._resultForDoCleanups)
diff --git a/debian/patches/0009-Skip-testing-nanmin-on-float64-arrays-on-mips-el.patch b/debian/patches/0009-Skip-testing-nanmin-on-float64-arrays-on-mips-el.patch
index f84e01a..6ef70a0 100644
--- a/debian/patches/0009-Skip-testing-nanmin-on-float64-arrays-on-mips-el.patch
+++ b/debian/patches/0009-Skip-testing-nanmin-on-float64-arrays-on-mips-el.patch
@@ -8,22 +8,23 @@ https://sourceware.org/binutils/docs/as/MIPS-NaN-Encodings.html
Discussion in the numpy bug: https://github.com/numpy/numpy/issues/23158
---
- src/silx/math/test/test_combo.py | 7 +++++++
- 1 file changed, 7 insertions(+)
+ src/silx/math/test/test_combo.py | 8 ++++++++
+ 1 file changed, 8 insertions(+)
diff --git a/src/silx/math/test/test_combo.py b/src/silx/math/test/test_combo.py
-index eed0625..bb3f4e4 100644
+index 917be55..1057344 100644
--- a/src/silx/math/test/test_combo.py
+++ b/src/silx/math/test/test_combo.py
-@@ -27,6 +27,7 @@ __license__ = "MIT"
+@@ -27,6 +27,8 @@ __license__ = "MIT"
__date__ = "17/01/2018"
+import sys
- import unittest
-
++
import numpy
-@@ -164,6 +165,9 @@ class TestMinMax(ParametricTestCase):
+
+ from silx.utils.testutils import ParametricTestCase
+@@ -161,6 +163,9 @@ class TestMinMax(ParametricTestCase):
def test_nandata(self):
"""Test min_max with NaN in data"""
for dtype in self.FLOATING_DTYPES:
@@ -33,7 +34,7 @@ index eed0625..bb3f4e4 100644
for data in self.NAN_TEST_DATA:
with self.subTest(dtype=dtype, data=data):
data = numpy.array(data, dtype=dtype)
-@@ -181,6 +185,9 @@ class TestMinMax(ParametricTestCase):
+@@ -178,6 +183,9 @@ class TestMinMax(ParametricTestCase):
def test_infdata(self):
"""Test min_max with inf."""
for dtype in self.FLOATING_DTYPES:
diff --git a/debian/patches/series b/debian/patches/series
index cb239bd..456e43f 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,8 +1,5 @@
0002-use-the-system-mathjax-privacy-breach.patch
-0003-do-not-modify-PYTHONPATH-from-setup.py.patch
0006-Tests-if-openCL-can-be-used.patch
0007-python3.10-fix.patch
-0007-do-not-install-scipy_spatial-COPYING.txt.patch
-0008-python3.11-fix.patch
0009-Skip-testing-nanmin-on-float64-arrays-on-mips-el.patch
0008-deal-with-h5py-until-we-solved-1051781.patch