summaryrefslogtreecommitdiff
path: root/patches/0007-add-install_requires-dependencies.patch
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2017-11-25 17:02:19 +0100
committerPicca Frédéric-Emmanuel <picca@debian.org>2017-11-25 17:02:19 +0100
commitf419d864bfd0f271bb0c3c2f5485f81fda869906 (patch)
tree057bfc1368eda812394ecb94a250380ffc1a86ba /patches/0007-add-install_requires-dependencies.patch
Import silx_0.6.1+dfsg-1.debian.tar.xz
[dgit import tarball silx 0.6.1+dfsg-1 silx_0.6.1+dfsg-1.debian.tar.xz]
Diffstat (limited to 'patches/0007-add-install_requires-dependencies.patch')
-rw-r--r--patches/0007-add-install_requires-dependencies.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/patches/0007-add-install_requires-dependencies.patch b/patches/0007-add-install_requires-dependencies.patch
new file mode 100644
index 0000000..8d5759b
--- /dev/null
+++ b/patches/0007-add-install_requires-dependencies.patch
@@ -0,0 +1,38 @@
+From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?=
+ <picca@synchrotron-soleil.fr>
+Date: Thu, 17 Aug 2017 09:30:39 +0200
+Subject: add install_requires dependencies
+
+---
+ setup.py | 18 +++++++++++++++++-
+ 1 file changed, 17 insertions(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index bede4df..c41df00 100644
+--- a/setup.py
++++ b/setup.py
+@@ -701,7 +701,23 @@ def get_project_configuration(dry_run):
+ # for most of the computation
+ "numpy",
+ # for the script launcher
+- "setuptools"]
++ "setuptools",
++ # Debian added
++ "ipython",
++ "qtconsole",
++ 'enum34;python_version<"3.4"',
++ "fabio",
++ "h5py",
++ "lxml",
++ "mako",
++ "matplotlib",
++ "PyOpenGL",
++ "pil",
++ "pyopencl",
++ "PyQt5",
++ "scipy",
++ "six"
++ ]
+
+ setup_requires = ["setuptools", "numpy"]
+