summaryrefslogtreecommitdiff
path: root/silx/math/setup.py
diff options
context:
space:
mode:
authorFrédéric-Emmanuel Picca <picca@debian.org>2018-08-08 14:09:02 +0200
committerFrédéric-Emmanuel Picca <picca@debian.org>2018-08-08 14:09:02 +0200
commit75271d5d9979b204baf8172b2a03da4330b14083 (patch)
tree22a2e31692654f1464c6fc8463cafe6598d9bdc4 /silx/math/setup.py
parent989033673e36f8d9959dd2d3a8285e5339bfae0c (diff)
parent302d3bcf3ef555284ce1bcf5cd7cd371addfa608 (diff)
Merge tag 'debian/0.8.0+dfsg-1' into debian/stretch-backports
silx release 0.8.0+dfsg-1 for unstable (sid) (maintainer view tag generated by dgit --quilt=gbp)
Diffstat (limited to 'silx/math/setup.py')
-rw-r--r--silx/math/setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/silx/math/setup.py b/silx/math/setup.py
index 8d54576..08272dd 100644
--- a/silx/math/setup.py
+++ b/silx/math/setup.py
@@ -1,6 +1,6 @@
# coding: utf-8
# /*##########################################################################
-# Copyright (C) 2016-2017 European Synchrotron Radiation Facility
+# Copyright (C) 2016-2018 European Synchrotron Radiation Facility
#
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to deal
@@ -75,6 +75,13 @@ def configuration(parent_package='', top_path=None):
include_dirs=['include'],
language='c')
+ config.add_extension('colormap',
+ sources=["colormap.pyx"],
+ language='c',
+ include_dirs=['include', numpy.get_include()],
+ extra_link_args=['-fopenmp'],
+ extra_compile_args=['-fopenmp'])
+
return config