summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index ea542b1..3dab5ee 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,6 +6,8 @@ export PYBUILD_AFTER_INSTALL=rm -rf {destdir}/usr/bin/
export PYBUILD_NAME=silx
export SPECFILE_USE_GNU_SOURCE=1
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
# Make does not offer a recursive wildcard function, so here's one:
rwildcard=$(wildcard $1$2) $(foreach d,$(wildcard $1*),$(call rwildcard,$d/,$2))
@@ -47,13 +49,13 @@ override_dh_install:
dh_install -p silx package/desktop/silx.xml usr/share/mime/packages
# install the qtdesigner files only for the python3 package
- dh_install -p python3-silx qtdesigner_plugins/*.py /usr/lib/qt4/plugins/designer/python
+ dh_install -p python3-silx qtdesigner_plugins/*.py /usr/lib/$(DEB_HOST_MULTIARCH)/qt5/plugins/designer/python
dh_install
override_dh_python3:
dh_python3
- dh_python3 -p python3-silx /usr/lib/qt4/plugins/designer/python
+ dh_python3 -p python3-silx /usr/lib/$(DEB_HOST_MULTIARCH)/qt5/plugins/designer/python
# WITH_QT_TEST=False to disable graphical tests
# SILX_OPENCL=False to disable OpenCL tests