summaryrefslogtreecommitdiff
path: root/requirements.txt
diff options
context:
space:
mode:
Diffstat (limited to 'requirements.txt')
-rw-r--r--requirements.txt16
1 files changed, 10 insertions, 6 deletions
diff --git a/requirements.txt b/requirements.txt
index fb5690d..a69d1ea 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -3,23 +3,27 @@
--trusted-host www.silx.org
--find-links http://www.silx.org/pub/wheelhouse/
---only-binary numpy,h5py,scipy,PySide2,PyQt5
+--only-binary numpy,h5py,scipy,PyQt5,PySide6,PyQt6
-# Required dependencies (from setup.py setup_requires and install_requires)
-numpy >= 1.12
+# Required dependencies
+# From pyproject.toml
+wheel
setuptools
+numpy >=1.12,<2
Cython >= 0.21.1
+# From setup.py install_requires
+packaging
h5py
fabio >= 0.9
-six
# Extra dependencies (from setup.py extra_requires 'full' target)
pyopencl; platform_machine in "i386, x86_64, AMD64" # For silx.opencl
Mako # For pyopencl reduction
qtconsole # For silx.gui.console
-matplotlib >= 1.2.0 # For silx.gui.plot
+matplotlib >= 3.1.0 # For silx.gui.plot
PyOpenGL # For silx.gui.plot3d
python-dateutil # For silx.gui.plot
scipy # For silx.math.fit demo, silx.image.sift demo, silx.image.sift.test
Pillow # For silx.opencl.image.test
-PyQt5 # or PySide2 # For silx.gui
+pint # For silx.io.dictdump
+PyQt5 # PySide6, PyQt6>=6.3 # For silx.gui