summaryrefslogtreecommitdiff
path: root/silx/io/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'silx/io/setup.py')
-rw-r--r--silx/io/setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/silx/io/setup.py b/silx/io/setup.py
index 4aaf324..9cafa17 100644
--- a/silx/io/setup.py
+++ b/silx/io/setup.py
@@ -51,7 +51,7 @@ else:
SPECFILE_USE_GNU_SOURCE = int(SPECFILE_USE_GNU_SOURCE)
if sys.platform == "win32":
- define_macros = [('WIN32', None)]
+ define_macros = [('WIN32', None), ('SPECFILE_POSIX', None)]
elif os.name.lower().startswith('posix'):
define_macros = [('SPECFILE_POSIX', None)]
# the best choice is to have _GNU_SOURCE defined