summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlessio Treglia <quadrispro@ubuntu.com>2009-12-03 13:03:13 +0100
committerAlessio Treglia <quadrispro@ubuntu.com>2009-12-03 13:03:13 +0100
commit8b022ab680a3f5e374a44f2c05c1671cfb2bc799 (patch)
treeaf20b9a16eeca697a1d30a554d8d1b31ae9c1e4f /configure.ac
parent5cd66eecc95be11cacc5aaf4db8c67a499bb2d4d (diff)
Imported Upstream version 11.1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac106
1 files changed, 37 insertions, 69 deletions
diff --git a/configure.ac b/configure.ac
index b85b0d5..5f726b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
# Configuration script for Snd
-AC_INIT(snd, 11.0, bil@ccrma.stanford.edu, ftp://ccrma-ftp.stanford.edu/pub/Lisp/snd-11.tar.gz)
+AC_INIT(snd, 11.1, bil@ccrma.stanford.edu, ftp://ccrma-ftp.stanford.edu/pub/Lisp/snd-11.tar.gz)
AC_CONFIG_SRCDIR(snd.c)
AC_CANONICAL_HOST
@@ -19,7 +19,7 @@ LOCAL_LANGUAGE="None"
GRAPHICS_TOOLKIT="None"
PACKAGE=Snd
-VERSION=11.0
+VERSION=11.1
AC_DEFINE_UNQUOTED(SND_PACKAGE, "$PACKAGE")
AC_DEFINE_UNQUOTED(SND_VERSION, "$VERSION")
AC_SUBST(SND_PACKAGE)
@@ -43,7 +43,7 @@ AC_DEFINE_UNQUOTED(SND_HOST, "$host")
# --with-gmp include multiprecision arithmetic via gmp, mpfr, and mpc
# --enable-snd-debug include Snd internal debugging stuff
# --enable-threads include pthread stuff [also "--with-threads" since I can't remember which is correct]
-# --disable-deprecated do not include any deprecated stuff (in gtk, motif, guile, sndlib, clm, etc)
+# --disable-deprecated do not include any deprecated stuff (in gtk, motif, s7, sndlib, clm, etc)
# --with-ladspa include LADSPA plugin support (Linux)
# --with-sample-width=N use N bits of samples (default = 24)
# --with-esd use Enlightened Sound Daemon
@@ -62,9 +62,9 @@ AC_DEFINE_UNQUOTED(SND_HOST, "$host")
# --with-temp-dir directory to use for temp files
# --with-save-dir directory to use for saved-state files
# --with-doc-dir directory to search for documentation
-# --with-gl include OpenGL support (default=no)
-# --with-just-gl include OpenGL support but omit the Guile bindings (gl.o) (default=no)
-# --with-gl2ps include gl2ps
+# --with-gl include OpenGL support (default=no, Motif only)
+# --with-just-gl include OpenGL support but omit the extension language bindings (default=no, Motif only)
+# --with-gl2ps include gl2ps (Motif only)
# --with-modules accommodate sndlib that was built with modules
# --with-editres include EditRes in xm
# --with-shared-sndlib load sndlib.so if possible
@@ -96,9 +96,9 @@ AC_ARG_WITH(static-gsl, [ --with-static-gsl use libgsl.a to build Snd (for o
AC_ARG_WITH(static-xm, [ --with-static-xm include the xm module])
AC_ARG_WITH(static-xg, [ --with-static-xg include the xg module])
AC_ARG_WITH(guile, [ --with-guile use Guile])
-AC_ARG_WITH(gl, [ --with-gl include OpenGL support])
-AC_ARG_WITH(just-gl, [ --with-just-gl include OpenGL support, but omit the GL/Guile bindings])
-AC_ARG_WITH(gl2ps, [ --with-gl2ps include gl2ps])
+AC_ARG_WITH(gl, [ --with-gl include OpenGL support, Motif only])
+AC_ARG_WITH(just-gl, [ --with-just-gl include OpenGL support, but omit the extension language bindings, Motif only])
+AC_ARG_WITH(gl2ps, [ --with-gl2ps include gl2ps, Motif only])
AC_ARG_WITH(motif, [ --with-motif use libXm to build Snd])
AC_ARG_WITH(static-motif,[ --with-static-motif use libXm.a to build Snd])
AC_ARG_WITH(modules, [ --with-modules use if sndlib uses modules])
@@ -124,6 +124,9 @@ AC_ARG_WITH(gmp, [ --with-gmp include multiprecision arithmetic via
AC_ARG_WITH(s7, [ --with-s7 use S7, default=yes])
AC_ARG_WITH(extension-language, [ --with-extension-language use some extension language, default=yes])
+# an experiment
+AC_ARG_WITH(directfb, [ --with-directfb use directfb config scripts, rather than gtk, default=no])
+
# -------- internal sample data type --------
@@ -404,20 +407,10 @@ if test "$with_fftw" != no; then
FFTW_LIBS="`$PKG_CONFIG fftw3 --libs`"
FFTW_CFLAGS="`$PKG_CONFIG fftw3 --cflags`"
AC_DEFINE(HAVE_FFTW3)
- OPTIONAL_LIBRARIES="$OPTIONAL_LIBRARIES fftw"
+ OPTIONAL_LIBRARIES="$OPTIONAL_LIBRARIES fftw3"
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)
- AC_MSG_CHECKING(for fftw2)
- if $PKG_CONFIG fftw --exists ; then
- FFTW_LIBS="`$PKG_CONFIG fftw --libs`"
- FFTW_CFLAGS="`$PKG_CONFIG fftw --cflags`"
- AC_DEFINE(HAVE_FFTW)
- OPTIONAL_LIBRARIES="$OPTIONAL_LIBRARIES fftw"
- AC_MSG_RESULT(yes)
- else
- AC_MSG_RESULT(no)
- fi
fi
else
SAVELIBS=$LIBS
@@ -427,19 +420,10 @@ if test "$with_fftw" != no; then
[fftw_plan plan; fftw_execute(plan)])],
[AC_MSG_RESULT(yes)
AC_DEFINE(HAVE_FFTW3)
- OPTIONAL_LIBRARIES="$OPTIONAL_LIBRARIES fftw"
+ OPTIONAL_LIBRARIES="$OPTIONAL_LIBRARIES fftw3"
FFTW_LIBS="-lfftw3"],
[AC_MSG_RESULT(no)
LIBS=$SAVELIBS
- LIBS="$LIBS -lrfftw -lfftw -lm"
- AC_MSG_CHECKING([for fftw-2])
- AC_LINK_IFELSE([AC_LANG_PROGRAM([#include <rfftw.h>],
- [rfftw_one(NULL, NULL, NULL)])],
- [AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_FFTW)
- OPTIONAL_LIBRARIES="$OPTIONAL_LIBRARIES fftw"
- FFTW_LIBS="-lrfftw -lfftw"],
- [AC_MSG_RESULT(no)])
])
LIBS=$SAVELIBS
fi
@@ -1012,7 +996,6 @@ else
fi
],
[
-# redundant... AC_MSG_RESULT(no)
AC_MSG_WARN([can't find the Motif library! -- will look for Gtk])
with_gtk=yes
with_motif=no
@@ -1066,7 +1049,11 @@ else
GTK_LD_LIBS="$GTK_LIBS"
if test x$PKG_CONFIG != xno ; then
- GTK_LD_LIBS="`$PKG_CONFIG gtk+-2.0 --libs-only-L` `$PKG_CONFIG gtk+-2.0 --libs-only-l`"
+ if test "$with_directfb" = yes ; then
+ GTK_LD_LIBS="`$PKG_CONFIG gtk+-directfb-2.0 --libs-only-L` `$PKG_CONFIG gtk+-directfb-2.0 --libs-only-l`"
+ else
+ GTK_LD_LIBS="`$PKG_CONFIG gtk+-2.0 --libs-only-L` `$PKG_CONFIG gtk+-2.0 --libs-only-l`"
+ fi
pango_version="`$PKG_CONFIG pango --modversion`"
AC_DEFINE_UNQUOTED(MUS_PANGO_VERSION,"${pango_version}")
fi
@@ -1147,8 +1134,10 @@ else
AC_CHECK_LIB(m, gtk_info_bar_new, [AC_DEFINE(HAVE_GTK_INFO_BAR_NEW)], ,$GTK_LIBS)
# for 2.17.3|4|5|6
AC_CHECK_LIB(m, gtk_status_icon_get_title, [AC_DEFINE(HAVE_GTK_STATUS_ICON_GET_TITLE)], ,$GTK_LIBS)
- # for 2.17.7
+ # for 2.17.7, 2.18.n
AC_CHECK_LIB(m, gtk_widget_get_visible, [AC_DEFINE(HAVE_GTK_WIDGET_GET_VISIBLE)], ,$GTK_LIBS)
+ # for 2.19.n
+ AC_CHECK_LIB(m, gtk_spinner_new, [AC_DEFINE(HAVE_GTK_SPINNER_NEW)], ,$GTK_LIBS)
# for gdk|pango_cairo
AC_CHECK_LIB(m, gdk_cairo_create,
@@ -1204,7 +1193,7 @@ GL_FILES=""
GL_FLAGS=""
have_gl=no
if test "$with_gl" = yes || test "$with_just_gl" = yes ; then
- if test "$with_motif" = yes || test "$with_gtk" = yes ; then
+ if test "$with_motif" = yes ; then
AC_CHECK_HEADER(GL/gl.h,
[have_gl=yes],
[
@@ -1230,30 +1219,9 @@ if test "$with_gl" = yes || test "$with_just_gl" = yes ; then
GL_LIBS="$GL_LIBS -lGLU"
])
GL_LIBS="$GL_LIBS -lGL"
- if test "$with_gtk" = yes ; then
- # motif uses built-in support, but gtk uses gtkglext, so we need to check for the latter
- if test x$PKG_CONFIG != xno && $PKG_CONFIG gtkglext-1.0 --exists ; then
- GL_LIBS="$GL_LIBS `$PKG_CONFIG gtkglext-1.0 --libs`"
- GL_FLAGS="$GL_FLAGS `$PKG_CONFIG gtkglext-1.0 --cflags`"
- AC_CHECK_LIB(m, gdk_gl_context_copy,
- [
- AC_DEFINE(HAVE_GDK_GL_CONTEXT_COPY)
- have_gl=yes
- OPTIONAL_LIBRARIES="$OPTIONAL_LIBRARIES gtkglext"
- ],
- [
- AC_MSG_WARN([gtkglext version is too old])
- have_gl=no
- ],
- $GL_LIBS)
- else
- have_gl=no
- AC_MSG_WARN([can't find gtkglext])
- fi
- fi
fi
else
- AC_MSG_WARN([GL only works with Motif or Gtk2])
+ AC_MSG_WARN([GL only works with Motif])
fi
fi
@@ -1471,7 +1439,7 @@ AC_ARG_WITH(ruby,
else
AC_MSG_WARN([can't find Ruby!])
AC_DEFINE(HAVE_RUBY,0)
- AC_DEFINE(HAVE_EXTENSION_LANGUAGE,0)
+# AC_DEFINE(HAVE_EXTENSION_LANGUAGE,0)
fi
fi)
@@ -1510,14 +1478,6 @@ AC_ARG_WITH(forth,
# Guile
#--------------------------------------------------------------------------------
-# TODO: change from guile-config to pkg-config guile-2.0.pc
-# if test x$PKG_CONFIG != xno ; then
-# if $PKG_CONFIG guile-2.0 --exists ; then
-# XEN_LIBS="`$PKG_CONFIG guile-2.0 --libs`"
-# XEN_CFLAGS="`$PKG_CONFIG guile-2.0 --cflags`"
-# fi
-# fi
-
if test "$with_guile" = yes && test "$ac_snd_have_extension_language" = yes ; then
with_guile=no
AC_MSG_WARN([You asked for both Guile and $LOCAL_LANGUAGE -- $LOCAL_LANGUAGE will be used])
@@ -1543,6 +1503,13 @@ if test "$with_guile" = no && test "$with_snd_as_pd_external" = no; then
AC_DEFINE(HAVE_GUILE,0)
else
+# if test x$PKG_CONFIG != xno ; then
+# if $PKG_CONFIG guile-2.0 --exists ; then
+# XEN_LIBS="`$PKG_CONFIG guile-2.0 --libs`"
+# XEN_CFLAGS="`$PKG_CONFIG guile-2.0 --cflags`"
+# fi
+# fi
+
AC_CHECK_FILE(/usr/lib/snd/bin/${GUILE_CONFIG_name},[
GUILE_CONFIG_path=/usr/lib/snd/bin/
GUILE_LIB_path=/usr/lib/snd/lib
@@ -1591,7 +1558,6 @@ if test $GUILE_CONFIG_works = yes; then
if test "`${GUILE_CONFIG_path}${GUILE_name} -c '(display (string>=? (version) "1.3.4"))'`" != "#t"; then
AC_MSG_WARN(Snd needs Guile 1.3.4 or later)
AC_DEFINE(HAVE_GUILE,0)
- AC_DEFINE(HAVE_EXTENSION_LANGUAGE,0)
else
AC_SUBST(XEN_CFLAGS)
if test "$XM_LIBS" = ""; then
@@ -2261,7 +2227,7 @@ fi
#--------------------------------------------------------------------------------
#
# look for sndlib-config, check mus_sample_bits against current choice [with-float-sample, with-sample-width]
-# also language (Guile, Ruby) needs to match (what about versions!) and audio choice
+# also language (s7, Ruby, Forth) needs to match (what about versions!) and audio choice
# check against needed version (17.2 for now -- need mus_vct_copy in vct.c)
# set SNDLIB_FILES and SNDLIB_LIB
@@ -2356,13 +2322,15 @@ AM_GNU_GETTEXT([external])
#--------------------------------------------------------------------------------
AC_ARG_ENABLE(deprecated,
- [ --disable-deprecated do not include any deprecated stuff from gtk, guile, motif, clm, or sndlib],
+ [ --disable-deprecated do not include any deprecated stuff from gtk, s7, motif, clm, snd, or sndlib],
if test "$enable_deprecated" = no ; then
CFLAGS="-DGTK_DISABLE_DEPRECATED -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED -DCAIRO_DISABLE_DEPRECATED $CFLAGS"
AC_DEFINE(XM_DISABLE_DEPRECATED)
AC_DEFINE(CLM_DISABLE_DEPRECATED)
AC_DEFINE(SNDLIB_DISABLE_DEPRECATED)
AC_DEFINE(XEN_DISABLE_DEPRECATED)
+ AC_DEFINE(S7_DISABLE_DEPRECATED)
+ AC_DEFINE(SND_DISABLE_DEPRECATED)
fi)
if test "$enable_snd_debug" = yes ; then
@@ -2419,7 +2387,7 @@ if test "$ac_snd_have_extension_language" = no ; then
if test "$ac_cv_header_dlfcn_h" = yes ; then
LDFLAGS="$LDFLAGS -ldl"
fi
- AC_MSG_WARN([Snd needs either an extension language (Guile, s7, Fth, or Ruby), or a graphics toolkit (Gtk or Motif), or preferably both. As currently configured, this version of Snd is useless.])
+ AC_MSG_WARN([Snd needs either an extension language (s7, Fth, Ruby, or Guile), or a graphics toolkit (Gtk or Motif), or preferably both. As currently configured, this version of Snd is useless.])
if test "$with_snd_as_pd_external" = yes ; then
AC_MSG_ERROR(Guile is needed when making snd as a pd external.)
fi