summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Shadura <andrew.shadura@collabora.co.uk>2016-05-14 12:41:44 +0100
committerAndrew Shadura <andrew.shadura@collabora.co.uk>2016-05-14 12:42:33 +0100
commitbc709f69885b5b85ed64843c9a0a139acaa85f6e (patch)
treea0af5dfa3e8bb2a0b76aa04dcde558663c6811e2
parente774a81006ef9a1c4e22e96c004b48307758fe07 (diff)
Apply the patches.debian/1.5.0-2
-rwxr-xr-xMakefile.am2
-rw-r--r--README.md2
-rwxr-xr-xSparkleShare/Linux/SparkleEventLog.cs1
-rw-r--r--SparkleShare/Linux/SparkleUI.cs2
-rw-r--r--SparkleShare/Linux/sparkleshare.desktop.appdata.xml27
-rwxr-xr-xSparkleShare/Linux/sparkleshare.in13
-rwxr-xr-xSparkleShare/Mac/SparkleEventLog.cs2
-rw-r--r--SparkleShare/Program.cs3
-rw-r--r--SparkleShare/Windows/README.md2
-rw-r--r--SparkleShare/Windows/SparkleSetup.cs2
-rwxr-xr-xbuild/build.environment.mk2
-rwxr-xr-xbuild/build.rules.mk2
-rwxr-xr-xbuild/m4/shamrock/mono.m46
-rwxr-xr-xconfigure.ac9
-rwxr-xr-xlegal/Authors.txt4
15 files changed, 64 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 47f3b20..6b54b1f 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,5 @@
+ACLOCAL_AMFLAGS = -I build/m4/sparkleshare -I build/m4/shamrock -I build/m4/shave
+
basedirs = build SparkleLib SparkleLib/Git
SUBDIRS = $(basedirs) $(GUISUBDIRS)
diff --git a/README.md b/README.md
index f029e78..a2908d7 100644
--- a/README.md
+++ b/README.md
@@ -25,7 +25,7 @@ Here are instructions to build SparkleShare on [Linux distributions](SparkleShar
## Useful links
-[Website](http://www.sparkleshare.org/), [Twitter](https://www.twitter.com/SparkleShare), [Wiki](https://www.github.com/hbons/SparkleShare/wiki), and [Source Code](https://www.github.com/hbons/SparkleShare). Join the chat: #sparkleshare on irc.gnome.org.
+[Website](http://www.sparkleshare.org/), [Twitter](https://www.twitter.com/SparkleShare), [Wiki](https://www.github.com/hbons/SparkleShare/wiki), and [Source Code](https://www.github.com/hbons/SparkleShare). Join the chat: `#sparkleshare` on `irc.gnome.org`.
## Finally
diff --git a/SparkleShare/Linux/SparkleEventLog.cs b/SparkleShare/Linux/SparkleEventLog.cs
index db6ff3f..8fcac27 100755
--- a/SparkleShare/Linux/SparkleEventLog.cs
+++ b/SparkleShare/Linux/SparkleEventLog.cs
@@ -70,6 +70,7 @@ namespace SparkleShare {
new Gdk.RGBA () { Red = 1, Green = 1, Blue=1, Alpha = 1 });
this.web_view = new WebView () { Editable = false };
+ this.web_view.Settings.EnablePlugins = false;
this.web_view.NavigationRequested += WebViewNavigationRequested;
this.scrolled_window.Add (this.web_view);
diff --git a/SparkleShare/Linux/SparkleUI.cs b/SparkleShare/Linux/SparkleUI.cs
index 4c5b27b..4bcc037 100644
--- a/SparkleShare/Linux/SparkleUI.cs
+++ b/SparkleShare/Linux/SparkleUI.cs
@@ -61,7 +61,7 @@ namespace SparkleShare {
public void Run ()
{
- (this.application as GLib.Application).Run (null, null);
+ (this.application as GLib.Application).Run (0, null);
}
diff --git a/SparkleShare/Linux/sparkleshare.desktop.appdata.xml b/SparkleShare/Linux/sparkleshare.desktop.appdata.xml
new file mode 100644
index 0000000..6df28d1
--- /dev/null
+++ b/SparkleShare/Linux/sparkleshare.desktop.appdata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop">
+ <id type="desktop">sparkleshare.desktop</id>
+ <metadata_licence>CC0-1.0</metadata_licence>
+ <project_license>GPL-3.0</project_license>
+ <name>SparkleShare</name>
+ <summary>Self hosted, instant, secure file sync</summary>
+ <description>
+ <p>SparkleShare creates a special folder on your computer. You can add remotely hosted folders (or "projects") to this folder. These projects will be automatically kept in sync with both the host and all of your peers when someone adds, removes or edits a file.</p>
+ <p>SparkleShare was made to cover certain use cases, but doesn't handle every scenario well. To help you decide if SparkleShare is right for you, here's a few examples of what it does well and less well:</p>
+ <p>Great:</p>
+ <ul>
+ <li>Frequently changing project files, like text, office documents, and images</li>
+ <li>Tracking and syncing files edited by multiple people</li>
+ <li>Reverting a file to any point in its history</li>
+ <li>Preventing spying on your files on the server using encryption</li>
+ </ul>
+ <p>Not so great:</p>
+ <ul>
+ <li>Full computer backups</li>
+ <li>Storing your photo or music collection</li>
+ <li>Large binary files that change often, like video editing projects</li>
+ </ul>
+ <p>Have fun!</p>
+ </description>
+ <url type="homepage">http://www.sparkleshare.org/</url>
+</component>
diff --git a/SparkleShare/Linux/sparkleshare.in b/SparkleShare/Linux/sparkleshare.in
index 5af417c..b53564c 100755
--- a/SparkleShare/Linux/sparkleshare.in
+++ b/SparkleShare/Linux/sparkleshare.in
@@ -8,6 +8,10 @@ fi
start() {
if [ -n "${SSH_AGENT_PID}" -o -n "${SSH_AUTH_SOCK}" ] ; then
mono "@expanded_libdir@/@PACKAGE@/SparkleShare.exe" $2 &
+ pid=$!
+ uid=`id -u`
+ mkdir -p /var/run/user/$uid/sparkleshare/
+ echo $pid > /var/run/user/$uid/sparkleshare/pidfile
else
ssh-agent mono "@expanded_libdir@/@PACKAGE@/SparkleShare.exe" $2 &
fi
@@ -23,6 +27,15 @@ case $1 in
curl --insecure --output ~/SparkleShare/.$invite.xml $open
start
;;
+ stop|--stop)
+ uid=`id -u`
+ if [ -e /var/run/user/$uid/sparkleshare/pidfile ] ; then
+ pid=`cat /var/run/user/$uid/sparkleshare/pidfile`
+ (kill $pid 2>&1) >/dev/null
+ rm /var/run/user/$uid/sparkleshare/pidfile
+ fi
+ ;;
+
*)
mono "@expanded_libdir@/@PACKAGE@/SparkleShare.exe" --help
;;
diff --git a/SparkleShare/Mac/SparkleEventLog.cs b/SparkleShare/Mac/SparkleEventLog.cs
index 6ea3c73..6859e1f 100755
--- a/SparkleShare/Mac/SparkleEventLog.cs
+++ b/SparkleShare/Mac/SparkleEventLog.cs
@@ -76,6 +76,8 @@ namespace SparkleShare {
new SizeF (ContentView.Frame.Width, ContentView.Frame.Height - 39))
};
+ this.web_view.Preferences.PlugInsEnabled = false;
+
this.cover = new NSBox () {
Frame = new RectangleF (
new PointF (-1, -1),
diff --git a/SparkleShare/Program.cs b/SparkleShare/Program.cs
index db3431b..1dfe811 100644
--- a/SparkleShare/Program.cs
+++ b/SparkleShare/Program.cs
@@ -46,8 +46,7 @@ namespace SparkleShare {
string n = Environment.NewLine;
Console.WriteLine (n +
- "SparkleShare is a collaboration and sharing tool that is" + n +
- "designed to keep things simple and to stay out of your way." + n +
+ "Share and collaborate by syncing with any Git repository instantly." + n +
n +
"Version: " + SparkleLib.SparkleBackend.Version + n +
"Copyright (C) 2010 Hylke Bons and others" + n +
diff --git a/SparkleShare/Windows/README.md b/SparkleShare/Windows/README.md
index 17ff4a6..e53fdf8 100644
--- a/SparkleShare/Windows/README.md
+++ b/SparkleShare/Windows/README.md
@@ -6,7 +6,7 @@ You can choose to build SparkleShare from source or to run the Windows installer
Install version 4.0 of the [.NET Framework](http://www.microsoft.com/download/en/details.aspx?id=17851) if you haven't already.
-Install [msysGit](http://msysgit.github.io/) and copy the contents of the install folder
+Install [msysGit](https://github.com/msysgit/msysgit/releases) and copy the contents of the install folder
(`C:\Program Files (x86)\Git` by default) to `C:\path\to\SparkleShare-sources\bin\msysgit\` (create the "bin"-folder in the SparkleShare source directory).
Open a command prompt and execute the following:
diff --git a/SparkleShare/Windows/SparkleSetup.cs b/SparkleShare/Windows/SparkleSetup.cs
index d51d69e..cbf306b 100644
--- a/SparkleShare/Windows/SparkleSetup.cs
+++ b/SparkleShare/Windows/SparkleSetup.cs
@@ -509,7 +509,7 @@ namespace SparkleShare {
help_block.Inlines.Add (new Bold (new Run (Controller.PreviousUrl)));
help_block.Inlines.Add (" is the address we’ve compiled. Does this look alright?\n\n");
- help_block.Inlines.Add ("Is this computer’s Client ID known by the host??");
+ help_block.Inlines.Add ("Is this computer’s Client ID known by the host?");
if (warnings.Length > 0) {
bullets_block.Text += "\n\n•";
diff --git a/build/build.environment.mk b/build/build.environment.mk
index 8fd2b44..3793053 100755
--- a/build/build.environment.mk
+++ b/build/build.environment.mk
@@ -19,7 +19,7 @@ REF_SPARKLELIB = $(LINK_SYSTEM) $(LINK_MONO_POSIX)
LINK_SPARKLELIB = -r:$(DIR_BIN)/SparkleLib.dll
LINK_SPARKLELIB_DEPS = $(REF_SPARKLELIB) $(LINK_SPARKLELIB)
-REF_SPARKLESHARE = $(LINK_GTK) $(LINK_SPARKLELIB_DEPS) $(LINK_APP_INDICATOR) $(LINK_WEBKIT)
+REF_SPARKLESHARE = $(LINK_NUNIT) $(LINK_GTK) $(LINK_SPARKLELIB_DEPS) $(LINK_APP_INDICATOR) $(LINK_WEBKIT)
# Cute hack to replace a space with something
colon:= :
diff --git a/build/build.rules.mk b/build/build.rules.mk
index 0beed5c..8766280 100755
--- a/build/build.rules.mk
+++ b/build/build.rules.mk
@@ -19,7 +19,7 @@ ASSEMBLY_FILE = $(top_builddir)/bin/$(ASSEMBLY).$(ASSEMBLY_EXTENSION)
INSTALL_DIR_RESOLVED = $(firstword $(subst , $(DEFAULT_INSTALL_DIR), $(INSTALL_DIR)))
if ENABLE_TESTS
- LINK = " $(NUNIT_LIBS)"
+ LINK_NUNIT = "$(NUNIT_LIBS)"
ENABLE_TESTS_FLAG = "-define:ENABLE_TESTS"
endif
diff --git a/build/m4/shamrock/mono.m4 b/build/m4/shamrock/mono.m4
index 393eaa3..8981305 100755
--- a/build/m4/shamrock/mono.m4
+++ b/build/m4/shamrock/mono.m4
@@ -13,6 +13,11 @@ AC_DEFUN([SHAMROCK_FIND_MONO_4_0_COMPILER],
SHAMROCK_FIND_PROGRAM_OR_BAIL(MCS, dmcs)
])
+AC_DEFUN([SHAMROCK_FIND_MONO_4_5_COMPILER],
+[
+ SHAMROCK_FIND_PROGRAM_OR_BAIL(MCS, mcs)
+])
+
AC_DEFUN([SHAMROCK_FIND_MONO_RUNTIME],
[
SHAMROCK_FIND_PROGRAM_OR_BAIL(MONO, mono)
@@ -65,4 +70,3 @@ AC_DEFUN([SHAMROCK_CHECK_MONO_GAC_ASSEMBLIES],
fi
done
])
-
diff --git a/configure.ac b/configure.ac
index ad67db6..76acec6 100755
--- a/configure.ac
+++ b/configure.ac
@@ -5,6 +5,9 @@ AC_PREREQ([2.54])
AC_INIT([SparkleShare], sparkleshare_version)
AM_INIT_AUTOMAKE([1.11 dist-bzip2 dist-zip foreign tar-pax])
AM_MAINTAINER_MODE
+LT_INIT
+
+AC_CONFIG_MACRO_DIRS([build/m4/sparkleshare build/m4/shamrock build/m4/shave])
dnl Export Version Info
AC_SUBST([ASM_VERSION], [sparkleshare_version])
@@ -15,8 +18,6 @@ if test "x$PKG_CONFIG" = "xno"; then
AC_MSG_ERROR([You need to install pkg-config])
fi
-AC_SUBST([ACLOCAL_AMFLAGS], ["-I build/m4/sparkleshare -I build/m4/shamrock -I build/m4/shave \${ACLOCAL_FLAGS}"])
-
SHAMROCK_EXPAND_LIBDIR
SHAMROCK_EXPAND_BINDIR
SHAMROCK_EXPAND_DATADIR
@@ -27,8 +28,8 @@ dnl Mono and gmcs
SHAMROCK_CHECK_MONO_MODULE(2.8)
SHAMROCK_FIND_MONO_RUNTIME
-PKG_CHECK_EXISTS([mono >= 2.8],
-[SHAMROCK_FIND_MONO_4_0_COMPILER
+PKG_CHECK_EXISTS([mono >= 3.2.8],
+[SHAMROCK_FIND_MONO_4_5_COMPILER
SHAMROCK_CHECK_MONO_GAC_ASSEMBLIES([
System
])]
diff --git a/legal/Authors.txt b/legal/Authors.txt
index b15e2ec..186ac29 100755
--- a/legal/Authors.txt
+++ b/legal/Authors.txt
@@ -12,7 +12,7 @@ Code:
Chris Magee <chris.magee@gametheworld.com>
Gabriel Burt <gabriel.burt@gmail.com>
Garrett LeSage <garrett@novell.com>
- Hylke Bons <hylkebons@gmail.com>
+ Hylke Bons <hi@planetpeanut.uk>
Jonathan Haines <jonno.haines@gmail.com>
Kristi Tsukida <kristi.tsukida@gmail.com>
Konstantinos Vaggelakos <kozze89@gmail.com>
@@ -39,7 +39,7 @@ Design:
Andreas Nilsson <andreasn@gnome.org>
Jakub Steiner <jimmac@redhat.com>
- Hylke Bons <hylkebons@gmail.com>
+ Hylke Bons <hi@planetpeanut.uk>
Lapo Calamandrei <calamandrei@gmail.com>
Sam Hewitt <hewittsamuel@gmail.com>