summaryrefslogtreecommitdiff
path: root/SparkleLib
diff options
context:
space:
mode:
authorCarlos Martín Nieto <carlos@cmartin.tk>2011-12-02 15:19:05 +0100
committerCarlos Martín Nieto <carlos@cmartin.tk>2011-12-02 15:19:05 +0100
commit0ffa88036ca9f092dcfc76b6ed34a7656d925b47 (patch)
tree7a47fd4b7cd8280f4d81480921590e2ed1c22271 /SparkleLib
parent2e25c2ce40b79215d6d1226da7b5eafcac3dd3d3 (diff)
Imported Upstream version 0.4.2
Diffstat (limited to 'SparkleLib')
-rw-r--r--SparkleLib/AssemblyInfo.cs2
-rw-r--r--SparkleLib/Defines.cs2
-rwxr-xr-xSparkleLib/Git/SparkleFetcherGit.cs7
-rwxr-xr-xSparkleLib/Git/SparkleRepoGit.cs6
-rw-r--r--SparkleLib/Makefile.in8
5 files changed, 13 insertions, 12 deletions
diff --git a/SparkleLib/AssemblyInfo.cs b/SparkleLib/AssemblyInfo.cs
index 2f4b094..73ec2ee 100644
--- a/SparkleLib/AssemblyInfo.cs
+++ b/SparkleLib/AssemblyInfo.cs
@@ -7,5 +7,5 @@
using System.Reflection;
using System.Runtime.CompilerServices;
-[assembly: AssemblyVersion("0.4.1")]
+[assembly: AssemblyVersion("0.4.2")]
[assembly: AssemblyTitle ("SparkleShare")]
diff --git a/SparkleLib/Defines.cs b/SparkleLib/Defines.cs
index a06a8ee..080de40 100644
--- a/SparkleLib/Defines.cs
+++ b/SparkleLib/Defines.cs
@@ -20,7 +20,7 @@ namespace SparkleLib {
public class Defines {
- public const string VERSION = "0.4.1";
+ public const string VERSION = "0.4.2";
public const string LOCALE_DIR = "/usr/local/share/locale";
public const string DATAROOTDIR = "/usr/local/share";
public const string GETTEXT_PACKAGE = "sparkleshare";
diff --git a/SparkleLib/Git/SparkleFetcherGit.cs b/SparkleLib/Git/SparkleFetcherGit.cs
index f9f7803..79ad2a8 100755
--- a/SparkleLib/Git/SparkleFetcherGit.cs
+++ b/SparkleLib/Git/SparkleFetcherGit.cs
@@ -203,9 +203,10 @@ namespace SparkleLib {
// Add a .gitignore file to the repo
private void InstallExcludeRules ()
{
- string exlude_rules_file_path = SparkleHelpers.CombineMore (
- this.target_folder, ".git", "info", "exclude");
+ DirectoryInfo info = Directory.CreateDirectory (SparkleHelpers.CombineMore (
+ this.target_folder, ".git", "info"));
+ string exlude_rules_file_path = Path.Combine (info.FullName, "exclude");
TextWriter writer = new StreamWriter (exlude_rules_file_path);
// gedit and emacs
@@ -238,7 +239,7 @@ namespace SparkleLib {
writer.WriteLine ("Thumbs.db");
writer.WriteLine ("Desktop.ini");
- // MS Office
+ // MS Office
writer.WriteLine ("~*.tmp");
writer.WriteLine ("~*.TMP");
writer.WriteLine ("*~*.tmp");
diff --git a/SparkleLib/Git/SparkleRepoGit.cs b/SparkleLib/Git/SparkleRepoGit.cs
index 2bba8c0..dd90378 100755
--- a/SparkleLib/Git/SparkleRepoGit.cs
+++ b/SparkleLib/Git/SparkleRepoGit.cs
@@ -533,8 +533,12 @@ namespace SparkleLib {
FillEmptyDirectories (child_path);
}
- if (Directory.GetFiles (path).Length == 0 && !path.Equals (LocalPath))
+ if (Directory.GetFiles (path).Length == 0 &&
+ Directory.GetDirectories (path).Length == 0 &&
+ !path.Equals (LocalPath)) {
+
File.Create (Path.Combine (path, ".empty")).Close ();
+ }
}
diff --git a/SparkleLib/Makefile.in b/SparkleLib/Makefile.in
index 20f7e66..f3c2078 100644
--- a/SparkleLib/Makefile.in
+++ b/SparkleLib/Makefile.in
@@ -39,7 +39,8 @@ DIST_COMMON = $(srcdir)/AssemblyInfo.cs.in $(srcdir)/Defines.cs.in \
$(top_srcdir)/build/build.rules.mk
subdir = SparkleLib
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
-am__aclocal_m4_deps = $(top_srcdir)/build/m4/shave/shave.m4 \
+am__aclocal_m4_deps = $(top_srcdir)/build/m4/gnome-doc-utils.m4 \
+ $(top_srcdir)/build/m4/shave/shave.m4 \
$(top_srcdir)/build/m4/shamrock/expansions.m4 \
$(top_srcdir)/build/m4/shamrock/gnome-doc.m4 \
$(top_srcdir)/build/m4/shamrock/mono.m4 \
@@ -100,8 +101,6 @@ CYGPATH_W = @CYGPATH_W@
DATADIRNAME = @DATADIRNAME@
DEFS = @DEFS@
DEPDIR = @DEPDIR@
-DISTCHECK_CONFIGURE_FLAGS = @DISTCHECK_CONFIGURE_FLAGS@
-DOC_USER_FORMATS = @DOC_USER_FORMATS@
ECHO_C = @ECHO_C@
ECHO_N = @ECHO_N@
ECHO_T = @ECHO_T@
@@ -121,7 +120,6 @@ GTKSHARP_A11Y_LIBS = @GTKSHARP_A11Y_LIBS@
GTKSHARP_CFLAGS = @GTKSHARP_CFLAGS@
GTKSHARP_LIBS = @GTKSHARP_LIBS@
GUISUBDIRS = @GUISUBDIRS@
-HELP_DIR = @HELP_DIR@
INSTALL = @INSTALL@
INSTALL_DATA = @INSTALL_DATA@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
@@ -135,7 +133,6 @@ LDFLAGS = @LDFLAGS@
LIBOBJS = @LIBOBJS@
LIBS = @LIBS@
LIBTOOL = @LIBTOOL@
-LN_S = @LN_S@
LTLIBOBJS = @LTLIBOBJS@
MAINT = @MAINT@
MAKEFLAGS = @MAKEFLAGS@
@@ -159,7 +156,6 @@ NUNIT_CFLAGS = @NUNIT_CFLAGS@
NUNIT_LIBS = @NUNIT_LIBS@
OBJC = @OBJC@
OBJEXT = @OBJEXT@
-OMF_DIR = @OMF_DIR@
PACKAGE = @PACKAGE@
PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
PACKAGE_NAME = @PACKAGE_NAME@