summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.org2
-rw-r--r--debian/changelog42
-rw-r--r--debian/compat1
-rw-r--r--debian/control15
-rw-r--r--spinner.el38
5 files changed, 73 insertions, 25 deletions
diff --git a/README.org b/README.org
index 4fb4a4a..06c7b32 100644
--- a/README.org
+++ b/README.org
@@ -73,4 +73,4 @@ defined in the ~spinner-types~ variable or even define your own.
Both ~spinner-start~ and ~spinner-create~ take extra options to configure the spinner, these are:
- ~FPS~: The number of frames to display per second. Defaults to ~spinner-frames-per-second~.
-- ~DELAY~: After startin a spinner, it still won’t be displayed for this many seconds.
+- ~DELAY~: After starting a spinner, it still won’t be displayed for this many seconds.
diff --git a/debian/changelog b/debian/changelog
index b0cc2ca..6d86ff8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,45 @@
+spinner-el (1.7.4-2) unstable; urgency=medium
+
+ * Adopt the package from Sean Whitton (Closes: #1007860).
+
+ * d/control:
+ - Bump Standards version to 4.5.1 (no changes required).
+ - Bump debhelper compat to 13.
+ - Added optional Rules-Requires-Root field to respect Debian Policy.
+ - Canonicalise Vcs-Git field (added .git suffix, canonical for remotes'
+ urls).
+
+ -- Aymeric Agon-Rambosson <aymeric.agon@yandex.com> Sun, 31 Jul 2022 05:18:08 +0200
+
+spinner-el (1.7.4-1) unstable; urgency=medium
+
+ [ Sean Whitton ]
+ * New upstream release.
+
+ [ Nicholas D Steeves ]
+ * Drop emacs25 from Enhances (package does not exist in bullseye).
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Tue, 21 Dec 2021 13:24:04 -0700
+
+spinner-el (1.7.3-3) unstable; urgency=medium
+
+ * Team upload
+
+ [ David Krauser ]
+ * Update maintainer email address
+
+ [ David Bremner ]
+ * Rebuild with dh-elpa 2.x
+
+ -- David Bremner <bremner@debian.org> Sat, 23 Jan 2021 07:36:43 -0400
+
+spinner-el (1.7.3-2) unstable; urgency=medium
+
+ * Team upload.
+ * Rebuild with current dh-elpa
+
+ -- David Bremner <bremner@debian.org> Thu, 29 Aug 2019 07:30:20 -0300
+
spinner-el (1.7.3-1) unstable; urgency=medium
* Initial release (Closes: #885349).
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index f599e28..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-10
diff --git a/debian/control b/debian/control
index db80530..8ca5c79 100644
--- a/debian/control
+++ b/debian/control
@@ -1,21 +1,22 @@
Source: spinner-el
Section: lisp
Priority: optional
-Maintainer: Debian Emacs addons team <pkg-emacsen-addons@lists.alioth.debian.org>
-Uploaders: Sean Whitton <spwhitton@spwhitton.name>
-Build-Depends: debhelper (>= 10),
+Maintainer: Debian Emacsen Team <debian-emacsen@lists.debian.org>
+Uploaders: Aymeric Agon-Rambosson <aymeric.agon@yandex.com>
+Build-Depends:
+ debhelper-compat (= 13),
dh-elpa
-Standards-Version: 4.1.2
+Standards-Version: 4.5.1
+Rules-Requires-Root: no
Vcs-Browser: https://salsa.debian.org/emacsen-team/spinner-el
-Vcs-Git: https://salsa.debian.org/emacsen-team/spinner-el
+Vcs-Git: https://salsa.debian.org/emacsen-team/spinner-el.git
Homepage: https://github.com/Malabarba/spinner.el
Package: elpa-spinner
Architecture: all
Depends: ${elpa:Depends}, ${misc:Depends}
Recommends: emacs (>= 46.0)
-Enhances: emacs,
- emacs25
+Enhances: emacs
Description: spinner for the Emacs modeline for operations in progress
This library provides functions to add spinners to the Emacs
modeline. Spinners are used to indicate that an operation is in
diff --git a/spinner.el b/spinner.el
index b227eba..6be8f13 100644
--- a/spinner.el
+++ b/spinner.el
@@ -3,7 +3,8 @@
;; Copyright (C) 2015 Free Software Foundation, Inc.
;; Author: Artur Malabarba <emacs@endlessparentheses.com>
-;; Version: 1.7.3
+;; Version: 1.7.4
+;; Package-Requires: ((emacs "24.3"))
;; URL: https://github.com/Malabarba/spinner.el
;; Keywords: processes mode-line
@@ -98,7 +99,7 @@
;;; Code:
(eval-when-compile
- (require 'cl))
+ (require 'cl-lib))
(defconst spinner-types
'((3-line-clock . ["┤" "┘" "┴" "└" "├" "┌" "┬" "┐"])
@@ -118,7 +119,7 @@
(box-in-box . ["◰" "◳" "◲" "◱"])
(box-in-circle . ["◴" "◷" "◶" "◵"])
(half-circle . ["◐" "◓" "◑" "◒"])
- (moon . ["🌑" "🌘" "🌖" "🌕" "🌔" "🌒"]))
+ (moon . ["🌑" "🌘" "🌗" "🌖" "🌕" "🌔" "🌓" "🌒"]))
"Predefined alist of spinners.
Each car is a symbol identifying the spinner, and each cdr is a
vector, the spinner itself.")
@@ -126,7 +127,7 @@ vector, the spinner itself.")
(defun spinner-make-progress-bar (width &optional char)
"Return a vector of strings of the given WIDTH.
The vector is a valid spinner type and is similar to the
-`progress-bar' spinner, except without the sorrounding brackets.
+`progress-bar' spinner, except without the surrounding brackets.
CHAR is the character to use for the moving bar (defaults to =)."
(let ((whole-string (concat (make-string (1- width) ?\s)
(make-string 4 (or char ?=))
@@ -135,7 +136,7 @@ CHAR is the character to use for the moving bar (defaults to =)."
(number-sequence (+ width 3) 0 -1)))))
(defvar spinner-current nil
- "Spinner curently being displayed on the `mode-line-process'.")
+ "Spinner currently being displayed on the `mode-line-process'.")
(make-variable-buffer-local 'spinner-current)
(defconst spinner--mode-line-construct
@@ -176,10 +177,10 @@ own spinner animations."
((symbolp type) (cdr (assq type spinner-types)))
(t (error "Unknown spinner type: %s" type))))
-(defstruct (spinner
- (:copier nil)
- (:conc-name spinner--)
- (:constructor make-spinner (&optional type buffer-local frames-per-second delay-before-start)))
+(cl-defstruct (spinner
+ (:copier nil)
+ (:conc-name spinner--)
+ (:constructor make-spinner (&optional type buffer-local frames-per-second delay-before-start)))
(frames (spinner--type-to-frames type))
(counter 0)
(fps (or frames-per-second spinner-frames-per-second))
@@ -205,7 +206,7 @@ buffer, use that instead of current buffer.
When started, in order to function properly, the spinner runs a
timer which periodically calls `force-mode-line-update' in the
-curent buffer. If BUFFER-LOCAL was set at creation time, then
+current buffer. If BUFFER-LOCAL was set at creation time, then
`force-mode-line-update' is called in that buffer instead. When
the spinner is stopped, the timer is deactivated.
@@ -234,9 +235,9 @@ stop the SPINNER's timer."
(and buffer (not (buffer-live-p buffer))))
(spinner-stop spinner)
;; Increment
- (callf (lambda (x) (if (< x 0)
- (1+ x)
- (% (1+ x) (length (spinner--frames spinner)))))
+ (cl-callf (lambda (x) (if (< x 0)
+ (1+ x)
+ (% (1+ x) (length (spinner--frames spinner)))))
(spinner--counter spinner))
;; Update mode-line.
(if (buffer-live-p buffer)
@@ -254,8 +255,9 @@ stop the SPINNER's timer."
(unless (ignore-errors (> (spinner--fps spinner) 0))
(error "A spinner's FPS must be a positive number"))
- (setf (spinner--counter spinner) (round (- (* (or (spinner--delay spinner) 0)
- (spinner--fps spinner)))))
+ (setf (spinner--counter spinner)
+ (round (- (* (or (spinner--delay spinner) 0)
+ (spinner--fps spinner)))))
;; Create timer.
(let* ((repeat (/ 1.0 (spinner--fps spinner)))
(time (timer-next-integral-multiple-of-time (current-time) repeat))
@@ -301,7 +303,8 @@ this time, in which case it won't display at all."
(setq spinner-current (make-spinner type-or-object (current-buffer) fps delay)))
(setq type-or-object spinner-current)
;; Maybe add to mode-line.
- (unless (memq 'spinner--mode-line-construct mode-line-process)
+ (unless (and (listp mode-line-process)
+ (memq 'spinner--mode-line-construct mode-line-process))
(setq mode-line-process
(list (or mode-line-process "")
'spinner--mode-line-construct))))
@@ -331,4 +334,7 @@ active spinner."
(provide 'spinner)
+;; Local Variables:
+;; indent-tabs-mode: nil
+;; End:
;;; spinner.el ends here