summaryrefslogtreecommitdiff
path: root/conf.sh
diff options
context:
space:
mode:
authormwesdorp <mwesdorp>2015-07-10 11:07:03 +0000
committerSteve Langasek <vorlon@debian.org>2018-09-25 18:10:15 +0000
commit1ee7cedc9310dee5c7bce513276d250df1c6fc53 (patch)
tree92b36a311f08af0abffd1eeb4b61330fcb00e0f9 /conf.sh
parent083cb6d573e20ada6f6ebdf208018b4f86172e2b (diff)
Cherry-pick 6dc2299: sqsh-3.0 new features and bugfixes. Closes: #891671.
Diffstat (limited to 'conf.sh')
-rwxr-xr-xconf.sh26
1 files changed, 13 insertions, 13 deletions
diff --git a/conf.sh b/conf.sh
index 9f11399..eefe230 100755
--- a/conf.sh
+++ b/conf.sh
@@ -16,12 +16,12 @@
# Note that it is not needed anymore in sqsh-2.5 to explicitly set the -DSYB_LP64
# precompiler flag for 64 bit compilations. "configure" will set this flag for
# 64 bit compilations automatically in the src/Makefile.
-export CC="gcc"
-export CPPFLAGS=""
+#export CC="gcc"
+#export CPPFLAGS=""
# export CPPFLAGS="-DSYB_LP64"
-export CFLAGS="-g -O2 -Wall -m64"
-export LDFLAGS="-s -m64"
-./configure
+#export CFLAGS="-g -O2 -Wall -m64"
+#export LDFLAGS="-s -m64"
+#./configure
#
# Below are some additional examples
@@ -50,11 +50,11 @@ export LDFLAGS="-s -m64"
#
# An example with some paranoia compiler settings
#
-# CC="gcc" \
-# CFLAGS="-g -O2 -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fomit-frame-pointer \
-# -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 \
-# -mtune=generic -fasynchronous-unwind-tables" \
-# LDFLAGS="-s -m64" \
-# ./configure --prefix=/usr/local --sysconfdir=/usr/local/etc --with-readline \
-# --with-debug --without-devlib --without-static --with-gcc --with-x --with-motif
-#
+CC="gcc" \
+CFLAGS="-g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fomit-frame-pointer \
+-fexceptions -fstack-protector --param=ssp-buffer-size=4 \
+-mtune=generic -fasynchronous-unwind-tables" \
+LDFLAGS="" \
+./configure --prefix=/usr/local --sysconfdir=/usr/local/etc --with-readline \
+ --with-debug --without-devlib --without-static --with-gcc --with-x --with-motif
+