summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2013-02-27 18:43:12 +0000
committerSteve Langasek <vorlon@debian.org>2018-09-25 11:06:18 -0700
commit1820bfece11221f886d062d315d71534b363bb19 (patch)
treed67f6ad6cf335f1a65f2d5521448ae5fdff72375 /debian
parent47ac209e94e2cb1a4eeb5d9b7eba87b3eba81576 (diff)
Fix up LDFLAGS handling so we get relro hardening.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/rules3
2 files changed, 4 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 77af655..8a60260 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ sqsh (2.1.7-2) UNRELEASED; urgency=low
* Explicitly link to libXt instead of relying on lesstif to provide this.
Thanks to Graham Inggs <graham@nerve.org.za> for the patch. (LP: #1134233)
+ * Fix up LDFLAGS handling so we get relro hardening.
-- Steve Langasek <vorlon@debian.org> Wed, 27 Feb 2013 10:03:31 -0800
diff --git a/debian/rules b/debian/rules
index b2fcc5e..f3473d6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,5 +9,8 @@ override_dh_auto_configure:
cp -f /usr/share/misc/config.sub autoconf/config.sub
SYBASE=/usr dh_auto_configure -- --with-readline --with-motif
+override_dh_auto_build:
+ dh_auto_build -- LDFLAGS="$$(dpkg-buildflags --get LDFLAGS)"
+
override_dh_auto_install:
dh_auto_install --destdir=debian/tmp