summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2011-09-04 09:04:47 +0000
committerSteve Langasek <vorlon@debian.org>2018-09-24 20:29:09 -0700
commitda5b5bbe7dc07f7159f771388b4b4ea80084d72b (patch)
tree41831e6f5efbd51f7208dd3cee3937bf18e4fac5 /debian
parent2eeb89d122a0ca078ad27912b53af4714d4d9dd8 (diff)
* configure.in, aclocal.m4: nuke the custom 'AC_FIND_LIB' macro and
sybase library filesystem walking from orbit; this does all the wrong things that AC_CHECK_LIB is designed to avoid, and results in us not finding freetds now that it's multiarched. Closes: #639195. * configure.in, aclocal.m4: call 'test' instead of the non-portable '[[', just in case. * aclocal.m4: don't link against extra libraries on Linux that we don't need. * Bump to debhelper 7 and dh. * Bump Standards Version to 3.9.2, no changes needed.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog15
-rw-r--r--debian/clean1
-rw-r--r--debian/control4
-rw-r--r--debian/dirs1
-rw-r--r--debian/examples1
-rwxr-xr-xdebian/rules86
-rw-r--r--debian/sqsh.install1
-rw-r--r--debian/sqsh.manpages1
8 files changed, 33 insertions, 77 deletions
diff --git a/debian/changelog b/debian/changelog
index 27b4115..f7a8ff3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,18 @@
+sqsh (2.1-10) unstable; urgency=low
+
+ * configure.in, aclocal.m4: nuke the custom 'AC_FIND_LIB' macro and
+ sybase library filesystem walking from orbit; this does all the wrong
+ things that AC_CHECK_LIB is designed to avoid, and results in us not
+ finding freetds now that it's multiarched. Closes: #639195.
+ * configure.in, aclocal.m4: call 'test' instead of the non-portable '[[',
+ just in case.
+ * aclocal.m4: don't link against extra libraries on Linux that we don't
+ need.
+ * Bump to debhelper 7 and dh.
+ * Bump Standards Version to 3.9.2, no changes needed.
+
+ -- Steve Langasek <vorlon@debian.org> Sun, 04 Sep 2011 01:04:47 +0000
+
sqsh (2.1-9) unstable; urgency=low
* Build-depend on libreadline-dev instead of libreadline5-dev.
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 0000000..6c28579
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1 @@
+autoconf/config.sub
diff --git a/debian/control b/debian/control
index 10debb7..77a4042 100644
--- a/debian/control
+++ b/debian/control
@@ -2,9 +2,9 @@ Source: sqsh
Section: utils
Priority: optional
Maintainer: Steve Langasek <vorlon@debian.org>
-Build-Depends: debhelper (>= 7), freetds-dev (>= 0.63), lesstif2-dev, libreadline-dev, autotools-dev
+Build-Depends: debhelper (>= 7.0.50~), freetds-dev (>= 0.63), lesstif2-dev, libreadline-dev, autotools-dev
Build-Conflicts: tcl-dev
-Standards-Version: 3.8.3
+Standards-Version: 3.9.2
Homepage: http://sourceforge.net/projects/sqsh/
Package: sqsh
diff --git a/debian/dirs b/debian/dirs
deleted file mode 100644
index e772481..0000000
--- a/debian/dirs
+++ /dev/null
@@ -1 +0,0 @@
-usr/bin
diff --git a/debian/examples b/debian/examples
index ceec67d..9d7e7dc 100644
--- a/debian/examples
+++ b/debian/examples
@@ -1,3 +1,4 @@
doc/advanced.sqshrc
doc/global.sqshrc
doc/sample.sqshrc
+debian/tmp/usr/etc/sqshrc
diff --git a/debian/rules b/debian/rules
index fc374c6..d7a23df 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,6 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
CFLAGS = -g -Wall
-INSTALL = install
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
@@ -14,76 +8,20 @@ else
CFLAGS += -O2
endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL += -s
-endif
-
-# Authoritative build/host types for the Debian archen.
-DEB_HOST_GNU_TYPE := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE := $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
- confflags += --build $(DEB_HOST_GNU_TYPE)
-else
- confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
-endif
+%:
+ dh $@
-configure: configure-stamp
-configure-stamp:
- dh_testdir
+override_dh_auto_configure:
cp -f /usr/share/misc/config.sub autoconf/config.sub
- SYBASE=/usr ./configure $(confflags) --prefix=/usr \
- --mandir=\$${prefix}/share/man --sysconfdir=/etc/ \
- --with-readline --with-motif
- touch configure-stamp
-
-build: configure-stamp build-stamp
-build-stamp:
- dh_testdir
-
- $(MAKE) SQSHRC_GLOBAL=/etc/sqshrc
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- dh_clean
-
- [ ! -f Makefile ] || $(MAKE) distclean
- rm -f autoconf/config.sub
-
-install: build
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs
-
- $(MAKE) install prefix=$(CURDIR)/debian/sqsh/usr
- $(MAKE) install.man man_dir=$(CURDIR)/debian/sqsh/usr/share/man
+ SYBASE=/usr dh_auto_configure -- --with-readline --with-motif
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
+override_dh_auto_build:
+ dh_auto_build -- SQSHRC_GLOBAL=/etc/sqshrc
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installdocs
- dh_installexamples debian/sqsh/usr/etc/sqshrc
- -rm -rf $(CURDIR)/debian/sqsh/usr/etc
- dh_installmenu
- dh_installman
- dh_installchangelogs
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
+override_dh_auto_install:
+ $(MAKE) install prefix=$(CURDIR)/debian/tmp/usr
+ $(MAKE) install.man man_dir=$(CURDIR)/debian/tmp/usr/share/man
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+override_dh_installexamples:
+ dh_installexamples
+ rm -rf $(CURDIR)/debian/tmp/usr/etc
diff --git a/debian/sqsh.install b/debian/sqsh.install
new file mode 100644
index 0000000..d6bb572
--- /dev/null
+++ b/debian/sqsh.install
@@ -0,0 +1 @@
+usr/bin/sqsh
diff --git a/debian/sqsh.manpages b/debian/sqsh.manpages
new file mode 100644
index 0000000..f2d3cb0
--- /dev/null
+++ b/debian/sqsh.manpages
@@ -0,0 +1 @@
+debian/tmp/usr/share/man/man1/sqsh.1