summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2018-09-25 06:51:01 +0000
committerSteve Langasek <vorlon@debian.org>2018-09-25 18:10:19 +0000
commit0aef8b06db193fab83ea0b5680ee2482e1cefbe1 (patch)
tree2a998bbee89ed7358d8b2f923ea1e0fcf967b8c3 /src
parent3272b569c43b62059c31b81b7a36c642424e2065 (diff)
src/Makefile.in: handle building of the requisite sqsh_parse.a library (which should be done using automake + libtool, but, well)
Diffstat (limited to 'src')
-rw-r--r--src/Makefile.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.in b/src/Makefile.in
index 93c822a..fbfa502 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -204,10 +204,10 @@ MAN_PAGES = sqsh.1
SRCS = $(OBJS:.o=.c)
HEADERS =
-$(TARGET) : $(OBJS) sqsh_main.o
+$(TARGET) : $(OBJS) sqsh_main.o @SQSH_PARSE_LIB@
$(CC) $(LDFLAGS) $(OBJS) sqsh_main.o $(LIBS) -o $@
-sqsh_test : $(OBJS) sqsh_test.o
+sqsh_test : $(OBJS) sqsh_test.o @SQSH_PARSE_LIB@
$(CC) $(LDFLAGS) $(OBJS) sqsh_test.o $(LIBS) -o $@
sig_test : sqsh_debug.o sqsh_error.o sqsh_sig.c
@@ -223,6 +223,8 @@ realclean : clean
distclean : realclean
rm -f Makefile config.h core
+sqsh_parser/sqsh_parser.a:
+ make -C sqsh_parser libsqsh
#
# The following absolutely disgusting list of dependancies was
# automatically generated via 'gcc -MM'