summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames McCoy <jamessan@debian.org>2022-12-16 17:25:35 -0500
committerJames McCoy <jamessan@debian.org>2024-01-01 09:34:52 -0500
commit454cb657ad1f0576d1402d4efa8b1d656ce1ef81 (patch)
treeca8cc7f37f038fc02cbf5789292ee2cdb69351b1
parent93252177cf952f424c91b0615f34316aeb91f165 (diff)
Add future=+lfs build options to ensure use of 64-bit filesystem APIs
Signed-off-by: James McCoy <jamessan@debian.org>
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index cb01c59..a03e39b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,11 +12,13 @@
include /usr/share/dpkg/architecture.mk
+DEB_BUILD_MAINT_OPTIONS=future=+lfs
+
# Workaround an issue with PIC/PIE on certain architectures (c.f., #942798)
ifneq (,$(filter x32,$(DEB_HOST_ARCH)))
- DEB_BUILD_MAINT_OPTIONS=hardening=+all,-pie
+ DEB_BUILD_MAINT_OPTIONS+=hardening=+all,-pie
else
- DEB_BUILD_MAINT_OPTIONS=hardening=+all
+ DEB_BUILD_MAINT_OPTIONS+=hardening=+all
endif
include /usr/share/dpkg/default.mk