summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorJames McCoy <jamessan@debian.org>2014-01-18 00:57:16 +0000
committerJames McCoy <jamessan@debian.org>2014-01-18 00:57:16 +0000
commit3c7234ad751b798c0d93dd5cd06159b4833e126e (patch)
tree58c0b918ced8059dd32cf38f77b199b5fc2db540 /debian/patches
parentb2acbe2cf7efeb6b8748e7af380fe2cc56b3b9f5 (diff)
Add patches/swig-pl_build_fix, from upstream, to fix a build failure when
configure is run with --enable-sqlite-compatibility.
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/swig-pl_build_fix37
2 files changed, 38 insertions, 0 deletions
diff --git a/debian/patches/series b/debian/patches/series
index 5a9382a..89b3e28 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -16,3 +16,4 @@ examples-compile-instructions
apache_module_dependency
workaround_EINVAL_on_kfreebsd
sqlite_3.8.x_workaround
+swig-pl_build_fix
diff --git a/debian/patches/swig-pl_build_fix b/debian/patches/swig-pl_build_fix
new file mode 100644
index 0000000..3740f60
--- /dev/null
+++ b/debian/patches/swig-pl_build_fix
@@ -0,0 +1,37 @@
+------------------------------------------------------------------------
+r1559009 | breser | 2014-01-16 23:54:43 -0500 (Thu, 16 Jan 2014) | 9 lines
+
+swig-pl: Fix when configure is passed --enable-sqlite-compatibility-version
+
+* subversion/bindings/swig/perl/native/Makefile.PL.in
+ ($cppflags, $cflags): Set from autoconf with here documents to avoid quoting
+ issues.
+
+Patch by: James McCoy <jamessan{_AT_}debian.org>
+
+
+
+--- a/subversion/bindings/swig/perl/native/Makefile.PL.in
++++ b/subversion/bindings/swig/perl/native/Makefile.PL.in
+@@ -51,10 +51,17 @@
+ }
+
+ my $apr_shlib_path_var = '@SVN_APR_SHLIB_PATH_VAR@';
+-my $cppflags = '@CPPFLAGS@';
+-my $cflags = '@CFLAGS@';
++my $cppflags = <<'EOT';
++@CPPFLAGS@
++EOT
++my $cflags = <<'EOT';
++@CFLAGS@
++EOT
+ my $includes = '@SVN_APR_INCLUDES@ @SVN_APRUTIL_INCLUDES@';
+
++chomp($cppflags);
++chomp($cflags);
++
+ # Avoid this bug in SWIG:
+ # https://sourceforge.net/tracker/?func=detail&aid=3571361&group_id=1645&atid=101645
+ # SWIG is using C++ style comments in an extern "C" code.
+
+------------------------------------------------------------------------