summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/patches/build-fixes41
-rw-r--r--debian/patches/java-build2
-rw-r--r--debian/patches/last-changed-date-charset2
-rw-r--r--debian/patches/loosen-sqlite-version-check12
-rw-r--r--debian/patches/no-extra-libs-237
-rw-r--r--debian/patches/python-builds22
-rw-r--r--debian/patches/repos-templates14
-rw-r--r--debian/patches/rpath26
-rw-r--r--debian/patches/ruby-no-strict-aliasing2
-rw-r--r--debian/patches/ruby-test-svnserve-race2
-rw-r--r--debian/patches/ssh-no-controlmaster2
11 files changed, 77 insertions, 85 deletions
diff --git a/debian/patches/build-fixes b/debian/patches/build-fixes
index 8703fdf..4a0d91b 100644
--- a/debian/patches/build-fixes
+++ b/debian/patches/build-fixes
@@ -29,7 +29,7 @@ Fix some build problems:
% " ".join(checkout_locations))
--- a/Makefile.in
+++ b/Makefile.in
-@@ -286,14 +286,14 @@
+@@ -290,14 +290,14 @@
# The path to generated and complementary source files for the SWIG
# bindings.
@@ -49,16 +49,7 @@ Fix some build problems:
### Automate JAR creation using Makefile generator's javahl-java.jar
### property. Enhance generator to support JAR installation.
-@@ -731,7 +731,7 @@
- swig-pl_DEPS = autogen-swig-pl libsvn_swig_perl \
- $(SWIG_PL_DIR)/native/Makefile
- swig-pl: $(swig-pl_DEPS)
-- if test "$(SWIG_PL_DIR)" != "$(SWIG_PL_SRC_DIR)"; then \
-+ if test "$$(cd $(SWIG_PL_DIR);pwd)" != "$(SWIG_PL_SRC_DIR)"; then \
- ln -sf $(SWIG_PL_SRC_DIR)/native/*.c $(SWIG_PL_DIR)/native; \
- fi
- cd $(SWIG_PL_DIR)/native; $(MAKE) OPTIMIZE="" OTHERLDFLAGS="$(SWIG_LDFLAGS)"
-@@ -754,8 +754,7 @@
+@@ -770,8 +770,7 @@
fi
for d in $(SWIG_PL_DIR)/libsvn_swig_perl; \
do \
@@ -68,7 +59,7 @@ Fix some build problems:
done
if [ -f "$(SWIG_PL_DIR)/native/Makefile" ]; then \
cd $(SWIG_PL_DIR)/native; $(MAKE) clean; \
-@@ -788,7 +787,7 @@
+@@ -804,7 +803,7 @@
fi
for d in $(SWIG_PY_DIR) $(SWIG_PY_DIR)/libsvn_swig_py; \
do \
@@ -77,7 +68,7 @@ Fix some build problems:
done
find $(SWIG_PY_SRC_DIR) $(SWIG_PY_DIR) -name "*.pyc" -exec rm {} ';'
-@@ -812,8 +811,7 @@
+@@ -828,8 +827,7 @@
fi
for d in $(SWIG_RB_DIR) $(SWIG_RB_DIR)/libsvn_swig_ruby; \
do \
@@ -89,7 +80,7 @@ Fix some build problems:
extraclean-swig-rb: clean-swig-rb
--- a/build/generator/gen_base.py
+++ b/build/generator/gen_base.py
-@@ -313,7 +313,8 @@
+@@ -333,7 +333,8 @@
class SWIGSource(SourceFile):
def __init__(self, filename):
@@ -112,8 +103,8 @@ Fix some build problems:
for fname in self.includes:
--- a/configure.ac
+++ b/configure.ac
-@@ -1245,6 +1245,11 @@
- AC_SUBST(SVN_CONFIG_SCRIPT_FILES)
+@@ -1355,6 +1355,11 @@
+ rm -f .swig_checked
AC_OUTPUT
+if test "$abs_srcdir" != "$abs_builddir"
@@ -126,7 +117,7 @@ Fix some build problems:
--- a/build.conf
+++ b/build.conf
-@@ -197,7 +197,7 @@
+@@ -196,7 +196,7 @@
description = Subversion Client Library
type = lib
path = subversion/libsvn_client
@@ -135,7 +126,7 @@ Fix some build problems:
install = lib
msvc-export = svn_client.h private/svn_client_private.h
-@@ -260,7 +260,7 @@
+@@ -259,7 +259,7 @@
description = Subversion Repository Access Library
type = lib
path = subversion/libsvn_ra
@@ -144,7 +135,7 @@ Fix some build problems:
# conditionally add more dependencies
add-deps = $(SVN_RA_LIB_DEPS)
add-install-deps = $(SVN_RA_LIB_INSTALL_DEPS)
-@@ -701,13 +701,14 @@
+@@ -703,13 +703,14 @@
# ----------------------------------------------------------------------------
# Tests for libsvn_subr
@@ -168,14 +159,12 @@ Fix some build problems:
description = Test in-memory cache
--- a/build/generator/templates/makefile.ezt
+++ b/build/generator/templates/makefile.ezt
-@@ -73,8 +73,8 @@
+@@ -73,7 +73,7 @@
# Section 4: Rules to build SWIG .c files from .i files
########################################
[for swig_c]
--[swig_c.c_file]:[for swig_c.deps] [swig_c.deps][end]
-- $(SWIG) $(SWIG_INCLUDES) [swig_c.opts] -o $@ $(top_srcdir)/[swig_c.source][end]
-+$(top_srcdir)/[swig_c.c_file]: [swig_c.source] [for swig_c.deps] [swig_c.deps][end]
-+ $(SWIG) $(SWIG_INCLUDES) [swig_c.opts] -o $@ $<[end]
-
+-[swig_c.c_file]: .swig_checked [for swig_c.deps] [swig_c.deps][end]
++$(top_srcdir)/[swig_c.c_file]: .swig_checked [for swig_c.deps] [swig_c.deps][end]
+ $(SWIG) $(SWIG_INCLUDES) [swig_c.opts] -o $@ $(top_srcdir)/[swig_c.source][end]
- ########################################
+ # This needs to be here, rather than in Makefile.in, else
diff --git a/debian/patches/java-build b/debian/patches/java-build
index 9512fa7..2428e9c 100644
--- a/debian/patches/java-build
+++ b/debian/patches/java-build
@@ -4,7 +4,7 @@ Patch is originally from Nobuhiro Iwamatsu, bug #561516.
--- a/build/generator/templates/makefile.ezt
+++ b/build/generator/templates/makefile.ezt
-@@ -90,7 +90,8 @@
+@@ -99,7 +99,8 @@
[if-any target.headers][target.varname]_CLASS_FILENAMES =[for target.header_class_filenames] [target.header_class_filenames][end]
[target.varname]_CLASSES =[for target.header_classes] [target.header_classes][end]
$([target.varname]_HEADERS): $([target.varname]_CLASS_FILENAMES)
diff --git a/debian/patches/last-changed-date-charset b/debian/patches/last-changed-date-charset
index e7a7cc5..02b2f5f 100644
--- a/debian/patches/last-changed-date-charset
+++ b/debian/patches/last-changed-date-charset
@@ -5,7 +5,7 @@ Not accepted upstream: http://svn.haxx.se/dev/archive-2006-04/0730.shtml
--- a/subversion/libsvn_subr/subst.c
+++ b/subversion/libsvn_subr/subst.c
-@@ -199,8 +199,12 @@
+@@ -200,8 +200,12 @@
break;
case 'D': /* long format of date of this revision */
if (date)
diff --git a/debian/patches/loosen-sqlite-version-check b/debian/patches/loosen-sqlite-version-check
index 26bcc27..16324ef 100644
--- a/debian/patches/loosen-sqlite-version-check
+++ b/debian/patches/loosen-sqlite-version-check
@@ -7,12 +7,12 @@ slightly more liberal shlibs file than the library version itself.
--- a/subversion/libsvn_subr/sqlite.c
+++ b/subversion/libsvn_subr/sqlite.c
-@@ -486,7 +486,7 @@ static volatile svn_atomic_t sqlite_init
+@@ -740,7 +740,7 @@
static svn_error_t *
init_sqlite(void *baton, apr_pool_t *pool)
{
-- if (sqlite3_libversion_number() < SQLITE_VERSION_NUMBER) {
-+ if (sqlite3_libversion_number()/1000 < SQLITE_VERSION_NUMBER/1000) {
- return svn_error_createf(SVN_ERR_SQLITE_ERROR, NULL,
- _("SQLite compiled for %s, but running with %s"),
- SQLITE_VERSION, sqlite3_libversion());
+- if (sqlite3_libversion_number() < SQLITE_VERSION_NUMBER)
++ if (sqlite3_libversion_number()/1000 < SQLITE_VERSION_NUMBER/1000)
+ {
+ return svn_error_createf(
+ SVN_ERR_SQLITE_ERROR, NULL,
diff --git a/debian/patches/no-extra-libs-2 b/debian/patches/no-extra-libs-2
index 11043ec..0a15051 100644
--- a/debian/patches/no-extra-libs-2
+++ b/debian/patches/no-extra-libs-2
@@ -6,7 +6,7 @@ _at all_, so we don't want it to pull in aprutil for us.)
--- a/build.conf
+++ b/build.conf
-@@ -110,7 +110,7 @@
+@@ -109,7 +109,7 @@
type = exe
path = subversion/svn
libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_diff libsvn_subr
@@ -15,7 +15,7 @@ _at all_, so we don't want it to pull in aprutil for us.)
manpages = subversion/svn/svn.1
install = bin
-@@ -155,7 +155,7 @@
+@@ -154,7 +154,7 @@
description = Subversion repository replicator
type = exe
path = subversion/svnsync
@@ -24,16 +24,16 @@ _at all_, so we don't want it to pull in aprutil for us.)
install = bin
manpages = subversion/svnsync/svnsync.1
-@@ -596,7 +596,7 @@
+@@ -606,7 +606,7 @@
type = lib
path = subversion/bindings/javahl/native
libs = libsvn_repos libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_diff
- libsvn_subr libsvn_fs aprutil apriconv apr neon
+ libsvn_subr libsvn_fs apriconv apr
sources = *.cpp *.c
- add-deps = $(javahl_javah_DEPS) $(javahl_java_DEPS) $(javahl_callback_javah_DEPS)
+ add-deps = $(javahl_javah_DEPS) $(javahl_java_DEPS) $(javahl_callback_javah_DEPS) $(javahl_types_javah_DEPS)
install = javahl-lib
-@@ -1023,7 +1023,7 @@
+@@ -1040,7 +1040,7 @@
[apriconv]
type = lib
@@ -42,7 +42,7 @@ _at all_, so we don't want it to pull in aprutil for us.)
[bdb]
type = lib
-@@ -1162,7 +1162,7 @@
+@@ -1188,7 +1188,7 @@
path = tools/client-side/svnmucc
sources = svnmucc.c
install = tools
@@ -53,32 +53,31 @@ _at all_, so we don't want it to pull in aprutil for us.)
type = exe
--- a/subversion/bindings/swig/perl/native/Makefile.PL.in
+++ b/subversion/bindings/swig/perl/native/Makefile.PL.in
-@@ -46,7 +46,12 @@
- fs_base
- fs_util
- fs_fs/));
--my @ldmodules = map {"-lsvn_$_-1"} (@modules, qw/diff subr/);
+@@ -43,6 +43,12 @@
+ ra_serf fs_base fs_util fs_fs/);
+
+ my @ldmodules = map {"-lsvn_$_-1"} (@modules, qw/diff subr/);
+sub libs_line {
-+ return join(' ', $apr_ldflags,
-+ (map {$_ = abs_path($_); "-L$_"} @ldpaths),
-+ (map {"-lsvn_$_-1"} @_),
-+ '-lsvn_swig_perl-1', `$swig -perl -ldflags`);
++ return join(' ', $apr_ldflags,
++ (map {"-L$_"} @ldpaths),
++ (map {"-lsvn_$_-1"} @_),
++ '-lsvn_swig_perl-1', qx($swig -perl -ldflags));
+}
my $apr_shlib_path_var = '@SVN_APR_SHLIB_PATH_VAR@';
my $cppflags = '@CPPFLAGS@';
-@@ -71,10 +76,6 @@
+@@ -67,10 +73,6 @@
" -I$svnlib_builddir",
" -I$swig_srcdir -g"),
OBJECT => q/$(O_FILES)/,
- LIBS => [join(' ', $apr_ldflags,
-- (map {$_ = abs_path($_); "-L$_"} @ldpaths),
+- (map {"-L$_"} @ldpaths),
- @ldmodules, '-lsvn_swig_perl-1',
- `$swig -perl -ldflags`)],
test => { TESTS => "$swig_srcdir/perl/native/t/*.t" }
);
-@@ -84,6 +85,7 @@
+@@ -80,6 +82,7 @@
$_;
}
@@ -86,7 +85,7 @@ _at all_, so we don't want it to pull in aprutil for us.)
WriteMakefile(%config, NAME => 'SVN::_Core', C => ['core.c'],
PM => {map { ("$swig_srcdir/perl/native/$_.pm" =>
"\$(INST_LIBDIR)/$_.pm") }
-@@ -98,6 +100,7 @@
+@@ -94,6 +97,7 @@
);
for (@modules) {
diff --git a/debian/patches/python-builds b/debian/patches/python-builds
index b9ed230..c1d1e13 100644
--- a/debian/patches/python-builds
+++ b/debian/patches/python-builds
@@ -6,7 +6,7 @@ Submitted upstream: http://svn.haxx.se/dev/archive-2008-05/0361.shtml
--- a/Makefile.in
+++ b/Makefile.in
-@@ -131,6 +131,7 @@
+@@ -132,6 +132,7 @@
APACHE_LDFLAGS = @APACHE_LDFLAGS@
SWIG = @SWIG@
@@ -16,7 +16,7 @@ Submitted upstream: http://svn.haxx.se/dev/archive-2008-05/0361.shtml
SWIG_PY_LINK = @SWIG_PY_LINK@
--- a/build/ac-macros/swig.m4
+++ b/build/ac-macros/swig.m4
-@@ -112,7 +112,8 @@
+@@ -109,7 +109,8 @@
AC_CACHE_CHECK([for Python includes], [ac_cv_python_includes],[
ac_cv_python_includes="`$PYTHON ${abs_srcdir}/build/get-py-info.py --includes`"
])
@@ -26,7 +26,7 @@ Submitted upstream: http://svn.haxx.se/dev/archive-2008-05/0361.shtml
if test "$ac_cv_python_includes" = "none"; then
AC_MSG_WARN([python bindings cannot be built without distutils module])
-@@ -285,6 +286,7 @@
+@@ -282,6 +283,7 @@
AC_MSG_RESULT([$SWIG_RB_TEST_VERBOSE])
fi
AC_SUBST(SWIG)
@@ -36,7 +36,7 @@ Submitted upstream: http://svn.haxx.se/dev/archive-2008-05/0361.shtml
AC_SUBST(SWIG_PY_LINK)
--- a/build.conf
+++ b/build.conf
-@@ -415,7 +415,7 @@
+@@ -413,7 +413,7 @@
type = swig
path = subversion/bindings/swig
sources = core.i
@@ -45,7 +45,7 @@ Submitted upstream: http://svn.haxx.se/dev/archive-2008-05/0361.shtml
libsvn_diff libsvn_subr apr
description = Subversion core library bindings
include-runtime = yes
-@@ -424,7 +424,7 @@
+@@ -422,7 +422,7 @@
type = swig
path = subversion/bindings/swig
sources = svn_client.i
@@ -54,7 +54,7 @@ Submitted upstream: http://svn.haxx.se/dev/archive-2008-05/0361.shtml
libsvn_client libsvn_subr apr
nonlibs = swig_core
description = Subversion client library bindings
-@@ -433,7 +433,7 @@
+@@ -431,7 +431,7 @@
type = swig
path = subversion/bindings/swig
sources = svn_delta.i
@@ -63,7 +63,7 @@ Submitted upstream: http://svn.haxx.se/dev/archive-2008-05/0361.shtml
libsvn_delta libsvn_subr apr
nonlibs = swig_core
description = Subversion delta library bindings
-@@ -442,7 +442,7 @@
+@@ -440,7 +440,7 @@
type = swig
path = subversion/bindings/swig
sources = svn_diff.i
@@ -72,7 +72,7 @@ Submitted upstream: http://svn.haxx.se/dev/archive-2008-05/0361.shtml
libsvn_diff libsvn_subr apr
nonlibs = swig_core
description = Subversion diff library bindings
-@@ -451,7 +451,7 @@
+@@ -449,7 +449,7 @@
type = swig
path = subversion/bindings/swig
sources = svn_fs.i
@@ -81,7 +81,7 @@ Submitted upstream: http://svn.haxx.se/dev/archive-2008-05/0361.shtml
libsvn_fs libsvn_subr apr
nonlibs = swig_core
description = Subversion FS library bindings
-@@ -460,7 +460,7 @@
+@@ -458,7 +458,7 @@
type = swig
path = subversion/bindings/swig
sources = svn_ra.i
@@ -90,7 +90,7 @@ Submitted upstream: http://svn.haxx.se/dev/archive-2008-05/0361.shtml
libsvn_ra libsvn_subr apr
nonlibs = swig_core
description = Subversion RA library bindings
-@@ -469,7 +469,7 @@
+@@ -467,7 +467,7 @@
type = swig
path = subversion/bindings/swig
sources = svn_repos.i
@@ -99,7 +99,7 @@ Submitted upstream: http://svn.haxx.se/dev/archive-2008-05/0361.shtml
libsvn_repos libsvn_subr apr
nonlibs = swig_core
description = Subversion repository library bindings
-@@ -478,13 +478,13 @@
+@@ -476,13 +476,13 @@
type = swig
path = subversion/bindings/swig
sources = svn_wc.i
diff --git a/debian/patches/repos-templates b/debian/patches/repos-templates
index f532f50..75b1e7c 100644
--- a/debian/patches/repos-templates
+++ b/debian/patches/repos-templates
@@ -5,7 +5,7 @@ hooks, not just use them in place.
--- a/subversion/libsvn_repos/repos.c
+++ b/subversion/libsvn_repos/repos.c
-@@ -287,7 +287,7 @@
+@@ -275,7 +275,7 @@
#define PREWRITTEN_HOOKS_TEXT \
"# For more examples and pre-written hooks, see those in" NL \
@@ -14,7 +14,7 @@ hooks, not just use them in place.
"# http://svn.apache.org/repos/asf/subversion/trunk/tools/hook-scripts/ and" NL \
"# http://svn.apache.org/repos/asf/subversion/trunk/contrib/hook-scripts/" NL
-@@ -366,8 +366,11 @@
+@@ -354,8 +354,11 @@
"REPOS=\"$1\"" NL
"USER=\"$2\"" NL
"" NL
@@ -28,7 +28,7 @@ hooks, not just use them in place.
"" NL
"# All checks passed, so allow the commit." NL
"exit 0" NL;
-@@ -454,10 +457,13 @@
+@@ -442,10 +445,13 @@
"$SVNLOOK log -t \"$TXN\" \"$REPOS\" | \\" NL
" grep \"[a-zA-Z0-9]\" > /dev/null || exit 1" NL
"" NL
@@ -44,7 +44,7 @@ hooks, not just use them in place.
"" NL
"# All checks passed, so allow the commit." NL
"exit 0" NL;
-@@ -840,7 +846,7 @@
+@@ -756,7 +762,7 @@
"REPOS=\"$1\"" NL
"REV=\"$2\"" NL
NL
@@ -53,7 +53,7 @@ hooks, not just use them in place.
#undef SCRIPT_NAME
-@@ -901,7 +907,8 @@
+@@ -817,7 +823,8 @@
"USER=\"$2\"" NL
"" NL
"# Send email to interested parties, let them know a lock was created:" NL
@@ -63,7 +63,7 @@ hooks, not just use them in place.
#undef SCRIPT_NAME
-@@ -960,7 +967,8 @@
+@@ -876,7 +883,8 @@
"USER=\"$2\"" NL
"" NL
"# Send email to interested parties, let them know a lock was removed:" NL
@@ -73,7 +73,7 @@ hooks, not just use them in place.
#undef SCRIPT_NAME
-@@ -1025,8 +1033,8 @@
+@@ -941,8 +949,8 @@
"PROPNAME=\"$4\"" NL
"ACTION=\"$5\"" NL
"" NL
diff --git a/debian/patches/rpath b/debian/patches/rpath
index aef20c6..f4f32f3 100644
--- a/debian/patches/rpath
+++ b/debian/patches/rpath
@@ -8,18 +8,22 @@ patch by David Kimdon <dwhedon@debian.org>. The basic theory is:
--- a/Makefile.in
+++ b/Makefile.in
-@@ -201,8 +201,9 @@
+@@ -203,10 +203,10 @@
COMPILE_JAVAHL_JAVAC = $(JAVAC) $(JAVAC_FLAGS)
COMPILE_JAVAHL_JAVAH = $(JAVAH)
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(libdir)
+-LINK_LIB = $(LINK) $(LT_SO_VERSION)
+-LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS) -rpath $(libdir)
+-LINK_CXX_LIB = $(LINK_CXX) $(LT_SO_VERSION)
+LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
- LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS) -rpath $(libdir)
-+LINK_LIB = $(LINK) -rpath $(libdir)
++LINK_LIB = $(LINK) $(LT_SO_VERSION) -rpath $(libdir)
++LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS)
++LINK_CXX_LIB = $(LINK_CXX) $(LT_SO_VERSION) -rpath $(libdir)
# special link rule for mod_dav_svn
LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS)
-@@ -726,7 +727,9 @@
+@@ -736,7 +736,9 @@
./config.status subversion/bindings/swig/perl/native/Makefile.PL
$(SWIG_PL_DIR)/native/Makefile: $(SWIG_PL_DIR)/native/Makefile.PL
@@ -28,11 +32,11 @@ patch by David Kimdon <dwhedon@debian.org>. The basic theory is:
+ $(PERL) Makefile.PL INSTALLDIRS=vendor; \
+ sed -i -e '/^LD_RUN_PATH/s/^/#/' Makefile Makefile.[a-z]*
- swig-pl_DEPS = autogen-swig-pl libsvn_swig_perl \
- $(SWIG_PL_DIR)/native/Makefile
+ # There is a "readlink -f" command on some systems for the same purpose,
+ # but it's not as portable (e.g. Mac OS X doesn't have it). These should
--- a/build.conf
+++ b/build.conf
-@@ -489,7 +489,7 @@
+@@ -487,7 +487,7 @@
lang = python
path = subversion/bindings/swig/python/libsvn_swig_py
libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_subr apriconv apr
@@ -41,7 +45,7 @@ patch by David Kimdon <dwhedon@debian.org>. The basic theory is:
install = swig-py-lib
# need special build rule to include -DSWIGPYTHON
compile-cmd = $(COMPILE_SWIG_PY)
-@@ -512,7 +512,7 @@
+@@ -510,7 +510,7 @@
lang = ruby
path = subversion/bindings/swig/ruby/libsvn_swig_ruby
libs = libsvn_client libsvn_wc libsvn_delta libsvn_subr apriconv apr
@@ -52,7 +56,7 @@ patch by David Kimdon <dwhedon@debian.org>. The basic theory is:
compile-cmd = $(COMPILE_SWIG_RB)
--- a/build/generator/gen_base.py
+++ b/build/generator/gen_base.py
-@@ -387,7 +387,7 @@
+@@ -407,7 +407,7 @@
self.install = options.get('install')
self.compile_cmd = options.get('compile-cmd')
self.sources = options.get('sources', '*.c *.cpp')
@@ -61,7 +65,7 @@ patch by David Kimdon <dwhedon@debian.org>. The basic theory is:
self.external_lib = options.get('external-lib')
self.external_project = options.get('external-project')
-@@ -439,6 +439,7 @@
+@@ -459,6 +459,7 @@
extmap = self.gen_obj._extension_map
self.objext = extmap['exe', 'object']
self.filename = build_path_join(self.path, name + extmap['exe', 'target'])
@@ -71,7 +75,7 @@ patch by David Kimdon <dwhedon@debian.org>. The basic theory is:
self.testing = options.get('testing')
--- a/build/generator/templates/makefile.ezt
+++ b/build/generator/templates/makefile.ezt
-@@ -117,7 +117,7 @@
+@@ -126,7 +126,7 @@
########################################
[for areas]
[is areas.type "apache-mod"]install-mods-shared:[for areas.files] [areas.files.fullname][end][for areas.files]
diff --git a/debian/patches/ruby-no-strict-aliasing b/debian/patches/ruby-no-strict-aliasing
index fc43a25..e170cd8 100644
--- a/debian/patches/ruby-no-strict-aliasing
+++ b/debian/patches/ruby-no-strict-aliasing
@@ -4,7 +4,7 @@ be real bugs with real consequences.
--- a/Makefile.in
+++ b/Makefile.in
-@@ -136,7 +136,7 @@
+@@ -138,7 +138,7 @@
SWIG_PY_LIBS = @SWIG_PY_LIBS@
SWIG_PL_INCLUDES = @SWIG_PL_INCLUDES@
SWIG_RB_INCLUDES = @SWIG_RB_INCLUDES@ -I$(SWIG_SRC_DIR)/ruby/libsvn_swig_ruby
diff --git a/debian/patches/ruby-test-svnserve-race b/debian/patches/ruby-test-svnserve-race
index 1664898..feeee81 100644
--- a/debian/patches/ruby-test-svnserve-race
+++ b/debian/patches/ruby-test-svnserve-race
@@ -28,7 +28,7 @@ Michlmayr.
# svnserve started successfully. Note port number and cease
# startup attempts.
@svnserve_port = port
-@@ -317,4 +314,25 @@
+@@ -320,4 +317,25 @@
include Svnserve
extend SetupEnvironment
end
diff --git a/debian/patches/ssh-no-controlmaster b/debian/patches/ssh-no-controlmaster
index 9d89200..633425f 100644
--- a/debian/patches/ssh-no-controlmaster
+++ b/debian/patches/ssh-no-controlmaster
@@ -27,7 +27,7 @@ connection sharing, but only if a ControlMaster is already present.
"# rsh = rsh" NL
--- a/subversion/libsvn_ra_svn/client.c
+++ b/subversion/libsvn_ra_svn/client.c
-@@ -387,7 +387,7 @@
+@@ -391,7 +391,7 @@
* versions have it too. If the user is using some other ssh
* implementation that doesn't accept it, they can override it
* in the [tunnels] section of the config. */