summaryrefslogtreecommitdiff
path: root/debian/patches/build-fixes
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/build-fixes')
-rw-r--r--debian/patches/build-fixes59
1 files changed, 45 insertions, 14 deletions
diff --git a/debian/patches/build-fixes b/debian/patches/build-fixes
index 0254181..4eb0b69 100644
--- a/debian/patches/build-fixes
+++ b/debian/patches/build-fixes
@@ -22,7 +22,7 @@
% " ".join(checkout_locations))
--- a/Makefile.in
+++ b/Makefile.in
-@@ -249,14 +249,14 @@
+@@ -252,14 +252,14 @@
# The path to generated and complementary source files for the SWIG
# bindings.
@@ -42,16 +42,7 @@
### Automate JAR creation using Makefile generator's javahl-java.jar
### property. Enhance generator to support JAR installation.
-@@ -674,7 +674,7 @@
- $(EXTRACLEAN_SWIG_HEADERS)
-
- $(SWIG_PL_DIR)/native/Makefile.PL: $(SWIG_SRC_DIR)/perl/native/Makefile.PL.in
-- ./config.status subversion/bindings/swig/perl/native/Makefile.PL
-+ ./config.status $@
-
- $(SWIG_PL_DIR)/native/Makefile: $(SWIG_PL_DIR)/native/Makefile.PL
- cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL
-@@ -682,7 +682,7 @@
+@@ -687,7 +687,7 @@
swig-pl_DEPS = autogen-swig-pl libsvn_swig_perl \
$(SWIG_PL_DIR)/native/Makefile
swig-pl: $(swig-pl_DEPS)
@@ -60,7 +51,7 @@
ln -sf $(SWIG_PL_SRC_DIR)/native/*.c $(SWIG_PL_DIR)/native; \
fi
cd $(SWIG_PL_DIR)/native; $(MAKE) OPTIMIZE="" OTHERLDFLAGS="$(SWIG_LDFLAGS)"
-@@ -705,8 +705,7 @@
+@@ -710,8 +710,7 @@
fi
for d in $(SWIG_PL_DIR)/libsvn_swig_perl; \
do \
@@ -70,7 +61,7 @@
done
if [ -f "$(SWIG_PL_DIR)/native/Makefile" ]; then \
cd $(SWIG_PL_DIR)/native; $(MAKE) clean; \
-@@ -739,7 +738,7 @@
+@@ -744,7 +743,7 @@
fi
for d in $(SWIG_PY_DIR) $(SWIG_PY_DIR)/libsvn_swig_py; \
do \
@@ -79,7 +70,7 @@
done
find $(SWIG_PY_SRC_DIR) $(SWIG_PY_DIR) -name "*.pyc" -exec rm {} ';'
-@@ -763,8 +762,7 @@
+@@ -768,8 +767,7 @@
fi
for d in $(SWIG_RB_DIR) $(SWIG_RB_DIR)/libsvn_swig_ruby; \
do \
@@ -104,6 +95,21 @@
)
self.ofile.write('\n')
+@@ -459,11 +459,11 @@
+ self.ofile.write('%s: %s\n' % (objname, deps))
+ cmd = objname.compile_cmd
+ if cmd:
+- if not getattr(objname, 'source_generated', 0):
++# if not getattr(objname, 'source_generated', 0):
+ self.ofile.write('\t%s %s\n\n'
+ % (cmd, '$(canonicalized_srcdir)' + str(sources[0])))
+- else:
+- self.ofile.write('\t%s %s\n\n' % (cmd, sources[0]))
++# else:
++# self.ofile.write('\t%s %s\n\n' % (cmd, sources[0]))
+ else:
+ self.ofile.write('\n')
+
--- a/build/generator/gen_base.py
+++ b/build/generator/gen_base.py
@@ -284,7 +284,8 @@
@@ -116,3 +122,28 @@
pass
lang_abbrev = {
+--- a/build/generator/swig/header_wrappers.py
++++ b/build/generator/swig/header_wrappers.py
+@@ -32,7 +32,7 @@
+ """Write makefile rules for generating SWIG wrappers for Subversion
+ header files."""
+ wrapper_fnames = []
+- python_script = '$(abs_srcdir)/build/generator/swig/header_wrappers.py'
++ python_script = 'build/generator/swig/header_wrappers.py'
+ makefile.write('GEN_SWIG_WRAPPER = cd $(top_srcdir) && $(PYTHON)' +
+ ' %s build.conf $(SWIG)\n\n' % python_script)
+ for fname in self.includes:
+--- a/configure.ac
++++ b/configure.ac
+@@ -948,6 +948,11 @@
+ AC_SUBST(SVN_CONFIG_SCRIPT_FILES)
+
+ AC_OUTPUT
++if test "$abs_srcdir" != "$abs_builddir"
++then
++ AC_MSG_NOTICE([Creating build directories])
++ (cd "$abs_srcdir"; find subversion tools contrib -type d) | xargs $MKDIR
++fi
+
+ # ==== Print final messages to user ==========================================
+