summaryrefslogtreecommitdiff
path: root/debian/patches/rpath
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/rpath')
-rw-r--r--debian/patches/rpath26
1 files changed, 13 insertions, 13 deletions
diff --git a/debian/patches/rpath b/debian/patches/rpath
index 50d0c6f..a2a773e 100644
--- a/debian/patches/rpath
+++ b/debian/patches/rpath
@@ -8,9 +8,9 @@ patch by David Kimdon <dwhedon@debian.org>. The basic theory is:
--- a/Makefile.in
+++ b/Makefile.in
-@@ -216,10 +216,10 @@
- # special compilation for files destined for cxxhl
- COMPILE_CXXHL_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=compile $(COMPILE_CXX) $(LT_CFLAGS) $(CXXHL_INCLUDES) -o $@ -c
+@@ -255,10 +255,10 @@
+ COMPILE_GMOCK_CXX = $(LT_COMPILE_CXX_NOWARN) $(GMOCK_INCLUDES) -o $@ -c
+ COMPILE_CXXHL_GMOCK_CXX = $(LT_COMPILE_CXX) $(CXXHL_INCLUDES) $(GMOCK_INCLUDES) -o $@ -c
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(libdir)
-LINK_LIB = $(LINK) $(LT_SO_VERSION)
@@ -23,32 +23,32 @@ patch by David Kimdon <dwhedon@debian.org>. The basic theory is:
# special link rule for mod_dav_svn
LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS)
-@@ -777,7 +777,9 @@
+@@ -837,7 +837,9 @@
./config.status subversion/bindings/swig/perl/native/Makefile.PL
$(SWIG_PL_DIR)/native/Makefile: $(SWIG_PL_DIR)/native/Makefile.PL
-- cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL
+- cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL PREFIX=$(prefix)
+ cd $(SWIG_PL_DIR)/native; \
-+ $(PERL) Makefile.PL INSTALLDIRS=vendor; \
++ $(PERL) Makefile.PL PREFIX=$(prefix); \
+ sed -i -e '/^LD_RUN_PATH/s/^/#/' Makefile Makefile.[a-z]*
# There is a "readlink -f" command on some systems for the same purpose,
# but it's not as portable (e.g. Mac OS X doesn't have it). These should
--- a/build.conf
+++ b/build.conf
-@@ -502,7 +502,7 @@
- lang = python
+@@ -561,7 +561,7 @@
path = subversion/bindings/swig/python/libsvn_swig_py
- libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_subr apriconv apr
+ libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_subr
+ apriconv apr python swig
-link-cmd = $(LINK)
+link-cmd = $(LINK_LIB) $(SWIG_PY_LIBS)
install = swig-py-lib
# need special build rule to include -DSWIGPYTHON
compile-cmd = $(COMPILE_SWIG_PY)
-@@ -525,7 +525,7 @@
+@@ -586,7 +586,7 @@
lang = ruby
path = subversion/bindings/swig/ruby/libsvn_swig_ruby
- libs = libsvn_client libsvn_wc libsvn_delta libsvn_subr apriconv apr
+ libs = libsvn_client libsvn_wc libsvn_delta libsvn_subr apriconv apr ruby swig
-link-cmd = $(LINK) $(SWIG_RB_LIBS)
+link-cmd = $(LINK_LIB) $(SWIG_RB_LIBS)
install = swig-rb-lib
@@ -56,7 +56,7 @@ patch by David Kimdon <dwhedon@debian.org>. The basic theory is:
compile-cmd = $(COMPILE_SWIG_RB)
--- a/build/generator/gen_base.py
+++ b/build/generator/gen_base.py
-@@ -415,7 +415,7 @@
+@@ -498,7 +498,7 @@
self.install = options.get('install')
self.compile_cmd = options.get('compile-cmd')
self.sources = options.get('sources', '*.c *.cpp')
@@ -65,7 +65,7 @@ patch by David Kimdon <dwhedon@debian.org>. The basic theory is:
self.external_lib = options.get('external-lib')
self.external_project = options.get('external-project')
-@@ -467,6 +467,7 @@
+@@ -551,6 +551,7 @@
extmap = self.gen_obj._extension_map
self.objext = extmap['exe', 'object']
self.filename = build_path_join(self.path, name + extmap['exe', 'target'])