summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2017-07-18 00:09:15 +0000
committerJelmer Vernooij <jelmer@jelmer.uk>2017-07-18 00:17:59 +0000
commit651f12db05e39042f4fa4b3f0aac3cafc49cf2fd (patch)
tree748321c5bb7df88d6418ebd78d8a590dc547a299
parentf32d92e1875af81ebfa22b1f34c7a3362cb1527d (diff)
Use alternatives for subvertpy-fast-export.
-rw-r--r--debian/python-subvertpy.postinst5
-rw-r--r--debian/python-subvertpy.prerm10
-rw-r--r--debian/python3-subvertpy.postinst5
-rw-r--r--debian/python3-subvertpy.prerm10
-rwxr-xr-xdebian/rules4
5 files changed, 34 insertions, 0 deletions
diff --git a/debian/python-subvertpy.postinst b/debian/python-subvertpy.postinst
new file mode 100644
index 00000000..35082285
--- /dev/null
+++ b/debian/python-subvertpy.postinst
@@ -0,0 +1,5 @@
+#!/bin/sh -e
+
+update-alternatives --install /usr/bin/subvertpy-fast-export subvertpy-fast-export /usr/bin/subvertpy2-fast-export 10
+
+#DEBHELPER#
diff --git a/debian/python-subvertpy.prerm b/debian/python-subvertpy.prerm
new file mode 100644
index 00000000..1f24b55c
--- /dev/null
+++ b/debian/python-subvertpy.prerm
@@ -0,0 +1,10 @@
+#!/bin/sh -e
+
+#DEBHELPER#
+
+case "$1" in
+ remove|deconfigure)
+ update-alternatives --remove subvertpy-fast-export /usr/bin/subvertpy2-fast-export
+ ;;
+ *)
+esac
diff --git a/debian/python3-subvertpy.postinst b/debian/python3-subvertpy.postinst
new file mode 100644
index 00000000..198139ce
--- /dev/null
+++ b/debian/python3-subvertpy.postinst
@@ -0,0 +1,5 @@
+#!/bin/sh -e
+
+update-alternatives --install /usr/bin/subvertpy-fast-export subvertpy-fast-export /usr/bin/subvertpy3-fast-export 10
+
+#DEBHELPER#
diff --git a/debian/python3-subvertpy.prerm b/debian/python3-subvertpy.prerm
new file mode 100644
index 00000000..cb6438b3
--- /dev/null
+++ b/debian/python3-subvertpy.prerm
@@ -0,0 +1,10 @@
+#!/bin/sh -e
+
+#DEBHELPER#
+
+case "$1" in
+ remove|deconfigure)
+ update-alternatives --remove subvertpy-fast-export /usr/bin/subvertpy3-fast-export
+ ;;
+ *)
+esac
diff --git a/debian/rules b/debian/rules
index 74187fa5..7095ef19 100755
--- a/debian/rules
+++ b/debian/rules
@@ -31,6 +31,10 @@ override_dh_auto_install:
debian/python-subvertpy/usr/share/doc/python-subvertpy
cp -a apidocs debian/python-subvertpy/usr/share/doc/python-subvertpy/api
cp -a apidocs debian/python3-subvertpy/usr/share/doc/python3-subvertpy/api
+ mv debian/python3-subvertpy/usr/bin/subvertpy-fast-export \
+ debian/python3-subvertpy/usr/bin/subvertpy3-fast-export
+ mv debian/python-subvertpy/usr/bin/subvertpy-fast-export \
+ debian/python-subvertpy/usr/bin/subvertpy2-fast-export
override_dh_strip:
dh_strip -p python-subvertpy --dbgsym-migration='python-subvertpy-dbg (<< 0.9.3-1)'