summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2015-09-20 21:19:05 +0000
committerJelmer Vernooij <jelmer@jelmer.uk>2015-09-20 21:19:05 +0000
commit9a9d72afdf2e4b4d11246ff6dd41e35666257c96 (patch)
treee0b64ad4927cd301ea0feac25955342ba582b4c5 /debian/rules
parentd5b16e4ad9641209f41650c89e99d2ea9229bf7a (diff)
Build pydoctor docs with --build-time; should make build reproducible.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 6f49739d..c0b9ba84 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,6 +12,8 @@ PYVERS = $(shell pyversions -r -v)
# Get the default Python version
PYVERSION = $(shell pyversions -d -v)
+BUILD_DATE = $(shell dpkg-parsechangelog -S Date)
+
# Callable functions to determine the correct PYTHONPATH
pythonpath = $$(ls -d $(CURDIR)/build/lib.*-$(1))
pythonpath_dbg = $$(ls -d $(CURDIR)/build/lib_d.*-$(1) 2>/dev/null || ls -d $(CURDIR)/build/lib.*$(1)-pydebug)
@@ -24,7 +26,7 @@ export HOME=$(CURDIR)/nonexistent
override_dh_auto_build:
dh_auto_build
- $(MAKE) pydoctor
+ $(MAKE) pydoctor PYDOCTOR_OPTIONS="--buildtime=$(shell date -u +'%Y-%m-%d\\ %H:%M:%S' --date='$(BUILD_DATE)')"
override_dh_auto_install:
dh_auto_install --destdir=debian/tmp