summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index bad12947..90e7cb0e 100644
--- a/Makefile
+++ b/Makefile
@@ -12,6 +12,9 @@ all: build build-inplace
build::
$(SETUP) build
+build-nodeprecated:
+ $(MAKE) build CFLAGS+=-Wno-deprecated-declarations
+
build-inplace::
$(SETUP) build_ext --inplace
@@ -24,6 +27,12 @@ check:: build-inplace
gdb-check::
$(MAKE) check DEBUGGER="gdb --args"
+valgrind-check-python3:
+ PYTHONMALLOC=malloc $(MAKE) check PYTHON=python DEBUGGER="valgrind --suppressions=/usr/lib/valgrind/python3.supp"
+
+valgrind-check-python2:
+ PYTHONMALLOC=malloc $(MAKE) check PYTHON=python3 DEBUGGER="valgrind --suppressions=/usr/lib/valgrind/python.supp"
+
check-one::
$(MAKE) check TEST_OPTIONS=-f
@@ -35,4 +44,4 @@ pydoctor:
$(PYDOCTOR) $(PYDOCTOR_OPTIONS) --introspect-c-modules -c subvertpy.cfg --make-html
style:
- $(FLAKE8) --exclude=build,.git,build-pypy,.tox
+ $(FLAKE8)