summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py39
1 files changed, 31 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 44b9ec9f..0fc21245 100755
--- a/setup.py
+++ b/setup.py
@@ -396,7 +396,8 @@ def subvertpy_modules():
SvnExtension(
"subvertpy.client",
[source_path(n)
- for n in ("client.c", "editor.c", "util.c", "_ra.c", "wc.c")],
+ for n in ("client.c", "editor.c", "util.c", "_ra.c", "wc.c",
+ "wc_adm.c")],
libraries=["svn_client-1", "svn_subr-1", "svn_ra-1", "svn_wc-1"]),
SvnExtension(
"subvertpy._ra",
@@ -407,12 +408,18 @@ def subvertpy_modules():
libraries=["svn_repos-1", "svn_subr-1", "svn_fs-1"]),
SvnExtension(
"subvertpy.wc",
- [source_path(n) for n in ("wc.c", "util.c", "editor.c")],
- libraries=["svn_wc-1", "svn_subr-1"])
+ [source_path(n) for n in
+ ["wc.c", "wc_adm.c", "util.c", "editor.c"]],
+ libraries=["svn_wc-1", "svn_subr-1"]),
+ SvnExtension(
+ "subvertpy.subr",
+ [source_path(n)
+ for n in ["util.c", "subr.c"]],
+ libraries=["svn_subr-1"]),
]
-subvertpy_version = (0, 10, 1)
+subvertpy_version = (0, 11, 0)
subvertpy_version_string = ".".join(map(str, subvertpy_version))
@@ -422,15 +429,31 @@ if __name__ == "__main__":
keywords='svn subvertpy subversion bindings',
version=subvertpy_version_string,
url='https://jelmer.uk/subvertpy',
- download_url="https://jelmer.uk/subvertpy/subvertpy-%s.tar.gz" % (
+ download_url="https://jelmer.uk/subvertpy/tarball/subvertpy-%s/" % (
subvertpy_version_string, ),
license='LGPLv2.1 or later',
author='Jelmer Vernooij',
author_email='jelmer@jelmer.uk',
long_description="""
- Alternative Python bindings for Subversion. The goal is to have
- complete, portable and "Pythonic" Python bindings.
- """,
+Alternative Python bindings for Subversion. The goal is to have
+complete, portable and "Pythonic" Python bindings.
+
+Bindings are provided for the working copy, client, delta, remote access and
+repository APIs. A hookable server side implementation of the custom Subversion
+protocol (svn_ra) is also provided.
+
+Differences with similar packages
+---------------------------------
+subvertpy covers more of the APIs than python-svn. It provides a more
+"Pythonic" API than python-subversion, which wraps the Subversion C API pretty
+much directly. Neither provide a hookable server-side.
+
+Dependencies
+------------
+Subvertpy depends on Python 2.7 or 3.5, and Subversion 1.4 or later. It should
+work on Windows as well as most POSIX-based platforms (including Linux, BSDs
+and Mac OS X).
+""",
packages=['subvertpy', 'subvertpy.tests'],
ext_modules=subvertpy_modules(),
scripts=['bin/subvertpy-fast-export'],