summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorDmitrijs Ledkovs <dmitrij.ledkov@gmail.com>2010-01-21 00:10:17 +0000
committerRoberto C. Sanchez <roberto@connexer.com>2014-03-29 10:54:04 -0400
commitc4b77f09da0b4c42d2b19f8b1bf7d7830e59295f (patch)
tree836a4638cb75c098e1041162dcd8ed6e8b2336a9 /debian/patches
parent0d670b073b99fc6940fe636a7065edafcbe55c57 (diff)
parent936d9e8484ff73282c8c0a277310d1ffdde86e10 (diff)
Imported Debian patch 1.6.1+dfsg-1
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/02_libver.diff24
-rw-r--r--debian/patches/10_diatheke.diff16
-rw-r--r--debian/patches/11_regex_only_when_needed.diff133
-rw-r--r--debian/patches/12_fix_compiler_warnings.diff129
-rw-r--r--debian/patches/13_fix_osis2mod_compression_default.diff15
-rw-r--r--debian/patches/14_closing_section_not_chapter.diff95
-rw-r--r--debian/patches/40_missing_includes.diff61
-rw-r--r--debian/patches/series4
8 files changed, 65 insertions, 412 deletions
diff --git a/debian/patches/02_libver.diff b/debian/patches/02_libver.diff
index 2a48dc0..21fe438 100644
--- a/debian/patches/02_libver.diff
+++ b/debian/patches/02_libver.diff
@@ -1,26 +1,26 @@
This patch changes the upstream SO name to Debian/Ubuntu SO name.
-Index: main/lib/Makefile.am
+Index: sword/lib/Makefile.am
===================================================================
---- main.orig/lib/Makefile.am 2009-05-25 10:23:38.000000000 -0700
-+++ main/lib/Makefile.am 2009-05-25 10:41:16.000000000 -0700
-@@ -36,7 +36,7 @@
+--- sword.orig/lib/Makefile.am 2010-01-03 04:36:09.622945995 +0200
++++ sword/lib/Makefile.am 2010-01-03 04:38:16.010955077 +0200
+@@ -23,7 +23,7 @@
- libsword_la_LIBADD = $(ICULIBADD) $(IMGRLIBADD) $(CLUCENE_LIBS)
+ AM_CPPFLAGS += $(ICUDEF)
-libsword_la_LDFLAGS = -release $(VERSION)
+libsword_la_LDFLAGS = -version-info 8
include ../src/keys/Makefile.am
include ../src/utilfuns/Makefile.am
-Index: main/lib/Makefile.in
+Index: sword/lib/Makefile.in
===================================================================
---- main.orig/lib/Makefile.in 2009-05-25 10:23:38.000000000 -0700
-+++ main/lib/Makefile.in 2009-05-25 10:41:37.000000000 -0700
-@@ -452,7 +452,7 @@
- #if WITHCURL
- @INSTALLMGR_TRUE@IMGRLIBADD = -lcurl $(CURL_LIBS)
- libsword_la_LIBADD = $(ICULIBADD) $(IMGRLIBADD) $(CLUCENE_LIBS)
+--- sword.orig/lib/Makefile.in 2010-01-03 03:49:46.274945658 +0200
++++ sword/lib/Makefile.in 2010-01-03 04:38:47.198943804 +0200
+@@ -537,7 +537,7 @@
+ $(zlddir)/zld.cpp $(bindingsdir)/flatapi.cpp
+ @HAVE_ICU_FALSE@ICUDEF =
+ @HAVE_ICU_TRUE@ICUDEF = -DSWICU_DATA=\"${pkglibdir}/${VERSION}_icu_${ICU_VER}\"
-libsword_la_LDFLAGS = -release $(VERSION)
+libsword_la_LDFLAGS = -version-info 8
keysdir = $(top_srcdir)/src/keys
diff --git a/debian/patches/10_diatheke.diff b/debian/patches/10_diatheke.diff
deleted file mode 100644
index 1288970..0000000
--- a/debian/patches/10_diatheke.diff
+++ /dev/null
@@ -1,16 +0,0 @@
-This patch simplifies the $range assignment.
-
-Index: sword-1.5.9/utilities/diatheke/cgi/diatheke.pl
-===================================================================
---- sword-1.5.9.orig/utilities/diatheke/cgi/diatheke.pl 2008-02-18 22:10:09.000000000 +0000
-+++ sword-1.5.9/utilities/diatheke/cgi/diatheke.pl 2008-02-18 22:30:25.000000000 +0000
-@@ -110,8 +110,7 @@
- $range = $mydata;
- $range =~ tr/+/ /;
- $range =~ s/%([a-fA-F0-9][a-fA-F0-9])/pack("C", hex($1))/eg;
-- $range = "-r \"$range\"";
-- $range = shell_escape($range);
-+ $range = "-r '" . shell_escape($range) . "'";
- }
-
- elsif ($varname eq "strongs") {
diff --git a/debian/patches/11_regex_only_when_needed.diff b/debian/patches/11_regex_only_when_needed.diff
deleted file mode 100644
index d60d3f7..0000000
--- a/debian/patches/11_regex_only_when_needed.diff
+++ /dev/null
@@ -1,133 +0,0 @@
-Only use included regex library when building for MINGW.
-Index: main/include/Makefile.am
-===================================================================
---- main.orig/include/Makefile.am 2009-05-24 18:25:38.000000000 -0700
-+++ main/include/Makefile.am 2009-05-24 18:25:57.000000000 -0700
-@@ -76,7 +76,9 @@
- pkginclude_HEADERS += $(swincludedir)/rawstr4.h
- pkginclude_HEADERS += $(swincludedir)/rawtext.h
- pkginclude_HEADERS += $(swincludedir)/rawverse.h
-+if MINGW
- pkginclude_HEADERS += $(swincludedir)/regex.h
-+endif
- pkginclude_HEADERS += $(swincludedir)/roman.h
- pkginclude_HEADERS += $(swincludedir)/rtfhtml.h
- pkginclude_HEADERS += $(swincludedir)/sapphire.h
-Index: main/lib/Makefile.in
-===================================================================
---- main.orig/lib/Makefile.in 2009-05-24 18:28:58.000000000 -0700
-+++ main/lib/Makefile.in 2009-05-24 18:29:58.000000000 -0700
-@@ -34,7 +34,7 @@
- build_triplet = @build@
- host_triplet = @host@
- target_triplet = @target@
--DIST_COMMON = README $(pkginclude_HEADERS) \
-+DIST_COMMON = README $(am__pkginclude_HEADERS_DIST) \
- $(srcdir)/../include/Makefile.am \
- $(srcdir)/../src/frontend/Makefile.am \
- $(srcdir)/../src/keys/Makefile.am \
-@@ -61,6 +61,7 @@
- $(srcdir)/../src/utilfuns/Makefile.am $(srcdir)/Makefile.am \
- $(srcdir)/Makefile.in
- @HAVE_VSNPRINTF_FALSE@am__append_1 = -DNO_VSNPRINTF
-+@MINGW_TRUE@am__append_2 = $(swincludedir)/regex.h
- subdir = lib
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
- am__aclocal_m4_deps = $(top_srcdir)/m4/acx_clucene.m4 \
-@@ -238,6 +239,86 @@
- $(LDFLAGS) -o $@
- SOURCES = $(libsword_la_SOURCES)
- DIST_SOURCES = $(am__libsword_la_SOURCES_DIST)
-+am__pkginclude_HEADERS_DIST = $(swincludedir)/Greek2Greek.h \
-+ $(swincludedir)/GreekChars.h $(swincludedir)/canon.h \
-+ $(swincludedir)/canon_abbrevs.h $(swincludedir)/cipherfil.h \
-+ $(swincludedir)/curlftpt.h $(swincludedir)/curlhttpt.h \
-+ $(swincludedir)/defs.h $(swincludedir)/echomod.h \
-+ $(swincludedir)/encfiltmgr.h $(swincludedir)/entriesblk.h \
-+ $(swincludedir)/femain.h $(swincludedir)/filemgr.h \
-+ $(swincludedir)/versemgr.h $(swincludedir)/flatapi.h \
-+ $(swincludedir)/ftpparse.h $(swincludedir)/ftptrans.h \
-+ $(swincludedir)/ftplibftpt.h $(swincludedir)/ftplib.h \
-+ $(swincludedir)/gbffootnotes.h $(swincludedir)/gbfheadings.h \
-+ $(swincludedir)/gbfhtml.h $(swincludedir)/gbfhtmlhref.h \
-+ $(swincludedir)/gbfwebif.h $(swincludedir)/gbfmorph.h \
-+ $(swincludedir)/gbfosis.h $(swincludedir)/gbfplain.h \
-+ $(swincludedir)/gbfredletterwords.h $(swincludedir)/gbfrtf.h \
-+ $(swincludedir)/gbfstrongs.h $(swincludedir)/gbfwordjs.h \
-+ $(swincludedir)/gbfthml.h $(swincludedir)/greeklexattribs.h \
-+ $(swincludedir)/hebrewmcim.h $(swincludedir)/hrefcom.h \
-+ $(swincludedir)/installmgr.h $(swincludedir)/latin1utf16.h \
-+ $(swincludedir)/latin1utf8.h $(swincludedir)/listkey.h \
-+ $(swincludedir)/localemgr.h $(swincludedir)/lzsscomprs.h \
-+ $(swincludedir)/markupfiltmgr.h $(swincludedir)/multimapwdef.h \
-+ $(swincludedir)/nullim.h $(swincludedir)/osisheadings.h \
-+ $(swincludedir)/osishtmlhref.h $(swincludedir)/osiswebif.h \
-+ $(swincludedir)/osismorph.h \
-+ $(swincludedir)/osismorphsegmentation.h \
-+ $(swincludedir)/osisplain.h $(swincludedir)/osisrtf.h \
-+ $(swincludedir)/osisosis.h $(swincludedir)/osisstrongs.h \
-+ $(swincludedir)/osisfootnotes.h $(swincludedir)/osislemma.h \
-+ $(swincludedir)/osisredletterwords.h \
-+ $(swincludedir)/osisscripref.h $(swincludedir)/osiswordjs.h \
-+ $(swincludedir)/osisvariants.h $(swincludedir)/papyriplain.h \
-+ $(swincludedir)/plainfootnotes.h $(swincludedir)/plainhtml.h \
-+ $(swincludedir)/rawcom.h $(swincludedir)/rawfiles.h \
-+ $(swincludedir)/rawgenbook.h $(swincludedir)/rawld.h \
-+ $(swincludedir)/rawld4.h $(swincludedir)/rawstr.h \
-+ $(swincludedir)/rawstr4.h $(swincludedir)/rawtext.h \
-+ $(swincludedir)/rawverse.h $(swincludedir)/regex.h \
-+ $(swincludedir)/roman.h $(swincludedir)/rtfhtml.h \
-+ $(swincludedir)/sapphire.h $(swincludedir)/strkey.h \
-+ $(swincludedir)/swbasicfilter.h $(swincludedir)/swbuf.h \
-+ $(swincludedir)/swcacher.h $(swincludedir)/swcipher.h \
-+ $(swincludedir)/swcom.h $(swincludedir)/swcomprs.h \
-+ $(swincludedir)/swconfig.h $(swincludedir)/swdisp.h \
-+ $(swincludedir)/swfilter.h $(swincludedir)/swfiltermgr.h \
-+ $(swincludedir)/swgenbook.h $(swincludedir)/swinputmeth.h \
-+ $(swincludedir)/swkey.h $(swincludedir)/swld.h \
-+ $(swincludedir)/swlocale.h $(swincludedir)/swlog.h \
-+ $(swincludedir)/swmacs.h $(swincludedir)/swmgr.h \
-+ $(swincludedir)/stringmgr.h $(swincludedir)/swmodule.h \
-+ $(swincludedir)/swoptfilter.h $(swincludedir)/swobject.h \
-+ $(swincludedir)/swsearchable.h $(swincludedir)/swtext.h \
-+ $(swincludedir)/swunicod.h $(swincludedir)/swversion.h \
-+ $(swincludedir)/sysdata.h $(swincludedir)/thmlfootnotes.h \
-+ $(swincludedir)/thmlgbf.h $(swincludedir)/thmlheadings.h \
-+ $(swincludedir)/thmlhtml.h $(swincludedir)/thmlhtmlhref.h \
-+ $(swincludedir)/thmlwebif.h $(swincludedir)/thmllemma.h \
-+ $(swincludedir)/thmlmorph.h $(swincludedir)/thmlosis.h \
-+ $(swincludedir)/thmlplain.h $(swincludedir)/thmlrtf.h \
-+ $(swincludedir)/thmlscripref.h $(swincludedir)/thmlstrongs.h \
-+ $(swincludedir)/thmlvariants.h $(swincludedir)/thmlwordjs.h \
-+ $(swincludedir)/teiplain.h $(swincludedir)/teirtf.h \
-+ $(swincludedir)/teihtmlhref.h $(swincludedir)/treekey.h \
-+ $(swincludedir)/treekeyidx.h $(swincludedir)/unicodertf.h \
-+ $(swincludedir)/url.h $(swincludedir)/untgz.h \
-+ $(swincludedir)/utf16utf8.h $(swincludedir)/utf8arshaping.h \
-+ $(swincludedir)/utf8bidireorder.h \
-+ $(swincludedir)/utf8cantillation.h \
-+ $(swincludedir)/utf8greekaccents.h \
-+ $(swincludedir)/utf8hebrewpoints.h \
-+ $(swincludedir)/utf8arabicpoints.h $(swincludedir)/utf8html.h \
-+ $(swincludedir)/utf8latin1.h $(swincludedir)/utf8nfc.h \
-+ $(swincludedir)/utf8nfkd.h \
-+ $(swincludedir)/utf8transliterator.h \
-+ $(swincludedir)/utf8utf16.h $(swincludedir)/utilstr.h \
-+ $(swincludedir)/utilxml.h $(swincludedir)/versekey.h \
-+ $(swincludedir)/versetreekey.h $(swincludedir)/zcom.h \
-+ $(swincludedir)/zconf.h $(swincludedir)/zipcomprs.h \
-+ $(swincludedir)/zld.h $(swincludedir)/zstr.h \
-+ $(swincludedir)/ztext.h $(swincludedir)/zverse.h
- pkgincludeHEADERS_INSTALL = $(INSTALL_HEADER)
- HEADERS = $(pkginclude_HEADERS)
- ETAGS = etags
-@@ -575,7 +656,7 @@
- $(swincludedir)/rawgenbook.h $(swincludedir)/rawld.h \
- $(swincludedir)/rawld4.h $(swincludedir)/rawstr.h \
- $(swincludedir)/rawstr4.h $(swincludedir)/rawtext.h \
-- $(swincludedir)/rawverse.h $(swincludedir)/regex.h \
-+ $(swincludedir)/rawverse.h $(am__append_2) \
- $(swincludedir)/roman.h $(swincludedir)/rtfhtml.h \
- $(swincludedir)/sapphire.h $(swincludedir)/strkey.h \
- $(swincludedir)/swbasicfilter.h $(swincludedir)/swbuf.h \
-
diff --git a/debian/patches/12_fix_compiler_warnings.diff b/debian/patches/12_fix_compiler_warnings.diff
index b095eca..6d579ff 100644
--- a/debian/patches/12_fix_compiler_warnings.diff
+++ b/debian/patches/12_fix_compiler_warnings.diff
@@ -1,40 +1,21 @@
Remove compiler warnings so SWORD will compile with -Wall -Werror
-Index: main/src/mgr/filemgr.cpp
+Index: sword/src/mgr/filemgr.cpp
===================================================================
---- main.orig/src/mgr/filemgr.cpp 2009-05-25 14:52:54.000000000 -0700
-+++ main/src/mgr/filemgr.cpp 2009-05-25 14:52:57.000000000 -0700
-@@ -273,8 +273,7 @@
- file->seek(0, SEEK_SET);
- while (size > 0) {
- bytes = file->read(nibble, 32767);
-- write(fd, nibble, (bytes < size)?bytes:size);
-- size -= bytes;
-+ size -= write(fd, nibble, (bytes < size)?bytes:size);
- }
- // zero out the file
- ::close(file->fd);
-@@ -396,7 +395,7 @@
+--- sword.orig/src/mgr/filemgr.cpp 2010-01-04 00:38:49.052717665 +0200
++++ sword/src/mgr/filemgr.cpp 2010-01-04 00:40:32.823732625 +0200
+@@ -408,7 +408,7 @@
int FileMgr::copyFile(const char *sourceFile, const char *targetFile) {
- int sfd, dfd, len;
-+ int sfd, dfd, len, written;
++ int sfd, dfd, len;
char buf[4096];
if ((sfd = ::open(sourceFile, O_RDONLY|O_BINARY, S_IREAD|S_IWRITE|S_IRGRP|S_IROTH)) < 1)
-@@ -406,7 +405,7 @@
-
- do {
- len = read(sfd, buf, 4096);
-- write(dfd, buf, len);
-+ written = write(dfd, buf, len);
- }
- while(len == 4096);
- ::close(dfd);
-Index: main/src/utilfuns/zlib/untgz.c
+Index: sword/src/utilfuns/zlib/untgz.c
===================================================================
---- main.orig/src/utilfuns/zlib/untgz.c 2009-05-25 14:52:54.000000000 -0700
-+++ main/src/utilfuns/zlib/untgz.c 2009-05-25 14:52:57.000000000 -0700
+--- sword.orig/src/utilfuns/zlib/untgz.c 2010-01-04 00:38:49.032728497 +0200
++++ sword/src/utilfuns/zlib/untgz.c 2010-01-04 00:39:44.144727307 +0200
@@ -13,6 +13,8 @@
#include <fcntl.h>
#ifdef unix
@@ -93,10 +74,19 @@ Index: main/src/utilfuns/zlib/untgz.c
/* error message for the filename */
-Index: main/tests/testblocks.cpp
+@@ -277,7 +280,7 @@
+ int remaining = 0;
+ FILE *outfile = NULL;
+ char fname[BLOCKSIZE];
+- time_t tartime;
++ time_t tartime = 0;
+
+ while (1) {
+ len = gzread(in, &buffer, BLOCKSIZE);
+Index: sword/tests/testblocks.cpp
===================================================================
---- main.orig/tests/testblocks.cpp 2009-05-25 14:52:53.000000000 -0700
-+++ main/tests/testblocks.cpp 2009-05-25 14:52:57.000000000 -0700
+--- sword.orig/tests/testblocks.cpp 2010-01-04 00:38:48.928718885 +0200
++++ sword/tests/testblocks.cpp 2010-01-04 00:39:44.144727307 +0200
@@ -29,14 +29,18 @@
void addEntry(EntriesBlock *eb) {
string input;
@@ -173,11 +163,11 @@ Index: main/tests/testblocks.cpp
}
}
}
-Index: main/utilities/stepdump.cpp
+Index: sword/utilities/stepdump.cpp
===================================================================
---- main.orig/utilities/stepdump.cpp 2009-05-25 14:52:53.000000000 -0700
-+++ main/utilities/stepdump.cpp 2009-05-25 14:53:05.000000000 -0700
-@@ -151,33 +151,56 @@
+--- sword.orig/utilities/stepdump.cpp 2010-01-04 00:38:49.012719004 +0200
++++ sword/utilities/stepdump.cpp 2010-01-04 00:39:44.144727307 +0200
+@@ -153,33 +153,56 @@
void readVersion(int fd, Version *versionRecord) {
@@ -245,7 +235,7 @@ Index: main/utilities/stepdump.cpp
cout << "\tmodifiedBy: " << versionRecord->modifiedBy << "\n";
int skip = versionRecord->versionRecordSize - 16/*sizeof(struct Version*/;
-@@ -185,33 +208,49 @@
+@@ -187,33 +210,49 @@
if (skip) {
cout << "\nSkipping " << skip << " unknown bytes.\n";
char *skipbuf = new char[skip];
@@ -304,7 +294,7 @@ Index: main/utilities/stepdump.cpp
cout << "\treserved2: " << viewableHeaderRecord->reserved2 << "\n";
int skip = viewableHeaderRecord->viewableHeaderRecordSize - 16/*sizeof(struct ViewableHeader)*/;
-@@ -219,18 +258,23 @@
+@@ -221,18 +260,23 @@
if (skip) {
cout << "\nSkipping " << skip << " unknown bytes.\n";
char *skipbuf = new char[skip];
@@ -330,7 +320,7 @@ Index: main/utilities/stepdump.cpp
compress->zBuf(&size, *buf);
strcpy(*buf, compress->Buf());
-@@ -240,30 +284,41 @@
+@@ -242,30 +286,41 @@
void readViewableBlock(int fd, ViewableBlock *vb) {
@@ -378,10 +368,10 @@ Index: main/utilities/stepdump.cpp
(*buf)[headerControlWordAreaSize] = 0;
cout << "headerControlWordArea:\n" << *buf << "\n";
-Index: main/utilities/treeidxutil.cpp
+Index: sword/utilities/treeidxutil.cpp
===================================================================
---- main.orig/utilities/treeidxutil.cpp 2009-05-25 14:52:53.000000000 -0700
-+++ main/utilities/treeidxutil.cpp 2009-05-25 14:52:57.000000000 -0700
+--- sword.orig/utilities/treeidxutil.cpp 2010-01-04 00:38:48.992719359 +0200
++++ sword/utilities/treeidxutil.cpp 2010-01-04 00:39:44.144727307 +0200
@@ -49,27 +49,33 @@
@@ -452,10 +442,10 @@ Index: main/utilities/treeidxutil.cpp
input = line;
if (input.length() > 0) {
switch (input[0]) {
-Index: main/utilities/gbfidx.cpp
+Index: sword/utilities/gbfidx.cpp
===================================================================
---- main.orig/utilities/gbfidx.cpp 2009-05-25 14:52:53.000000000 -0700
-+++ main/utilities/gbfidx.cpp 2009-05-25 14:52:57.000000000 -0700
+--- sword.orig/utilities/gbfidx.cpp 2010-01-04 00:38:48.952718391 +0200
++++ sword/utilities/gbfidx.cpp 2010-01-04 00:39:44.144727307 +0200
@@ -53,7 +53,7 @@
int main(int argc, char **argv)
{
@@ -570,10 +560,10 @@ Index: main/utilities/gbfidx.cpp
}
}
}
-Index: main/utilities/genbookutil.cpp
+Index: sword/utilities/genbookutil.cpp
===================================================================
---- main.orig/utilities/genbookutil.cpp 2009-05-25 14:52:53.000000000 -0700
-+++ main/utilities/genbookutil.cpp 2009-05-25 14:52:57.000000000 -0700
+--- sword.orig/utilities/genbookutil.cpp 2010-01-04 00:38:49.024719769 +0200
++++ sword/utilities/genbookutil.cpp 2010-01-04 00:39:44.144727307 +0200
@@ -48,9 +48,11 @@
@@ -674,10 +664,10 @@ Index: main/utilities/genbookutil.cpp
input = line;
input.trim();
if (input.length() > 0) {
-Index: main/utilities/vpl2mod.cpp
+Index: sword/utilities/vpl2mod.cpp
===================================================================
---- main.orig/utilities/vpl2mod.cpp 2009-05-25 14:52:53.000000000 -0700
-+++ main/utilities/vpl2mod.cpp 2009-05-25 14:52:57.000000000 -0700
+--- sword.orig/utilities/vpl2mod.cpp 2010-01-04 00:38:48.968728584 +0200
++++ sword/utilities/vpl2mod.cpp 2010-01-04 00:39:44.144727307 +0200
@@ -67,14 +67,18 @@
break;
}
@@ -700,11 +690,11 @@ Index: main/utilities/vpl2mod.cpp
(*buf)[size] = 0;
// clean up any trailing junk on buf
-Index: main/utilities/installmgr.cpp
+Index: sword/utilities/installmgr.cpp
===================================================================
---- main.orig/utilities/installmgr.cpp 2009-05-25 14:52:53.000000000 -0700
-+++ main/utilities/installmgr.cpp 2009-05-25 14:52:57.000000000 -0700
-@@ -62,8 +62,10 @@
+--- sword.orig/utilities/installmgr.cpp 2010-01-04 00:38:48.984719291 +0200
++++ sword/utilities/installmgr.cpp 2010-01-04 00:39:44.144727307 +0200
+@@ -65,8 +65,10 @@
cout << "then type yes at the prompt\n\n";
cout << "enable? [no] ";
@@ -715,12 +705,12 @@ Index: main/utilities/installmgr.cpp
+ if (c == NULL)
+ std::cerr <<"ERROR: fgets failed in isUserDisclaimerConfirmed\n";
confirmed = (!strcmp(prompt, "yes\n"));
+ cout << "\n";
}
- return confirmed;
-Index: main/utilities/step2vpl.cpp
+Index: sword/utilities/step2vpl.cpp
===================================================================
---- main.orig/utilities/step2vpl.cpp 2009-05-25 14:52:53.000000000 -0700
-+++ main/utilities/step2vpl.cpp 2009-05-25 14:52:57.000000000 -0700
+--- sword.orig/utilities/step2vpl.cpp 2010-01-04 00:38:48.936719093 +0200
++++ sword/utilities/step2vpl.cpp 2010-01-04 00:39:44.148729122 +0200
@@ -218,93 +218,169 @@
@@ -1068,10 +1058,10 @@ Index: main/utilities/step2vpl.cpp
}
void cleanBuf(char *buf) {
-Index: main/utilities/cipherraw.cpp
+Index: sword/utilities/cipherraw.cpp
===================================================================
---- main.orig/utilities/cipherraw.cpp 2009-05-25 14:52:53.000000000 -0700
-+++ main/utilities/cipherraw.cpp 2009-05-25 14:52:57.000000000 -0700
+--- sword.orig/utilities/cipherraw.cpp 2010-01-04 00:38:48.960718319 +0200
++++ sword/utilities/cipherraw.cpp 2010-01-04 00:39:44.148729122 +0200
@@ -43,7 +43,7 @@
SWCipher *zobj;
VerseKey key;
@@ -1148,23 +1138,10 @@ Index: main/utilities/cipherraw.cpp
lzsize = size;
}
}
-Index: main/src/modules/filters/teirtf.cpp
-===================================================================
---- main.orig/src/modules/filters/teirtf.cpp 2009-05-25 14:52:53.000000000 -0700
-+++ main/src/modules/filters/teirtf.cpp 2009-05-25 14:52:57.000000000 -0700
-@@ -159,7 +159,7 @@
- SWBuf type = tag.getAttribute("type");
-
- SWBuf footnoteNumber = tag.getAttribute("swordFootnote");
-- VerseKey *vkey;
-+ VerseKey *vkey = NULL;
- // see if we have a VerseKey * or descendant
- SWTRY {
- vkey = SWDYNAMIC_CAST(VerseKey, u->key);
-Index: main/utilities/lexdump.c
+Index: sword/utilities/lexdump.c
===================================================================
---- main.orig/utilities/lexdump.c 2009-05-25 14:53:18.000000000 -0700
-+++ main/utilities/lexdump.c 2009-05-25 14:54:46.000000000 -0700
+--- sword.orig/utilities/lexdump.c 2010-01-04 00:38:49.004730321 +0200
++++ sword/utilities/lexdump.c 2010-01-04 00:39:44.148729122 +0200
@@ -40,7 +40,7 @@
int main(int argc, char **argv) {
diff --git a/debian/patches/13_fix_osis2mod_compression_default.diff b/debian/patches/13_fix_osis2mod_compression_default.diff
deleted file mode 100644
index 0fa230e..0000000
--- a/debian/patches/13_fix_osis2mod_compression_default.diff
+++ /dev/null
@@ -1,15 +0,0 @@
-Ensure LZSS compression is not accidentally enabled by default.
-This is svn revision 2416 in the upstream SWORD repository.
-Index: main/utilities/osis2mod.cpp
-===================================================================
---- main.orig/utilities/osis2mod.cpp 2009-05-28 21:59:05.000000000 -0700
-+++ main/utilities/osis2mod.cpp 2009-05-28 21:59:33.000000000 -0700
-@@ -1473,7 +1473,7 @@
- if (compType == "ZIP") {
- compressor = new ZipCompress();
- }
-- else if (compType = "LZSS") {
-+ else if (compType == "LZSS") {
- compressor = new LZSSCompress();
- }
-
diff --git a/debian/patches/14_closing_section_not_chapter.diff b/debian/patches/14_closing_section_not_chapter.diff
deleted file mode 100644
index dbdeac5..0000000
--- a/debian/patches/14_closing_section_not_chapter.diff
+++ /dev/null
@@ -1,95 +0,0 @@
-Adds changes from upstream svn to fix known issues in osis2mod,
-Index: main/utilities/osis2mod.cpp
-===================================================================
---- main.orig/utilities/osis2mod.cpp 2009-05-28 22:02:59.000000000 -0700
-+++ main/utilities/osis2mod.cpp 2009-05-28 23:05:34.000000000 -0700
-@@ -612,6 +612,12 @@
- // Flag used to indicate where useful text begins
- static bool firstDiv = false;
-
-+ // Retain the sID of book, chapter and verse (commentary) divs so that we can find them again.
-+ // This relies on transformBSP.
-+ static SWBuf sidBook = "";
-+ static SWBuf sidChapter = "";
-+ static SWBuf sidVerse = "";
-+
- // Stack of quote elements used to handle Words of Christ
- static std::stack<XMLTag> quoteStack;
-
-@@ -628,9 +634,10 @@
- static int verseDepth = 0;
-
- int tagDepth = tagStack.size();
-- const char *tokenName = token.getName();
-+ SWBuf tokenName = token.getName();
- bool isEndTag = token.isEndTag() || token.getAttribute("eID");
-- const char *typeAttr = token.getAttribute("type");
-+ SWBuf typeAttr = token.getAttribute("type");
-+ SWBuf eidAttr = token.getAttribute("eID");
-
- // process start tags
- if (!isEndTag) {
-@@ -688,6 +695,7 @@
- currentVerse.Verse(0);
- strcpy(currentOsisID, currentVerse.getOSISRef());
-
-+ sidBook = token.getAttribute("sID");
- inChapter = false;
- inVerse = false;
- inPreVerse = false;
-@@ -733,6 +741,7 @@
- #endif
- strcpy(currentOsisID, currentVerse.getOSISRef());
-
-+ sidChapter = token.getAttribute("sID");
- inChapter = true;
- inVerse = false;
- inPreVerse = false;
-@@ -772,7 +781,7 @@
- // Did we have pre-verse material that needs to be marked?
- if (inPreVerse) {
- char genBuf[200];
-- sprintf(genBuf, "<div type=\"x-milestone\" subType=\"x-preverse\" eID=\"pv%d\"/>", genID++);
-+ sprintf(genBuf, "<div type=\"x-milestone\" subType=\"x-preverse\" eID=\"pv%d\"/>", genID);
- text.append(genBuf);
- }
-
-@@ -813,6 +822,7 @@
- }
- #endif
-
-+ sidVerse = token.getAttribute("sID");
- inVerse = true;
- inPreVerse = false;
- inBookHeader = false;
-@@ -966,8 +976,7 @@
- }
-
- // VERSE and COMMENTARY END
-- if (!strcmp(tokenName, "verse") || (inVerse && !strcmp(tokenName, "div"))) {
--
-+ if ((!strcmp(tokenName, "verse")) || ((!strcmp(tokenName, "div")) && (eidAttr == sidVerse))) {
- if (tagDepth != verseDepth) {
- cout << "WARNING(NESTING): verse " << currentOsisID << " is not well formed:(" << verseDepth << "," << tagDepth << ")" << endl;
- }
-@@ -1061,17 +1070,18 @@
- // Also for material that goes with last entry
- if (!inVerse && !inBookHeader && !inChapterHeader) {
- // Is this the end of a chapter.
-- if (tagDepth == chapterDepth && (!strcmp(tokenName, "div") || !strcmp(tokenName, "chapter"))) {
-+ if (((!strcmp(tokenName, "div")) && (eidAttr == sidChapter)) || (!strcmp(tokenName, "chapter"))) {
- text.append(token);
- writeEntry(text);
- inChapter = false;
-+ sidChapter = "";
- chapterDepth = 0;
- verseDepth = 0;
- return true;
- }
-
- // Is it the end of a book
-- if (tagDepth == bookDepth && (!strcmp(tokenName, "div"))) {
-+ if ((!strcmp(tokenName, "div")) && (eidAttr == sidBook)) {
- text.append(token);
- writeEntry(text);
- bookDepth = 0;
diff --git a/debian/patches/40_missing_includes.diff b/debian/patches/40_missing_includes.diff
deleted file mode 100644
index 92e9b5e..0000000
--- a/debian/patches/40_missing_includes.diff
+++ /dev/null
@@ -1,61 +0,0 @@
-Adding missing <stdio.h> includes in the testsuite.
-Index: main/tests/localetest.cpp
-===================================================================
---- main.orig/tests/localetest.cpp 2009-05-25 10:43:41.000000000 -0700
-+++ main/tests/localetest.cpp 2009-05-25 14:51:45.000000000 -0700
-@@ -18,6 +18,7 @@
- #include <localemgr.h>
- #include <versekey.h>
- #include <iostream>
-+#include <stdio.h>
- #ifndef NO_SWORD_NAMESPACE
- using namespace sword;
- #endif
-Index: main/tests/parsekey.cpp
-===================================================================
---- main.orig/tests/parsekey.cpp 2009-05-25 10:43:40.000000000 -0700
-+++ main/tests/parsekey.cpp 2009-05-25 14:51:45.000000000 -0700
-@@ -16,6 +16,7 @@
- */
-
- #include <iostream>
-+#include <stdio.h>
-
- #include <versekey.h>
- #include <localemgr.h>
-Index: main/tests/rawldidxtest.cpp
-===================================================================
---- main.orig/tests/rawldidxtest.cpp 2009-05-25 10:43:40.000000000 -0700
-+++ main/tests/rawldidxtest.cpp 2009-05-25 14:51:45.000000000 -0700
-@@ -19,6 +19,7 @@
- #include <rawstr.h>
- #include <swmgr.h>
- #include <filemgr.h>
-+#include <stdio.h>
-
- #ifndef __GNUC__
- #include <io.h>
-Index: main/tests/filtertest.cpp
-===================================================================
---- main.orig/tests/filtertest.cpp 2009-05-25 10:43:41.000000000 -0700
-+++ main/tests/filtertest.cpp 2009-05-25 14:51:45.000000000 -0700
-@@ -20,6 +20,7 @@
- #include <filemgr.h>
- #include <papyriplain.h>
- #include <utf8utf16.h>
-+#include <stdio.h>
- //#include <swmgr.h>
- #ifndef NO_SWORD_NAMESPACE
- using namespace sword;
-Index: main/utilities/stepdump.cpp
-===================================================================
---- main.orig/utilities/stepdump.cpp 2009-05-25 14:52:05.000000000 -0700
-+++ main/utilities/stepdump.cpp 2009-05-25 14:52:17.000000000 -0700
-@@ -17,6 +17,7 @@
-
- #include <iostream>
- #include <string>
-+#include <stdio.h>
- #include <sys/stat.h>
- #include <fcntl.h>
-
diff --git a/debian/patches/series b/debian/patches/series
index d4de339..d9bddb8 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,6 +1,2 @@
02_libver.diff
-11_regex_only_when_needed.diff
12_fix_compiler_warnings.diff
-13_fix_osis2mod_compression_default.diff
-14_closing_section_not_chapter.diff
-40_missing_includes.diff