summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorDimitri John Ledkov <xnox@debian.org>2014-04-19 15:05:09 +0100
committerRoberto C. Sanchez <roberto@connexer.com>2014-05-12 08:21:35 -0400
commite08828aafb4a32ee52586e1696e4d16b426366f5 (patch)
tree7b0368f960fa1b115be69d184ff51c929cebdeb0 /debian/patches
parente2b4166ef05be662a1ce096e28b680711e98f2bf (diff)
parent7a00574163029c0c2b649878c95d5acbd083564a (diff)
Imported Debian patch 1.7.2+dfsg-1
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/12_fix_compiler_warnings.diff268
-rw-r--r--debian/patches/13_curl.diff2
-rw-r--r--debian/patches/dso-missing-shared.patch6
-rw-r--r--debian/patches/no-included-zconf.h.diff10
-rw-r--r--debian/patches/series14
5 files changed, 98 insertions, 202 deletions
diff --git a/debian/patches/12_fix_compiler_warnings.diff b/debian/patches/12_fix_compiler_warnings.diff
index 9822dcc..dbcf8b5 100644
--- a/debian/patches/12_fix_compiler_warnings.diff
+++ b/debian/patches/12_fix_compiler_warnings.diff
@@ -1,9 +1,7 @@
Remove compiler warnings so SWORD will compile with -Wall -Werror
-Index: debian/src/mgr/filemgr.cpp
-===================================================================
---- debian.orig/src/mgr/filemgr.cpp
-+++ debian/src/mgr/filemgr.cpp
-@@ -408,7 +408,7 @@ int FileMgr::createPathAndFile(const cha
+--- a/src/mgr/filemgr.cpp
++++ b/src/mgr/filemgr.cpp
+@@ -409,7 +409,7 @@
int FileMgr::copyFile(const char *sourceFile, const char *targetFile) {
@@ -12,69 +10,9 @@ Index: debian/src/mgr/filemgr.cpp
char buf[4096];
if ((sfd = ::open(sourceFile, O_RDONLY|O_BINARY, S_IREAD|S_IWRITE|S_IRGRP|S_IROTH)) < 1)
-Index: debian/src/utilfuns/zlib/untgz.c
-===================================================================
---- debian.orig/src/utilfuns/zlib/untgz.c
-+++ debian/src/utilfuns/zlib/untgz.c
-@@ -13,6 +13,8 @@
- #include <fcntl.h>
- #ifdef unix
- # include <unistd.h>
-+# include <sys/stat.h>
-+# include <sys/types.h>
- #else
- # include <direct.h>
- # include <io.h>
-@@ -80,7 +82,7 @@ union tar_buffer {
-
- enum { TGZ_EXTRACT = 0, TGZ_LIST };
-
--static char *TGZfname OF((const char *));
-+// static char *TGZfname OF((const char *));
- void TGZnotfound OF((const char *));
-
- int getoct OF((char *, int));
-@@ -105,22 +107,23 @@ static char *TGZprefix[] = { "\0", ".tgz
- /* Return the real name of the TGZ archive */
- /* or NULL if it does not exist. */
-
--static char *TGZfname OF((const char *fname))
--{
-- static char buffer[1024];
-- int origlen,i;
--
-- strcpy(buffer,fname);
-- origlen = strlen(buffer);
--
-- for (i=0; TGZprefix[i]; i++)
-- {
-- strcpy(buffer+origlen,TGZprefix[i]);
-- if (access(buffer,F_OK) == 0)
-- return buffer;
-- }
-- return NULL;
--}
-+// COMMENTED OUT 20090516 for SWORD
-+// static char *TGZfname OF((const char *fname))
-+// {
-+// static char buffer[1024];
-+// int origlen,i;
-+//
-+// strcpy(buffer,fname);
-+// origlen = strlen(buffer);
-+//
-+// for (i=0; TGZprefix[i]; i++)
-+// {
-+// strcpy(buffer+origlen,TGZprefix[i]);
-+// if (access(buffer,F_OK) == 0)
-+// return buffer;
-+// }
-+// return NULL;
-+// }
-
- /* error message for the filename */
-
-@@ -277,7 +280,7 @@ int untar (gzFile in, const char *dest)
+--- a/src/utilfuns/zlib/untgz.c
++++ b/src/utilfuns/zlib/untgz.c
+@@ -262,7 +262,7 @@
int remaining = 0;
FILE *outfile = NULL;
char fname[BLOCKSIZE];
@@ -83,11 +21,9 @@ Index: debian/src/utilfuns/zlib/untgz.c
while (1) {
len = gzread(in, &buffer, BLOCKSIZE);
-Index: debian/tests/testblocks.cpp
-===================================================================
---- debian.orig/tests/testblocks.cpp
-+++ debian/tests/testblocks.cpp
-@@ -29,14 +29,18 @@ using namespace sword;
+--- a/tests/testblocks.cpp
++++ b/tests/testblocks.cpp
+@@ -34,14 +34,18 @@
void addEntry(EntriesBlock *eb) {
string input;
string body;
@@ -111,7 +47,7 @@ Index: debian/tests/testblocks.cpp
}
while (input.compare("."));
std::cout << "Adding new entry. Index is: " << eb->addEntry(body.c_str()) << "\n\n";
-@@ -72,29 +76,33 @@ int main(int argc, char **argv) {
+@@ -77,29 +81,33 @@
EntriesBlock *eb = new EntriesBlock();
string input;
@@ -163,11 +99,9 @@ Index: debian/tests/testblocks.cpp
}
}
}
-Index: debian/utilities/stepdump.cpp
-===================================================================
---- debian.orig/utilities/stepdump.cpp
-+++ debian/utilities/stepdump.cpp
-@@ -158,33 +158,56 @@ int main(int argc, char **argv) {
+--- a/utilities/stepdump.cpp
++++ b/utilities/stepdump.cpp
+@@ -163,33 +163,56 @@
void readVersion(int fd, Version *versionRecord) {
@@ -235,7 +169,7 @@ Index: debian/utilities/stepdump.cpp
cout << "\tmodifiedBy: " << versionRecord->modifiedBy << "\n";
int skip = versionRecord->versionRecordSize - 16/*sizeof(struct Version*/;
-@@ -192,33 +215,49 @@ void readVersion(int fd, Version *versio
+@@ -197,33 +220,49 @@
if (skip) {
cout << "\nSkipping " << skip << " unknown bytes.\n";
char *skipbuf = new char[skip];
@@ -294,7 +228,7 @@ Index: debian/utilities/stepdump.cpp
cout << "\treserved2: " << viewableHeaderRecord->reserved2 << "\n";
int skip = viewableHeaderRecord->viewableHeaderRecordSize - 16/*sizeof(struct ViewableHeader)*/;
-@@ -226,18 +265,23 @@ void readViewableHeader(int fd, Viewable
+@@ -231,18 +270,23 @@
if (skip) {
cout << "\nSkipping " << skip << " unknown bytes.\n";
char *skipbuf = new char[skip];
@@ -320,7 +254,7 @@ Index: debian/utilities/stepdump.cpp
compress->zBuf(&size, *buf);
strcpy(*buf, compress->Buf());
-@@ -247,30 +291,41 @@ void readViewableBlockText(int fd, Viewa
+@@ -252,30 +296,41 @@
void readViewableBlock(int fd, ViewableBlock *vb) {
@@ -368,11 +302,9 @@ Index: debian/utilities/stepdump.cpp
(*buf)[headerControlWordAreaSize] = 0;
cout << "headerControlWordArea:\n" << *buf << "\n";
-Index: debian/utilities/treeidxutil.cpp
-===================================================================
---- debian.orig/utilities/treeidxutil.cpp
-+++ debian/utilities/treeidxutil.cpp
-@@ -53,27 +53,33 @@ void printLocalName(TreeKeyIdx *treeKey)
+--- a/utilities/treeidxutil.cpp
++++ b/utilities/treeidxutil.cpp
+@@ -58,27 +58,33 @@
void setLocalName(TreeKeyIdx *treeKey) {
@@ -412,7 +344,7 @@ Index: debian/utilities/treeidxutil.cpp
treeKey->append();
treeKey->setLocalName(buf);
treeKey->save();
-@@ -83,9 +89,11 @@ void appendSibbling(TreeKeyIdx *treeKey)
+@@ -88,9 +94,11 @@
void appendChild(TreeKeyIdx *treeKey) {
@@ -426,7 +358,7 @@ Index: debian/utilities/treeidxutil.cpp
treeKey->appendChild();
treeKey->setLocalName(buf);
treeKey->save();
-@@ -118,11 +126,13 @@ int main(int argc, char **argv) {
+@@ -123,11 +131,13 @@
TreeKeyIdx root = *treeKey;
std::string input;
@@ -442,11 +374,9 @@ Index: debian/utilities/treeidxutil.cpp
input = line;
if (input.length() > 0) {
switch (input[0]) {
-Index: debian/utilities/gbfidx.cpp
-===================================================================
---- debian.orig/utilities/gbfidx.cpp
-+++ debian/utilities/gbfidx.cpp
-@@ -53,7 +53,7 @@ char testmnt;
+--- a/utilities/gbfidx.cpp
++++ b/utilities/gbfidx.cpp
+@@ -55,7 +55,7 @@
int main(int argc, char **argv)
{
long pos, offset;
@@ -455,9 +385,9 @@ Index: debian/utilities/gbfidx.cpp
char startflag = 0;
short size;
-@@ -65,18 +65,30 @@ int main(int argc, char **argv)
- num1 = key1.Chapter();
- num2 = key1.Verse();
+@@ -67,18 +67,30 @@
+ num1 = key1.getChapter();
+ num2 = key1.getVerse();
pos = 0;
- write(bfp, &pos, 4); /* Book offset for testament intros */
+ w = write(bfp, &pos, 4); /* Book offset for testament intros */
@@ -492,7 +422,7 @@ Index: debian/utilities/gbfidx.cpp
while(!findbreak(fp, &offset, &num1, &num2, &rangemax, &size)) {
if (!startflag) {
-@@ -120,6 +132,7 @@ int main(int argc, char **argv)
+@@ -122,6 +134,7 @@
void writeidx(VerseKey &key1, VerseKey &key2, VerseKey &key3, long offset, short size)
{
@@ -500,9 +430,9 @@ Index: debian/utilities/gbfidx.cpp
long pos;
short tmp;
-@@ -127,26 +140,48 @@ void writeidx(VerseKey &key1, VerseKey &
- if (key1.Verse() == 1) { // new chapter
- if (key1.Chapter() == 1) { // new book
+@@ -129,26 +142,48 @@
+ if (key1.getVerse() == 1) { // new chapter
+ if (key1.getChapter() == 1) { // new book
pos = lseek(cfp, 0, SEEK_CUR);
- write(bfp, &pos, 4);
+ w = write(bfp, &pos, 4);
@@ -560,11 +490,9 @@ Index: debian/utilities/gbfidx.cpp
}
}
}
-Index: debian/utilities/genbookutil.cpp
-===================================================================
---- debian.orig/utilities/genbookutil.cpp
-+++ debian/utilities/genbookutil.cpp
-@@ -53,9 +53,11 @@ void printLocalName(TreeKeyIdx *treeKey)
+--- a/utilities/genbookutil.cpp
++++ b/utilities/genbookutil.cpp
+@@ -58,9 +58,11 @@
void setLocalName(TreeKeyIdx *treeKey) {
@@ -578,7 +506,7 @@ Index: debian/utilities/genbookutil.cpp
SWBuf name = buf;
treeKey->setLocalName(name.trim());
treeKey->save();
-@@ -63,18 +65,22 @@ void setLocalName(TreeKeyIdx *treeKey) {
+@@ -68,18 +70,22 @@
void gotoPath(TreeKeyIdx *treeKey) {
@@ -605,7 +533,7 @@ Index: debian/utilities/genbookutil.cpp
SWBuf path = buf;
treeKey->assureKeyPath(path.trim());
}
-@@ -91,10 +97,12 @@ void setEntryText(RawGenBook *book) {
+@@ -96,10 +102,12 @@
SWBuf body;
TreeKeyIdx *treeKey = (TreeKeyIdx *)(SWKey *)(*book);
if (treeKey->getOffset()) {
@@ -620,7 +548,7 @@ Index: debian/utilities/genbookutil.cpp
SWBuf text = buf;
text.trim();
if ((text[0] == '.') && (text[1] == 0))
-@@ -111,9 +119,11 @@ void setEntryText(RawGenBook *book) {
+@@ -116,9 +124,11 @@
void appendSibbling(TreeKeyIdx *treeKey) {
if (treeKey->getOffset()) {
@@ -634,7 +562,7 @@ Index: debian/utilities/genbookutil.cpp
SWBuf name = buf;
treeKey->append();
treeKey->setLocalName(name.trim());
-@@ -124,9 +134,11 @@ void appendSibbling(TreeKeyIdx *treeKey)
+@@ -129,9 +139,11 @@
void appendChild(TreeKeyIdx *treeKey) {
@@ -648,7 +576,7 @@ Index: debian/utilities/genbookutil.cpp
SWBuf name = buf;
treeKey->appendChild();
treeKey->setLocalName(name.trim());
-@@ -168,11 +180,13 @@ int main(int argc, char **argv) {
+@@ -173,11 +185,13 @@
treeKey = (TreeKeyIdx *)(SWKey *)(*book);
SWBuf input;
@@ -664,11 +592,9 @@ Index: debian/utilities/genbookutil.cpp
input = line;
input.trim();
if (input.length() > 0) {
-Index: debian/utilities/vpl2mod.cpp
-===================================================================
---- debian.orig/utilities/vpl2mod.cpp
-+++ debian/utilities/vpl2mod.cpp
-@@ -72,14 +72,18 @@ char readline(int fd, char **buf) {
+--- a/utilities/vpl2mod.cpp
++++ b/utilities/vpl2mod.cpp
+@@ -76,14 +76,18 @@
break;
}
@@ -690,11 +616,9 @@ Index: debian/utilities/vpl2mod.cpp
(*buf)[size] = 0;
// clean up any trailing junk on buf
-Index: debian/utilities/installmgr.cpp
-===================================================================
---- debian.orig/utilities/installmgr.cpp
-+++ debian/utilities/installmgr.cpp
-@@ -69,8 +69,10 @@ virtual bool isUserDisclaimerConfirmed()
+--- a/utilities/installmgr.cpp
++++ b/utilities/installmgr.cpp
+@@ -74,8 +74,10 @@
cout << "then type yes at the prompt\n\n";
cout << "enable? [no] ";
@@ -707,11 +631,9 @@ Index: debian/utilities/installmgr.cpp
confirmed = (!strcmp(prompt, "yes\n"));
cout << "\n";
}
-Index: debian/utilities/step2vpl.cpp
-===================================================================
---- debian.orig/utilities/step2vpl.cpp
-+++ debian/utilities/step2vpl.cpp
-@@ -223,93 +223,169 @@ int main(int argc, char **argv) {
+--- a/utilities/step2vpl.cpp
++++ b/utilities/step2vpl.cpp
+@@ -228,93 +228,169 @@
void readVersion(int fd, Version *versionRecord) {
@@ -916,7 +838,7 @@ Index: debian/utilities/step2vpl.cpp
compress->zBuf(&size, *buf);
strcpy(*buf, compress->Buf());
-@@ -317,35 +393,53 @@ void readViewableBlockText(int fd, Viewa
+@@ -322,35 +398,53 @@
void readViewableBlock(int fd, ViewableBlock *vb) {
@@ -977,7 +899,7 @@ Index: debian/utilities/step2vpl.cpp
VSyncPoint vSyncPoint;
lseek(fdvsync, vSyncBooksInfo->offset, SEEK_SET);
-@@ -356,9 +450,15 @@ void displayBook(int fdbook, int fdviewa
+@@ -361,9 +455,15 @@
char *sectionName;
char *verseText;
@@ -996,7 +918,7 @@ Index: debian/utilities/step2vpl.cpp
vSyncPoint.offset = SECTIONSLEVELSTART + (vSyncPoint.offset * SECTIONSLEVELSIZE);
lseek(fdsections, vSyncPoint.offset, SEEK_SET);
readSectionLevelInfo(fdsections, &sectionLevelInfo);
-@@ -413,26 +513,50 @@ void extractVerseText(int fdviewable, in
+@@ -418,26 +518,50 @@
void readSectionName(int fd, SectionLevelInfo *sli, char **name) {
@@ -1058,11 +980,9 @@ Index: debian/utilities/step2vpl.cpp
}
void cleanBuf(char *buf) {
-Index: debian/utilities/cipherraw.cpp
-===================================================================
---- debian.orig/utilities/cipherraw.cpp
-+++ debian/utilities/cipherraw.cpp
-@@ -48,7 +48,7 @@ int main(int argc, char **argv) {
+--- a/utilities/cipherraw.cpp
++++ b/utilities/cipherraw.cpp
+@@ -53,7 +53,7 @@
SWCipher *zobj;
VerseKey key;
RawVerse *rawdrv;
@@ -1071,7 +991,7 @@ Index: debian/utilities/cipherraw.cpp
long tmpoff = 0, offset, loffset = 0, lzoffset = 0;
unsigned short size, lsize = 0, lzsize;
char *tmpbuf;
-@@ -74,10 +74,18 @@ int main(int argc, char **argv) {
+@@ -79,10 +79,18 @@
delete [] tmpbuf;
printf("\n");
@@ -1092,57 +1012,46 @@ Index: debian/utilities/cipherraw.cpp
+ if (w < 0)
+ perror("ERROR: write failed in main");
- key.AutoNormalize(0);
- key.Headings(1);
-@@ -89,8 +97,13 @@ int main(int argc, char **argv) {
+ key.setAutoNormalize(false);
+ key.setIntros(true);
+@@ -94,8 +102,10 @@
printf("using previous offset,size %d\n", size);
- offset = lseek(oxfd[key.Testament() - 1], 0, SEEK_CUR);
+ offset = lseek(oxfd[key.getTestament() - 1], 0, SEEK_CUR);
printf("%ld %ld %d \n", offset, lzoffset, lzsize);
-- write(oxfd[key.Testament() - 1], &lzoffset, 4);
-- write(oxfd[key.Testament() - 1], &lzsize, 2);
-+ w = write(oxfd[key.Testament() - 1], &lzoffset, 4);
-+ if (w < 0)
-+ perror("ERROR: write failed in main");
-+
-+ w = write(oxfd[key.Testament() - 1], &lzsize, 2);
-+ if (w < 0)
-+ perror("ERROR: write failed in main");
+- write(oxfd[key.getTestament() - 1], &lzoffset, 4);
+- write(oxfd[key.getTestament() - 1], &lzsize, 2);
++ if (write(oxfd[key.getTestament() - 1], &lzoffset, 4) < 0)
++ perror("ERROR: write failed in main");
++ if (write(oxfd[key.getTestament() - 1], &lzsize, 2) < 0)
++ perror("ERROR: write failed in main");
}
else {
lsize = size;
-@@ -107,13 +120,23 @@ int main(int argc, char **argv) {
- offset = lseek(ofd[key.Testament() - 1], 0, SEEK_CUR);
- tmpoff = lseek(oxfd[key.Testament() - 1], 0, SEEK_CUR);
+@@ -112,13 +122,17 @@
+ offset = lseek(ofd[key.getTestament() - 1], 0, SEEK_CUR);
+ tmpoff = lseek(oxfd[key.getTestament() - 1], 0, SEEK_CUR);
printf("%s: (%ld) NEW offset: %ld; size: %d\n", (const char *)key, tmpoff, offset, size);
-- write(oxfd[key.Testament() - 1], &offset, 4);
-+ w = write(oxfd[key.Testament() - 1], &offset, 4);
-+ if (w < 0)
-+ perror("ERROR: write failed in main");
-+
+- write(oxfd[key.getTestament() - 1], &offset, 4);
++ if (write(oxfd[key.getTestament() - 1], &offset, 4) < 0)
++ perror("ERROR: write failed in main");
unsigned long ulSize = size;
- if (size)
-- write(ofd[key.Testament() - 1], zobj->cipherBuf(&ulSize), size);
+- write(ofd[key.getTestament() - 1], zobj->cipherBuf(&ulSize), size);
+ if (size) {
-+ w = write(ofd[key.Testament() - 1], zobj->cipherBuf(&ulSize), size);
-+ if (w < 0)
-+ perror("ERROR: write failed in main");
-+ }
-+
++ if (write(ofd[key.getTestament() - 1], zobj->cipherBuf(&ulSize), size) < 0)
++ perror("ERROR: write failed in main");
++ }
size = (unsigned int)ulSize;
lzoffset = offset;
-- write(oxfd[key.Testament() - 1], &size, 2);
-+ w = write(oxfd[key.Testament() - 1], &size, 2);
-+ if (w < 0)
-+ perror("ERROR: write failed in main");
-+
+- write(oxfd[key.getTestament() - 1], &size, 2);
++ if (write(oxfd[key.getTestament() - 1], &size, 2) < 0)
++ perror("ERROR: write failed in main");
lzsize = size;
}
}
-Index: debian/utilities/lexdump.c
-===================================================================
---- debian.orig/utilities/lexdump.c
-+++ debian/utilities/lexdump.c
-@@ -40,7 +40,7 @@
+--- a/utilities/lexdump.c
++++ b/utilities/lexdump.c
+@@ -45,7 +45,7 @@
int main(int argc, char **argv) {
char *tmpbuf;
@@ -1151,7 +1060,7 @@ Index: debian/utilities/lexdump.c
long offset;
unsigned int size;
char datbuf[255];
-@@ -59,11 +59,17 @@ int main(int argc, char **argv) {
+@@ -64,11 +64,17 @@
offset = atoi(argv[2]) * 6;
lseek(idxfd, offset, SEEK_SET);
@@ -1172,16 +1081,3 @@ Index: debian/utilities/lexdump.c
datbuf[40] = 0;
printf("%s\n", datbuf);
close(datfd);
-Index: debian/tests/ciphertest.cpp
-===================================================================
---- debian.orig/tests/ciphertest.cpp
-+++ debian/tests/ciphertest.cpp
-@@ -30,7 +30,7 @@ int main(int argc, char **argv) {
- }
-
-
-- int encipher = atoi(argv[2]);
-+ long encipher = atoi(argv[2]);
-
- SWFilter *filter = new CipherFilter(argv[1]);
-
diff --git a/debian/patches/13_curl.diff b/debian/patches/13_curl.diff
index 2d3fc68..8cd9df8 100644
--- a/debian/patches/13_curl.diff
+++ b/debian/patches/13_curl.diff
@@ -7,7 +7,7 @@ message:
--- a/src/mgr/curlftpt.cpp
+++ b/src/mgr/curlftpt.cpp
-@@ -180,6 +180,9 @@
+@@ -186,6 +186,9 @@
// it seems CURL tries to use this option data later for some reason, so we unset here
curl_easy_setopt(session, CURLOPT_PROGRESSDATA, (void*)NULL);
diff --git a/debian/patches/dso-missing-shared.patch b/debian/patches/dso-missing-shared.patch
index 94b540b..1b9c1b4 100644
--- a/debian/patches/dso-missing-shared.patch
+++ b/debian/patches/dso-missing-shared.patch
@@ -2,9 +2,9 @@ Description: clucene-shared is missing
Author: Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>
Bug-Debian: http://bugs.debian.org/707537
---- sword-1.6.2+dfsg.orig/CMakeLists.txt
-+++ sword-1.6.2+dfsg/CMakeLists.txt
-@@ -162,7 +162,7 @@ IF(WITH_CURL)
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -190,7 +190,7 @@
ENDIF(WITH_CURL)
IF(WITH_CLUCENE)
INCLUDE_DIRECTORIES(${CLUCENE_INCLUDE_DIR})
diff --git a/debian/patches/no-included-zconf.h.diff b/debian/patches/no-included-zconf.h.diff
index 8286ead..5205051 100644
--- a/debian/patches/no-included-zconf.h.diff
+++ b/debian/patches/no-included-zconf.h.diff
@@ -1,5 +1,5 @@
---- a/include/zconf.h 2005-01-01 05:42:26.000000000 +0100
-+++ /dev/null 2012-07-03 16:36:49.000000000 +0200
+--- a/include/zconf.h
++++ /dev/null
@@ -1,279 +0,0 @@
-/* zconf.h -- configuration of the zlib compression library
- * Copyright (C) 1995-2002 Jean-loup Gailly.
@@ -280,9 +280,9 @@
-#endif
-
-#endif /* _ZCONF_H */
---- a/cmake/sources.cmake-old 2013-08-04 17:07:19.448157271 +0200
-+++ b/cmake/sources.cmake 2013-08-04 17:07:29.192157017 +0200
-@@ -383,7 +383,6 @@
+--- a/cmake/sources.cmake
++++ b/cmake/sources.cmake
+@@ -394,7 +394,6 @@
include/versekey.h
include/versetreekey.h
include/zcom.h
diff --git a/debian/patches/series b/debian/patches/series
index 0b77828..f081236 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,12 +1,12 @@
12_fix_compiler_warnings.diff
13_curl.diff
-16_gcc4.6_sword.patch
-2631_fix_curl.patch
-cmake_backport.patch
-icu_in_soname.patch
-fix-ftbfs-gcc4.7.diff
-fix-ftbfs-icu.patch
-2661.patch
+#16_gcc4.6_sword.patch
+#2631_fix_curl.patch
+#cmake_backport.patch
+#icu_in_soname.patch
+#fix-ftbfs-gcc4.7.diff
+#fix-ftbfs-icu.patch
+#2661.patch
multiarch-clucene.patch
no-included-zconf.h.diff
dso-missing-shared.patch