summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorRoberto C. Sanchez <roberto@connexer.com>2014-03-29 10:53:52 -0400
committerRoberto C. Sanchez <roberto@connexer.com>2014-03-29 10:53:52 -0400
commit148bd343f3e7e32d141f66b5b5c9b98b2975b0b3 (patch)
tree31078963b85110d57310759016e60e8d26ccb1e6 /scripts
parent8c8aa6b07e595cfac56838b5964ab3e96051f1b2 (diff)
Imported Upstream version 1.5.8
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/backupmake.sh5
-rwxr-xr-xscripts/burncd1
-rwxr-xr-xscripts/demotar1
-rwxr-xr-xscripts/disttar7
-rwxr-xr-xscripts/dlltar1
-rwxr-xr-xscripts/eastonstar1
-rwxr-xr-xscripts/mhctar1
-rwxr-xr-xscripts/mkcd5
-rwxr-xr-xscripts/mkswordbase14
-rwxr-xr-xscripts/mkswordbase242
-rwxr-xr-xscripts/mkswordtar16
-rwxr-xr-xscripts/restoremake.sh5
-rwxr-xr-xscripts/sapphire.cpp73
-rwxr-xr-xscripts/svetar1
-rwxr-xr-xscripts/swordenv1
-rwxr-xr-xscripts/swtxtdsp.bat2
-rwxr-xr-xscripts/vinestar1
-rwxr-xr-xscripts/webtar1
18 files changed, 0 insertions, 178 deletions
diff --git a/scripts/backupmake.sh b/scripts/backupmake.sh
deleted file mode 100755
index 8c4db3e..0000000
--- a/scripts/backupmake.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-cp Makefile Makefile.sw
-cp lib/Makefile lib/Makefile.sw
-cp tests/Makefile tests/Makefile.sw
-cp utilities/Makefile utilities/Makefile.sw
diff --git a/scripts/burncd b/scripts/burncd
deleted file mode 100755
index bdd8b37..0000000
--- a/scripts/burncd
+++ /dev/null
@@ -1 +0,0 @@
-cdrecord -v speed=2 dev=0,0 /mnt/server/space/im.iso
diff --git a/scripts/demotar b/scripts/demotar
deleted file mode 100755
index 9093b5b..0000000
--- a/scripts/demotar
+++ /dev/null
@@ -1 +0,0 @@
-cd /dosc/usr/troy/src; tar -v -c -p -s -z -f ~/src/multimo4.tgz sword/examples/windoze/delphi20/multimo4/multimod.exe
diff --git a/scripts/disttar b/scripts/disttar
deleted file mode 100755
index 70e1a1d..0000000
--- a/scripts/disttar
+++ /dev/null
@@ -1,7 +0,0 @@
-REV=`cd ..;basename \`pwd ..\`|cut -d\- -f2`
-cd /; tar cfvz sword-$REV.i386.tar.gz /etc/sword.conf /usr/lib/libsword.* /usr/include/sword/* /usr/bin/cheatah /usr/doc/sword/ /usr/share/sword/mods.d/globals.conf
-
-echo
-echo Did you set legalexport := yes
-echo did you set buildshare := yes
-echo
diff --git a/scripts/dlltar b/scripts/dlltar
deleted file mode 100755
index a93fb3c..0000000
--- a/scripts/dlltar
+++ /dev/null
@@ -1 +0,0 @@
-cp /dosc/winnt/system32/sword32.dll ../bin; cd /dosc/usr/troy/src; tar -v -c -p -s -z -f ~/src/dlls.tgz sword/bin/sword32.dll
diff --git a/scripts/eastonstar b/scripts/eastonstar
deleted file mode 100755
index ac3d71a..0000000
--- a/scripts/eastonstar
+++ /dev/null
@@ -1 +0,0 @@
-cd /dosc/usr/troy/src/; tar -v -c -p -s -z -f ~/src/eastons.tgz sword/modules/lexdict/rawld/eastons
diff --git a/scripts/mhctar b/scripts/mhctar
deleted file mode 100755
index eea59c4..0000000
--- a/scripts/mhctar
+++ /dev/null
@@ -1 +0,0 @@
-cd /dosc/usr/troy/src/; tar -v -c -p -s -z -f ~/src/mhc.tgz sword/modules/comments/rawcom/mhc
diff --git a/scripts/mkcd b/scripts/mkcd
deleted file mode 100755
index c1a9ee0..0000000
--- a/scripts/mkcd
+++ /dev/null
@@ -1,5 +0,0 @@
-REV=`cd ..;basename \`pwd ..\`|cut -d\- -f2`
-chmod +x *
-chmod +x ../apps/X11/cheatah/configure
-chmod +x ../apps/X11/cheatah/missing
-cd ../../..; mkisofs -a -J -o -l -L ./im.iso -r -v -V "SWORD_20000428" /mnt/server/space/swordiso/
diff --git a/scripts/mkswordbase b/scripts/mkswordbase
deleted file mode 100755
index 93f5931..0000000
--- a/scripts/mkswordbase
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh
-cd ..
-make distclean
-./usrinst.sh
-make
-
-echo
-echo Please execute the following commands
-echo su
-echo cd ..
-echo "make install; make distclean; exit"
-echo ./mkswordbase2
-echo
-
diff --git a/scripts/mkswordbase2 b/scripts/mkswordbase2
deleted file mode 100755
index 0609181..0000000
--- a/scripts/mkswordbase2
+++ /dev/null
@@ -1,42 +0,0 @@
-#!/bin/sh
-mkdir /tmp/$$
-cd /tmp/$$
-mkdir etc
-echo [Install] > etc/sword.conf
-echo DataPath=/usr/share/sword >> etc/sword.conf
-echo >> etc/sword.conf
-
-mkdir usr
-mkdir usr/include
-cp -r /usr/include/sword usr/include/sword
-
-mkdir usr/lib
-cp -r /usr/lib/libsword.a /usr/lib/libsword.la usr/lib
-
-mkdir usr/share
-mkdir usr/share/sword
-mkdir usr/share/sword/mods.d
-
-echo [Globals] > usr/share/sword/mods.d/globals.conf
-echo >> usr/share/sword/mods.d/globals.conf
-echo >> usr/share/sword/mods.d/globals.conf
-
-cp -r /usr/share/sword/locales.d usr/share/sword/locales.d
-
-mkdir usr/share/doc
-mkdir usr/share/doc/sword
-
-cd -
-cd ..
-cp -r doc/* /tmp/$$/usr/share/doc/sword/
-cp -r ChangeLog README INSTALL LICENSE examples samples /tmp/$$/usr/share/doc/sword/
-cd -
-cd /tmp/$$
-find . -name CVS -type d -exec rm -rf {} \;
-tar czfv swordbase.tar.gz *
-cd -
-mv /tmp/$$/swordbase.tar.gz ../../
-rm -rf /tmp/$$
-
-cd ../..
-echo swordbase.tar.gz in `pwd`
diff --git a/scripts/mkswordtar b/scripts/mkswordtar
deleted file mode 100755
index 28e4d14..0000000
--- a/scripts/mkswordtar
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-REV=`cd ..;basename \`pwd ..\`|cut -d\- -f2`
-SWORDVER=`grep "define SWORDVER" ../include/swversion.h |cut -f2 -d"\""`
-
-if test `echo $REV` == `echo $SWORDVER`; then
- chmod +x *
- chmod +x ../apps/X11/cheatah/configure
- chmod +x ../apps/X11/cheatah/missing
- #cp sapphire.cpp ../src/modules/common
- cd ..; ./autogen.sh
- cd ..; tar -v -c -p -s -z --exclude sword-$REV/bin -X sword-$REV/modlist -f sword-$REV.tar.gz sword-$REV/*
-else
- echo $"Directory version is $REV, but swversion.h has $SWORDVER"
- exit 1
-
-fi
diff --git a/scripts/restoremake.sh b/scripts/restoremake.sh
deleted file mode 100755
index e4bd939..0000000
--- a/scripts/restoremake.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-cp Makefile.sw Makefile
-cp lib/Makefile.sw lib/Makefile
-cp tests/Makefile.sw tests/Makefile
-cp utilities/Makefile.sw utilities/Makefile
diff --git a/scripts/sapphire.cpp b/scripts/sapphire.cpp
deleted file mode 100755
index 63968a4..0000000
--- a/scripts/sapphire.cpp
+++ /dev/null
@@ -1,73 +0,0 @@
-/******************************************************************************
- *
- * Placeholder for the REAL SAPPHIRE II Stream Cipher Files
- *
- * The SAPPHIRE II package may be obtained from within the United States or
- * Canada from:
- *
- * http://cryptography.org/cgi-bin/crypto.cgi/libraries/sapphire.zip
- *
- *
- * These files must be placed accordingly:
- *
- * .../sword/include/sapphire.h
- * .../sword/src/modules/common/sapphire.cpp
- *
- * If you are outside of these countries, you will have to obtain this package
- * elsewhere.
- *
- */
-
-
-#ifdef UNIX
-#include <memory.h>
-#include <unistd.h>
-#else
-#include <mem.h>
-#endif
-#include "sapphire.h"
-
-unsigned char sapphire::keyrand(int limit,
- unsigned char *user_key,
- unsigned char keysize,
- unsigned char *rsum,
- unsigned *keypos)
- {
- return keysize;
- }
-
-void sapphire::initialize(unsigned char *key, unsigned char keysize)
- {
- }
-
-void sapphire::hash_init(void)
- {
- }
-
-sapphire::sapphire(unsigned char *key, unsigned char keysize)
- {
- }
-
-void sapphire::burn(void)
- {
- }
-
-sapphire::~sapphire()
- {
- }
-
-unsigned char sapphire::encrypt(unsigned char b)
- {
- return b;
- }
-
-unsigned char sapphire::decrypt(unsigned char b)
- {
- return b;
- }
-
-void sapphire::hash_final(unsigned char *hash, // Destination
- unsigned char hashlength) // Size of hash.
- {
- }
-
diff --git a/scripts/svetar b/scripts/svetar
deleted file mode 100755
index f6fad43..0000000
--- a/scripts/svetar
+++ /dev/null
@@ -1 +0,0 @@
-cd /dosc/usr/troy/src/; tar -v -c -p -s -z -f ~/src/sve.tgz sword/modules/texts/rawtext/sve sword/modules/texts/rawtext/svetxidx.c
diff --git a/scripts/swordenv b/scripts/swordenv
deleted file mode 100755
index 924c739..0000000
--- a/scripts/swordenv
+++ /dev/null
@@ -1 +0,0 @@
-export PATH=`dirname \`pwd\``/bin:$PATH
diff --git a/scripts/swtxtdsp.bat b/scripts/swtxtdsp.bat
deleted file mode 100755
index 5cb4bf5..0000000
--- a/scripts/swtxtdsp.bat
+++ /dev/null
@@ -1,2 +0,0 @@
-pkzip -r -P -a ..\tmp\swtxtdsp.zip \sword\frontend\windoze\delphi20\swtxtdsp\*.*
-
diff --git a/scripts/vinestar b/scripts/vinestar
deleted file mode 100755
index 2783b7d..0000000
--- a/scripts/vinestar
+++ /dev/null
@@ -1 +0,0 @@
-cd /dosc/usr/troy/src/; tar -v -c -p -s -z -f ~/src/vines.tgz sword/modules/lexdict/rawld/vines
diff --git a/scripts/webtar b/scripts/webtar
deleted file mode 100755
index db263f7..0000000
--- a/scripts/webtar
+++ /dev/null
@@ -1 +0,0 @@
-cd /dosc/usr/troy/src/; tar -v -c -p -s -z -f ~/src/webster.tgz sword/modules/texts/rawtext/webster