summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRoberto C. Sanchez <roberto@connexer.com>2014-03-29 10:54:02 -0400
committerRoberto C. Sanchez <roberto@connexer.com>2014-03-29 10:54:02 -0400
commit936d9e8484ff73282c8c0a277310d1ffdde86e10 (patch)
tree084d6d2e50f188b0e9c00c109a935efa6ad665fc /tests/Makefile.am
parent71a39f4652cd51df814c930dd268f3c9ad2aee86 (diff)
Imported Upstream version 1.6.1+dfsg
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am18
1 files changed, 11 insertions, 7 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 44d6c00..afdf311 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,15 +1,18 @@
AUTOMAKE_OPTIONS = 1.6
INCLUDES = -I $(top_srcdir)/include
+if USE_INTERNAL_REGEX
+INCLUDES += -I$(top_srcdir)/include/internal/regex
+endif
LDADD = $(top_builddir)/lib/libsword.la
SUBDIRS = cppunit
-noinst_PROGRAMS = ciphertest keytest mgrtest parsekey versekeytest vtreekeytest versemgrtest listtest casttest \
+noinst_PROGRAMS = utf8norm ciphertest keytest mgrtest parsekey versekeytest vtreekeytest versemgrtest listtest casttest \
modtest compnone complzss localetest introtest indextest configtest keycast \
romantest testblocks filtertest rawldidxtest lextest swaptest \
- swbuftest xmltest webiftest
+ swbuftest xmltest webiftest striptest
-if ICU
+if HAVE_ICU
ICUPROG = icutest translittest tlitmgrtest
else
ICUPROG =
@@ -17,14 +20,13 @@ endif
noinst_PROGRAMS += $(ICUPROG)
-if ICU
+if HAVE_ICU
icutest_SOURCES = icutest.cpp
translittest_SOURCES = translittest.cpp
tlitmgrtest_SOURCES = tlitmgrtest.cpp
-#tlitmgrtest_LDADD = -lustdio
endif
-if ZLIB
+if HAVE_LIBZ
ZLIBPROG = compzip
else
ZLIBPROG =
@@ -32,13 +34,14 @@ endif
noinst_PROGRAMS += $(ZLIBPROG)
-if ZLIB
+if HAVE_LIBZ
compzip_SOURCES = compzip.cpp
endif
keytest_SOURCES = keytest.cpp
mgrtest_SOURCES = mgrtest.cpp
ciphertest_SOURCES = ciphertest.cpp
+utf8norm_SOURCES = utf8norm.cpp
parsekey_SOURCES = parsekey.cpp
versekeytest_SOURCES = versekeytest.cpp
vtreekeytest_SOURCES = vtreekeytest.cpp
@@ -61,6 +64,7 @@ rawldidxtest_SOURCES = rawldidxtest.cpp
swaptest_SOURCES = swaptest.cpp
swbuftest_SOURCES = swbuftest.cpp
webiftest_SOURCES = webiftest.cpp
+striptest_SOURCES = striptest.cpp
xmltest_SOURCES = xmltest.cpp